Jump to content


Photo

Schedule does not work with unicode chare

utf

  • Please log in to reply
2 replies to this topic

#1 edge67

edge67
  • Members
  • 2 posts

Posted 26 January 2012 - 08:34 AM

Smartftp 4.0.1231

Does the schedule transfer not work with unicode charaters (russian)?
Manually i can transfer files with russian filenames from and to a ftp server.
As soon as i automat this with the schedule transfers it fails because it tries to copy ?????? ??? ?? files.

Again manually no problems. (code page is set to 650001 (UTF-8))


[09:31:22] Operation Begin
[09:31:22] MLST ???????? ?????? ??????????.txt
[09:31:22] 450 File action is not taken.
[09:31:22] TYPE I
[09:31:22] 200 Command OK.
[09:31:22] SIZE ???????? ?????? ??????????.txt
[09:31:22] 550 Requested action not taken. File unavailable.
[09:31:22] File exist check failed. File not found or permission denied.
[09:31:22] TYPE U
[09:31:22] 504 Command not implemented for that parameter.
[09:31:22] MLST ???????? ?????? ??????????.txt
[09:31:22] 450 File action is not taken.
[09:31:22] MDTM ???????? ?????? ??????????.txt
[09:31:22] 550 Requested action not taken. File unavailable.
[09:31:22] STAT ???????? ?????? ??????????.txt
[09:31:22] 500 Syntax error, command unrecognized.
[09:31:22] Transfer failed.
[09:31:22] Operation End

#2 mb

mb

    Developer

  • Administrators
  • 11528 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 26 January 2012 - 05:24 PM

Do not change the transfer type to Unicode. Set the transfer type to Binary.
Contact support: https://www.smartftp...support/kb/2653

#3 edge67

edge67
  • Members
  • 2 posts

Posted 27 January 2012 - 12:11 PM

Thanks.

It is solved, problem is on the remote ftp server.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users