Jump to content


Photo

Scheduled Delete keeps retrying


  • Please log in to reply
6 replies to this topic

#1 dph01

dph01
  • Members
  • 5 posts
  • Gender:
    Male

Posted 28 October 2011 - 11:16 AM

Hi,

I'm evaluating the free SmartFTP at the moment with a view to using it on one of our production projects, however and I'm having a problem with a scheduled Delete job.

The job goes into the Transfer Queue OK but it just sits there with a status of e.g. 'Retry at 12:02:46', and time updates every 30 seconds.

Double-clicking on the queue entry gives the following:


[12:01:45] Operation Begin
[12:01:45] Resolving source path.
[12:01:45] SIZE timelinetest
[12:01:46] 550 Can't check for file existence
[12:01:46] Operation End

I can manually delete the file through the remote browser window.

Is there anything that I might have missed in the setup of the scheduled task? The XML export of the job is:


<!--?xml version="1.0"?-->
<scheduleitems clsid="{9E01C548-1E53-4EC5-9AB9-80BA97266EA5}">
<item clsid="{1661ECCB-8B40-4BC5-B486-51B287896B1B}">
<id>{268A3168-8181-4556-9455-FB4B914AEFFB}</id>
<name>get from businessdynamite</name>
<lastruntime>129642733056441892</lastruntime>
<lastrunresult>0</lastrunresult>
<created>129642674291661910</created>
<actions clsid="{D83B4DD2-1763-4BBB-8931-8EC781BAB25E}">
<action clsid="{EBB2D70B-3677-421E-AE8F-2F181F233E58}">
<item>
<version>4</version>
<id>{3613F2A5-4B4B-43A7-A8E0-30526918C788}</id>
<type>0</type>
<time>0</time>
<timeprecision>0</timeprecision>
<operation>3</operation>
<synchronization>1</synchronization>
<state>1</state>
<fileexistaction>1</fileexistaction>
<transfertype>1</transfertype>
<source>
<type>2</type>
<favoriteid>{D86A2366-7C4E-4BC5-BE8D-56EA65ADF7D4}</favoriteid>
<path>timelinetest</path>

<destination>
<type>1</type>
<path>J:\Docs\personal\timeline\ftptestdest</path>
</destination>
</item>
</action>
</actions>
<triggers>
<trigger clsid="{8428D9B1-0B74-4879-80D1-797848330314}">
<version>2</version>
<recurrence>1</recurrence>
<starttime>2011-10-28T10:24:00Z</starttime>
<nextruntime>2011-10-28T10:45:00Z</nextruntime>
<enable>0</enable>
<utc>0</utc>
<recurrencetimeinterval>P0000-00-00T00:01:00
</recurrencetimeinterval>
</trigger>
</triggers>
</item>
</scheduleitems>

Thanks

Damian.

#2 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 28 October 2011 - 11:21 AM

I think the transfer queue item inside the schedule task is wrong. E.g.
<path>timelinetest</path>
This looks wrong.

Try to create a new schedule for a delete item.

#3 dph01

dph01
  • Members
  • 5 posts
  • Gender:
    Male

Posted 28 October 2011 - 12:02 PM

Hi,
Thanks for the quick reply.

The <path>timelinetest</path> refers to the directory on the FTP server whose contents I want to delete - isn't that a legitimate setting? What do you think it should look like?

I'm wondering if you're referring to the 'destination' component of the xml file - that's there because I previously set up a 'move' task, which had the same problems, and in the process of narrowing down onto the issue I changed the task to a 'delete'.

Anyway, I created a new delete task from scratch and the same problem occurs. Here is the xml file for the new task:


<?xml version="1.0"?>
<ScheduleItems clsid="{9E01C548-1E53-4EC5-9AB9-80BA97266EA5}">
<Item clsid="{1661ECCB-8B40-4BC5-B486-51B287896B1B}">
<Id>{351D31D2-2994-4A10-8295-A57B481F4380}</Id>
<Name>Delete</Name>
<LastRunTime>129642760846402971</LastRunTime>
<LastRunResult>0</LastRunResult>
<Created>129642760096988870</Created>
<Actions clsid="{D83B4DD2-1763-4BBB-8931-8EC781BAB25E}">
<Action clsid="{EBB2D70B-3677-421E-AE8F-2F181F233E58}">
<Item>
<Version>4</Version>
<Id>{17CD7BEC-AC63-4E63-AB31-2F623FEBAED8}</Id>
<Type>0</Type>
<Time>0</Time>
<TimePrecision>0</TimePrecision>
<Operation>3</Operation>
<Synchronization>1</Synchronization>
<State>1</State>
<Source>
<Type>2</Type>
<FavoriteId>{D86A2366-7C4E-4BC5-BE8D-56EA65ADF7D4}</FavoriteId>
<Path>timelinetest</Path>
</Source>
</Item>
</Action>
</Actions>
</Item>
</ScheduleItems>

Thanks again for your help.

Damian.

#4 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 28 October 2011 - 12:17 PM

It still looks incorrect to me. I recommend that you contact technical support which is available for licensed customers. They can assist you on how to create the delete task.

#5 dph01

dph01
  • Members
  • 5 posts
  • Gender:
    Male

Posted 28 October 2011 - 01:19 PM

Hi,

Ah, that's a shame that help is only available for licensed customers. I was hoping to be able to evaluate the product before I bought it.

Do you know if there any documentation on how to set up a delete & move scheduled jobs so I can check my setup? I had a look in the Knowledge Base but couldn't see anything.

Thanks

Damian

#6 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 28 October 2011 - 01:54 PM

I can guarantee you that technical support is able to resolve your problem. Unfortunately we cannot offer free support for advanced topics during the trial period. Please remember that we offer our product at low cost where it is impossible to offer professional services during the trial period for free.

#7 dph01

dph01
  • Members
  • 5 posts
  • Gender:
    Male

Posted 29 October 2011 - 05:20 AM

ok thanks.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users