Jump to content


Photo

Cannot setup a differnt editor to EDIT a remote file


This topic has been archived. This means that you cannot reply to this topic.
2 replies to this topic

#1 ikraj

ikraj
  • Members
  • 2 posts

Posted 27 September 2011 - 11:56 PM

I have tried to add Notepad++ to as my default remote editor for EDIT.

I am using the 64 bit home edition

I have done everything correctly as per your video and still whenever I try to open any .htm or .html files it defaults to MS Notepad as the editor.
Everything is setup correctly in the Tools > Seting > Remote Edit.

Why is it that SmartFTP does not recognize Notepad++ and it defaults to MS Notepad.

THe only way I can use Notepad++ is to use Edit with... and select Notepad++.

I will appreciate your help in fixing this problem

#2 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 28 September 2011 - 01:51 AM

Try to edit the file with Edit With..., then select the editor you want to use.

#3 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 28 September 2011 - 04:32 AM

I'm unable to reproduce the problem. Here is how I have set it up:
- Tools - Settings. In the Remote Edit dialog, added .php extension. Set the editor to C:\Windows\write.exe
- Ensured that the Remote Edit option in the same dialog is set to "Editors, Shell Extensions"

Connected to server, right-clicked on a .php file. In the context menu I noticed that the Edit menu item now has the icon of write. Clicked on Edit and the file was downloaded and opened in write/WordPad.