Jump to content


Photo

SmartFTP client crash after update to 4.0.1215

crash

This topic has been archived. This means that you cannot reply to this topic.
4 replies to this topic

#1 sqrbox

sqrbox
  • Members
  • 4 posts

Posted 21 September 2011 - 06:48 PM

The SmartFTP client keeps crashing intermittently, no particular action to trigger it after update to latest version. It was stable in previous version 4.0.1180. I tried clean install, wipe off the registry key and local data, re-install the 4.0.1215, still the same issue.

Crash dump file from VS 2010: https://rapidshare.c...artFTP_crash.7z

System info:
+- System -----------------------------
Microsoft Windows 7
Service Pack 1 (Build 7601)

CPU Speed : 2926 MHz
Total Memory : 8151 MB
Free Memory : 5167 MB

+- SmartFTP ---------------------------
Version : 4.0.1215.0
Time Stamp : 2011-09-10 20:52:32
Platform : x64
Id : 400039615
Maintenance : 2013-06-21
Days in use : 338

+- Language ---------------------------
en-US

+- Internet Explorer ------------------
Version : 8.0.7601.17514

Thanks.

#2 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 21 September 2011 - 10:01 PM

I wasn't able to see anything meaningful in the dump. The crash is in an unknown thread and the stack is empty. Are you interested in a remote debug session? If yes please contact us at support at smartftp.com. Thank you.

#3 sqrbox

sqrbox
  • Members
  • 4 posts

Posted 22 September 2011 - 07:29 PM

The event viewer shows that op_shell.dll is the faulting module when SmartFTP crashed. I think it may have something to do with the Outpost Firewall 7.5.1 that I'm using, that was my first thought too. I'll try to contact you guys again for remote debugging session if I can't figure out from here.

Here is the event viewer details:
Faulting application name: SmartFTP.exe, version: 4.0.1215.0, time stamp: 0x4e6bb699
Faulting module name: op_shell.dll_unloaded, version: 0.0.0.0, time stamp: 0x4e1dd243
Exception code: 0xc0000005
Fault offset: 0x000007feedadc18b
Faulting process id: 0x1200
Faulting application start time: 0x01cc795b7b9c0217
Faulting application path: C:\Program Files\SmartFTP Client\SmartFTP.exe
Faulting module path: op_shell.dll
Report Id: 92e29e2b-e54f-11e0-a316-842b2ba5bbee

#4 sqrbox

sqrbox
  • Members
  • 4 posts

Posted 22 September 2011 - 09:19 PM

Yep, I think the Outpost shell extension is the problem. I turned it off using ShellExView and the SmartFTP client has been running fine.

#5 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 22 September 2011 - 10:31 PM

It seems others have been reporting similar problems with Outpost and Windows Explorer: http://www.outpostfi...th-op_shell.dll