Jump to content


Photo

sfFTPLib fails to register

sfftplib.dll

  • Please log in to reply
5 replies to this topic

#1 DDI

DDI
  • Members
  • 3 posts

Posted 11 August 2011 - 10:18 AM

when trying to install Smart FTP Library, the installation does not finish properly ( it skips the step where it registers the dlls) and when trying to run a VBScript, it fails to find the sfftplib objects.

i tried to register "sfFTPLib.dll" manually , i got the below error,

LoadLibrary("c:\RPS\FTPLib\sfFTPLib.dll") failed - the specified procedure could not be found.

my operating system is : M. Windows Server 2003 - Enterprise edition.


could you please advice ?

#2 mb

mb

    Developer

  • Administrators
  • 11525 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 11 August 2011 - 11:09 AM

Do you have all the necessary files and folders (e.g. en-us) in the c:\RPS\FTPLib\ folder?
Try to manually register the dll: regsvr32 sfFTPLib.dll

#3 DDI

DDI
  • Members
  • 3 posts

Posted 11 August 2011 - 11:11 AM

yes i made shure that all dependencies are available in the same folder, as well as the en-us folder.

i already tried to register the dll manually using the regsvr32, and this is when i got the error already listed.

#4 mb

mb

    Developer

  • Administrators
  • 11525 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 11 August 2011 - 11:25 AM

I'm unable to reproduce the problem This is the content of my folder:

11.08.2011 04:23 <DIR> en-US
11.07.2011 17:05 1'181'696 libeay32.dll
12.04.2010 10:05 7'835 License.rtf
10.06.2011 16:58 421'200 msvcp100.dll
10.06.2011 16:58 773'968 msvcr100.dll
03.06.2010 00:50 <DIR> Samples
08.07.2011 03:53 921'844 sfFTPLib.chm
09.08.2011 20:58 3'149'192 sfFTPLib.dll
02.08.2011 19:37 159'550 sfFTPLib.idl
11.08.2011 04:23 62'270 uninst-sftplib.exe
11.08.2011 04:23 <DIR> x64

Did you try it on a different operating system? Windows XP? Windows 7?

#5 DDI

DDI
  • Members
  • 3 posts

Posted 11 August 2011 - 11:31 AM

it is working on my windows 7 test machine.

i tried to user the same files on both machines. it worked on the test machine(win 7) but not on the server.

here are the folder contents :

20/07/2011 09:55 AM <DIR> en-US
08/03/2011 05:36 PM 43 FTPReg.bat
15/01/2011 04:20 AM 1,059,328 libeay32.dll
18/03/2010 10:15 AM 421,200 msvcp100.dll
18/03/2010 10:15 AM 770,384 msvcr100.dll
07/03/2011 10:44 PM 2,917,768 sfFTPLib.dll
11/02/2011 01:40 AM 156,032 sfFTPLib.idl
23/03/2011 01:03 PM 715 SmartFTP FTP Library License Key.xml

#6 mb

mb

    Developer

  • Administrators
  • 11525 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 11 August 2011 - 12:58 PM

Do you have Windows 2003 64-bit installed? Do you see any errors in the event log?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users