Jump to content


Photo

Error On ssh SFTP


This topic has been archived. This means that you cannot reply to this topic.
5 replies to this topic

#1 Sean_w

Sean_w
  • Members
  • 4 posts

Posted 08 July 2011 - 05:16 PM

Is there an archive of old versions we can download ? Heres my situation:

I just purchased a license but previously was using a trail that just ran out ( NOT AN ISSUE AT ALL , worked flawless).

After purchase i realize im running an older version of smartftp so i download the latest.

Same settings (carries over from the last install): i get an error trying to connect to the same site ive been using for a month previous.

[
10:02:20] SmartFTP v4.0.1204.0
[10:02:20] Resolving host name "****.seedunlimited.com"
[10:02:21] Connecting to **** Port: 20722
[10:02:21] SSH-2.0-OpenSSH_5.5
[10:02:21] Starting SSH session. Remote Id: "SSH-2.0-OpenSSH_5.5"
[10:02:21] SSH protocol version reply. Client Id: SSH-2.0-SmartFTP
[10:02:21] Key Exchange Algorithm: diffie-hellman-group-exchange-sha256
[10:02:22] Key exchange completed.
[10:02:22] Host Key Algorithm: ssh-rsa
[10:02:22] Client to Server Encryption: aes128-ctr
[10:02:22] Server to Client Encryption: aes128-ctr
[10:02:22] Session MAC: hmac-sha1
[10:02:22] Client to Server Compression: zlib@openssh.com
[10:02:22] Server to Client Compression: zlib@openssh.com
[10:02:22] Requesting service "ssh-userauth".
[10:02:23] RTT: 379.836 ms
[10:02:23] Authentication request. Method: none
[10:02:23] Server supported authentications: publickey,password,keyboard-interactive
[10:02:23] Authentication request. Method: password
[10:02:23] User authentication successful.
[10:02:23] SSH session established.
[10:02:23] Connected to ***.seedunlimited.com.
[10:02:23] Detected Server Software: OpenSSH
[10:02:23] Opening channel 0.
[10:03:23] Timeout (60s).
[10:03:23] SSH channel closed by client.
[10:03:23] Connect failed. Error=0x8004440b
[10:03:23] Disconnecting.

So i assume it just may be an error caused by some old settings that need to be updated , I go regedit and delete my old setting ( start fresh)

This version of smartftp returns the same error without a timeout (60)s

After playing with the ssh settings to find something that would work i eventually start getting the following error:

[10:12:15] SmartFTP v4.0.1204.0
[10:12:15] Resolving host name "***.seedunlimited.com"
[10:12:15] Connecting to *** Port: 20722
[10:12:15] SSH-2.0-OpenSSH_5.5
[10:12:15] Starting SSH session. Remote Id: "SSH-2.0-OpenSSH_5.5"
[10:12:15] SSH protocol version reply. Client Id: SSH-2.0-SmartFTP
[10:12:15] Server closed connection
[10:12:15] Connect failed. Error=0x80004005
[10:12:15] Waiting to retry (30s)...

which i assume is my ftp server spitting me out because of the connection errors

<<Scratching my head>> Im at a loss the only thing i can think is theres a prob with the build,but nowhere on the site id there a place to download old builds to rule this out. Any ideas?

i love the software i dont understand y it no longer loves me :o lol
ps: **** = my username is included on the host name

#2 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 08 July 2011 - 05:18 PM

Please email the account information for the server to premium support. This will allow us to reproduce the problem here and if there is a bug provide a fix. Thank you.

#3 Sean_w

Sean_w
  • Members
  • 4 posts

Posted 08 July 2011 - 05:33 PM

Done ... thanx for the quick reply

#4 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 08 July 2011 - 06:01 PM

SFTP is not configured on the server:

19:58:12] Channel request failed (Local=0, Remote=0).
[19:58:12] Failed to open sftp subsystem. Attempting fallback.
[19:58:12] Requesting exec command="test -x /usr/lib/sftp-server && exec /usr/lib/sftp-server
[19:58:12] test -x /usr/local/lib/sftp-server && exec /usr/local/lib/sftp-server
[19:58:12] exec sftp-server" (Local=0, Remote=0).
[19:58:12] Channel request failed (Local=0, Remote=0).

It doesnt work with other clients either.

#5 Sean_w

Sean_w
  • Members
  • 4 posts

Posted 08 July 2011 - 07:04 PM

SFTP is not configured on the server:

19:58:12] Channel request failed (Local=0, Remote=0).
[19:58:12] Failed to open sftp subsystem. Attempting fallback.
[19:58:12] Requesting exec command="test -x /usr/lib/sftp-server && exec /usr/lib/sftp-server
[19:58:12] test -x /usr/local/lib/sftp-server && exec /usr/local/lib/sftp-server
[19:58:12] exec sftp-server" (Local=0, Remote=0).
[19:58:12] Channel request failed (Local=0, Remote=0).

It doesnt work with other clients either.

Confirmed... tested it on a local sftp server and connected fine .... guess i shouldn't have ruled out the server lol

will keep u posted thanx for clarifying.

#6 Sean_w

Sean_w
  • Members
  • 4 posts

Posted 08 July 2011 - 09:14 PM

Edit****: Nvm problem solved ... server was having Sporadic problems including ftp issues ...

Thanks again for the speedy support , sadly u responded correctly and much faster then the server admins i pay monthly :o if only the rest of the world worked perfectly lol

Edited by Sean_w, 08 July 2011 - 09:22 PM.