Jump to content


Photo

Scheduled Task Adds File Multiple Times to Queue


  • Please log in to reply
19 replies to this topic

#1 lmg

lmg
  • Members
  • 26 posts
  • Gender:
    Male

Posted 24 June 2011 - 04:58 PM

I'm evaluating SmartFTP for use at a client and I've noticed something strange in setting up the scheduled tasks. It appears that every time the task is run, the task executes multiple times (I've noticed it executing 2-3 times for each run of the scheduled task).

I found a thread with the same thing happening here, and I am interested to know why the task is being triggered 2-3 times and if there is any possible way I can set the task such that it only executes once. I have the scheduled task set up to copy a single file from the server to the local machine every minute. When I pause the transfer queue, the file shows up in the queue 2-3 times each minute.

Let me know if I can provide any further information that would be helpful!

#2 Josh Steiner

Josh Steiner
  • Members
  • 7 posts

Posted 24 June 2011 - 05:59 PM

Just started using the application this week with the intent of scheduling jobs throughout the day. I've noticed this exact same behavior as well - files will get queued up 3 times. I schedule 195 files and end up with 390 failing after the first 195 download successfully. Must be a bug...

#3 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 24 June 2011 - 08:39 PM

Img: Can you please provide instructions on how to reproduce the problem? Are you using a folder/file monitor?

#4 lmg

lmg
  • Members
  • 26 posts
  • Gender:
    Male

Posted 24 June 2011 - 08:46 PM

Img: Can you please provide instructions on how to reproduce the problem? Are you using a folder/file monitor?


I created a scheduled task to transfer a folder as in this tutorial. I followed the same method to create a scheduled task to transfer a single file as well and have the same issues.

Here are the details of the scheduled task for the folder transfer:
Trigger: Every 1 minute indefinitely
Action: Copy all files from the source folder to the destination folder

And the single file task:
Trigger: Every 1 minute indefinitely
Action: Copy test.txt from the source folder to the destination folder

I'm not using a monitor and there are no scripts assigned to either task.

#5 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 24 June 2011 - 09:02 PM

And what do you see and what are you expecting to see?

You should see that a new transfer queue item is added every minute to the queue. This is the designed behavior.

#6 lmg

lmg
  • Members
  • 26 posts
  • Gender:
    Male

Posted 24 June 2011 - 09:07 PM

I created a scheduled task to transfer a folder as in this tutorial. I followed the same method to create a scheduled task to transfer a single file as well and have the same issues.

Here are the details of the scheduled task for the folder transfer:
Trigger: Every 1 minute indefinitely
Action: Copy all files from the source folder to the destination folder

And the single file task:
Trigger: Every 1 minute indefinitely
Action: Copy test.txt from the source folder to the destination folder

I'm not using a monitor and there are no scripts assigned to either task.


As stated in the original post, I expect to see 1 item added to the queue (or one copy of each of the items in the folder in the case of the folder transfer). Instead, I see 2-3 copies of every file to be transferred showing up each minute.

Example: If the transfer queue is paused and I let the scheduled task run, here is what I would see:

(Elapsed time 1 minute - three copies of the file are in the queue and there should only be one)
Transfer test.txt
Transfer test.txt
Transfer test.txt

(Elapsed time 2 minutes - six copies of the file are in the queue and there should only be two)
Transfer test.txt
Transfer test.txt
Transfer test.txt
Transfer test.txt
Transfer test.txt
Transfer test.txt

#7 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 24 June 2011 - 09:08 PM

I'm unable to reproduce it here. Please post the system information from the menu: Help->About "System Information" dialog.

#8 lmg

lmg
  • Members
  • 26 posts
  • Gender:
    Male

Posted 24 June 2011 - 09:10 PM

I'm unable to reproduce it here. Please post the system information from the menu: Help->About "System Information" dialog.


As requested:

+- System -----------------------------
Microsoft Windows 7  
Service Pack 1 (Build 7601)

CPU Speed           : 2667 MHz
Total Memory        : 4095 MB
Free Memory         :  700 MB

+- SmartFTP ---------------------------
Version             : 4.0.1194.0
Time Stamp          : 2011-06-17 20:25:37
Platform            : x64
Unlicensed
Days in use         : 3

+- Language ---------------------------
en-US

+- Internet Explorer ------------------
Version             : 8.0.7601.17514

I tried version 4.0.1197.0 this morning as suggested by you in my other post and couldn't even get the transfers to work, so I reverted back to 4.0.1194.0.

#9 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 24 June 2011 - 09:47 PM

The newest build 1198 corrects the bugs in 1197.

I'm not sure if you are aware of this:
The transfer queue and the scheduler are independent components. This means if you stop the transfer queue, items from the scheduler will still be added to the queue.

#10 lmg

lmg
  • Members
  • 26 posts
  • Gender:
    Male

Posted 27 June 2011 - 01:42 PM

The newest build 1198 corrects the bugs in 1197.

I'm not sure if you are aware of this:
The transfer queue and the scheduler are independent components. This means if you stop the transfer queue, items from the scheduler will still be added to the queue.


I'll give build 1198 a try.

I am aware that the transfer queue and the scheduler are independent. What I am trying to say is that each time the scheduled task runs, 2-3 items are added to the queue. My task is set to run every minute and for each run, two to three items added to the queue.

#11 lmg

lmg
  • Members
  • 26 posts
  • Gender:
    Male

Posted 27 June 2011 - 02:55 PM

I gave the latest build (1199) a try and I still see items repeating in the queue. There doesn't appear to be a change in the behavior.

#12 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 27 June 2011 - 03:05 PM

Please provide exact instructions on how to reproduce the problem. Thank you.

#13 lmg

lmg
  • Members
  • 26 posts
  • Gender:
    Male

Posted 27 June 2011 - 03:09 PM

Please provide exact instructions on how to reproduce the problem. Thank you.


As before:

I created a scheduled task to transfer a folder as in this tutorial. I followed the same method to create a scheduled task to transfer a single file as well and have the same issues.

Here are the details of the scheduled task for the folder transfer:
Trigger: Every 1 minute indefinitely
Action: Copy all files from the source folder to the destination folder

And the single file task:
Trigger: Every 1 minute indefinitely
Action: Copy test.txt from the source folder to the destination folder

#14 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 27 June 2011 - 03:09 PM

I have found some possible problem in the code. I will add a fix.

#15 lmg

lmg
  • Members
  • 26 posts
  • Gender:
    Male

Posted 27 June 2011 - 03:30 PM

I have found some possible problem in the code. I will add a fix.


Awesome thanks!

#16 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 29 June 2011 - 01:09 AM

The new version is available now: http://www.smartftp.com/download/

#17 lmg

lmg
  • Members
  • 26 posts
  • Gender:
    Male

Posted 29 June 2011 - 03:19 PM

The new version is available now: http://www.smartftp.com/download/


It's still not working for me. I have taken a video of the issue and can email it to you if that would be helpful.

#18 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 29 June 2011 - 07:49 PM

I apologize. Yes it's still broken :-(

#19 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 30 June 2011 - 05:25 AM

Could you try it with the latest build?
http://www.smartftp.com/download/

I'm really sorry for your inconvenience.

#20 lmg

lmg
  • Members
  • 26 posts
  • Gender:
    Male

Posted 30 June 2011 - 01:49 PM

Could you try it with the latest build?
http://www.smartftp.com/download/

I'm really sorry for your inconvenience.


Appears to be fixed on my end now. Thanks!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users