Jump to content


Photo

smartftp und Keepass


  • Please log in to reply
26 replies to this topic

#1 Robertsche

Robertsche
  • Members
  • 15 posts

Posted 09 June 2011 - 02:10 PM

hi,

wenn ich in den einstellungen ein zertifikat auswählen möchte für Keepass dann kommt immer egal welches zertifikat ich wähle der fehler.

Test failed. Error=0x80004005

#2 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 09 June 2011 - 02:32 PM

Try this:
http://www.smartftp....ider-f2648.html

#3 Robertsche

Robertsche
  • Members
  • 15 posts

Posted 09 June 2011 - 03:04 PM

das habe ich getan.der fehler kommt auch wenn ich mir ein zertifikat selbst erstelle.

#4 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 09 June 2011 - 03:19 PM

Ist das KeePassRest im KeePass geladen?
Blockiert die Firewall incoming connection zu KeePass?
Was passiert wenn du das im browser eingibst? https://localhost:12...F812F1A413BAAAA

#5 Robertsche

Robertsche
  • Members
  • 15 posts

Posted 09 June 2011 - 03:27 PM

ja das plugin ist geladen

die firewall blockiert nichts.

wenn ich das eingebe kommt ein leeres fenster.

#6 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 09 June 2011 - 03:40 PM

Probiers mal auf einem anderen system.

#7 Robertsche

Robertsche
  • Members
  • 15 posts

Posted 09 June 2011 - 06:13 PM

auf einem anderen system gehts... warum nur ???

auf dem anderen system kommt auch ein fenster wo ich den zugriff auf Keepass zulassen muss. bei dem nicht funktionierendem kommt das nicht.

Edited by Robertsche, 09 June 2011 - 06:22 PM.


#8 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 10 June 2011 - 06:44 AM

Meine Vermutung ist firewall.

#9 Robertsche

Robertsche
  • Members
  • 15 posts

Posted 10 June 2011 - 02:26 PM

also wenn ich die firewall ausschalte geht es auch nicht.

folgendes...

Rechner 1: windows 7 64 bit
Rechner 2: win Server 2008 RC2 64 bit

auf rechner 1 funktioniert nur ein zertifikat welches auf einer smart card liegt !!! sonst keins.

auf rechner 2 funktionieren nur zertifikate die auf dem rechner installiert sind aber nicht das von der smart card von rechner 1 ???

#10 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 10 June 2011 - 02:47 PM

Weiss leider auch nicht wo die probleme bei dir sind.

#11 Robertsche

Robertsche
  • Members
  • 15 posts

Posted 10 June 2011 - 02:49 PM

:o

#12 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 10 June 2011 - 03:06 PM

Installier mal die neue version von hier: http://www.smartftp.com/download/

Eventuell erhaelst du einen anderen error code in der Test funktion.

#13 Robertsche

Robertsche
  • Members
  • 15 posts

Posted 10 June 2011 - 03:14 PM

hi, ja fehler code 0x80044801

#14 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 10 June 2011 - 03:17 PM

Der HTTP server bzw das keePassRest plugin return ein HTTP reply mit status code != 200. Eventuell mag der server dein client certificate nicht oder es gibt sonst ein problem auf der server seite.

#15 Robertsche

Robertsche
  • Members
  • 15 posts

Posted 10 June 2011 - 03:19 PM

ja aber warum nicht ? das zertifikat erstelle ich mir mit smartftp. auf dem anderen rechner geht es ja auch

#16 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 10 June 2011 - 03:22 PM

Das musst du bei dir debuggen :-) Zb. event log obs da irgend ein cert error gibt. Und sonst die security option in den Local Security Policy anpassen. Eventuell gibts da ein setting wegen self signed client certificates.

#17 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 10 June 2011 - 04:24 PM

Versuch mal folgendes:
command line
C:\Users\mb>netsh http show sslcert

SSL Certificate bindings:
-------------------------

IP:port : 0.0.0.0:12984
Certificate Hash : 6acc34a69961aa4c29fa7011e657e6412aeda276
Application ID : {9aa80290-a376-4b4e-bc6a-588b2317eeed}
Certificate Store Name : (null)
Verify Client Certificate Revocation : Enabled
Verify Revocation Using Cached Client Certificate Only : Disabled
Usage Check : Enabled
Revocation Freshness Time : 0
URL Retrieval Timeout : 0
Ctl Identifier : (null)
Ctl Store Name : (null)
DS Mapper Usage : Disabled
Negotiate Client Certificate : Disabled


Bei mir sieht das so aus. Passt mal deines. Eventuell sind die default settings anders auf Windows 2008 R2.

#18 Robertsche

Robertsche
  • Members
  • 15 posts

Posted 10 June 2011 - 04:32 PM

IP:Port : 0.0.0.0:12984
Zertifikathash : 6acc34a69961aa4c29fa7011e657e6412aeda276
Anwendungskennung : {9aa80290-a376-4b4e-bc6a-588b2317eeed}
Zertifikatspeichername : (null)
Clientzertifikatsperre überprüfen : Enabled
Sperre nur mithilfe des zwischengespeicherten Zertifikats prüfen : Disabled

Verwendungsprüfung : Enabled
Sperraktualisierungszeit : 0
URL-Abrufzeitlimit : 0
Steuerelement-ID : (null)
Steuerelement-Speichername : (null)
DS-Zuordnungsverwendung : Disabled
Clientzertifikat aushandeln : Disabled


sieht genau so aus

#19 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 10 June 2011 - 04:36 PM

Versuch folgendes: Oeffne command line als admin. Dann:

netsh http del sslcert ipport=0.0.0.0:12984

netsh http add sslcert ipport=0.0.0.0:12984 certhash=6acc34a69961aa4c29fa7011e657e6412aeda276 appid={9aa80290-a376-4b4e-bc6a-588b2317eeed} usagecheck=disable verifyclientcertrevocation=disable

#20 Robertsche

Robertsche
  • Members
  • 15 posts

Posted 10 June 2011 - 04:39 PM

hat leider nichts gebracht




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users