Jump to content


Photo

Automated transfer - queue never empties


This topic has been archived. This means that you cannot reply to this topic.
3 replies to this topic

#1 NetTech

NetTech
  • Members
  • 3 posts

Posted 18 April 2011 - 07:50 PM

This has been an ongoing battle to try to streamline a seemingly simple automatic transfer. Here's what I'm trying to do:

A production system produces a plain-text file periodically and places it in a network folder.
A batch process runs every ten minutes that processes that file for internal purposes and then places it in a folder local to the SmartFTP installation.
SmartFTP then moves that file to a folder on a remote server.
SmartFTP then sends a Transfer Successful email (see below).

This is actually occurring, but I've been dealing with irritating little issues no matter what method I employ to streamline the process. If I can solve these two, I'm good to go.

1) After transferring, the items re-appear in the queue and retry ... these stack up cumulatively and after several days I've got dozens in the queue. The transfers still go through, but the "ghost" queue items cause some kind of authentication overload on the remote server and the NOC calls me to find out why I'm authenticating 2300 times a day. I clear the ghost items, and the NOC is happy again.

2) If I leave the connection open, the remote server closes it after 5 minutes. The result of this is mixed. In some cases activity in SmartFTP somehow initiates a reconnect and things flow smoothly. Other times, with an active item in the running queue, the connection remains disconnected and nothing happens until I either restart SmartFTP or click on the reconnect button. I have not isolated what the difference is on what causes the connection to automatically re-establish and when it doesn't.

As far as trying to keep the queue from getting these retry "ghosts" when it has already successfully transferred the file, I've tried:

a. Create a queue entry with the queue stopped then modify the properties of the item to schedule it for every 10 minutes or to monitor the folder the file gets dropped into. I've created the queue item a number of ways (cut and paste the item into the remote folder, manually dragging and dropping it into the remote folder, clicking the Add button, and so on) with no change in the result.

b. Set the program to automatically close on Queue completion (this had various results, BTW).

c. Downloaded the SDK and used a template for MoveSourceItemToFolder.js - mixed results here too, but still ghost entries present.

The pre-processing done before dropping the file into the monitored folder can actually take care of everything the scripting can do - except clear these persistent ghost entries.

Why, if the file transferred OK, does the item re-appear in the queue????
What method can I use to watch for this file to appear and then transfer it once and be done with it!?


Details of pertinence:

SFTP over SSH (keepalive not working with this type of connection)
Remote server automatically renames the transferred file - if this is interfering with SmartFTP realizing it transferred the file, how can I tell SmartFTP not to check the file at the remote end?
I can automate starting and stopping SmartFTP within the preprocessing engine.

I am getting Successful indications via email:

******************************start example email*********************
General
Id {FDBD090E-XXXX-49AE-8543-C3DAXXXXXXX}
Operation Move
Synchronization One Way
Status Success
Type File
Size 328
StartTime 2011-04-18T13:06:20
FinishTime
Source
Type Local
Favorite
Path C:\smartftp\watch_folder
Destination
Type Remote
Favorite sshftp.examplesite.com - userid_1
Path /inbound/target_folder/filename
Retries 0
Last Progress
StartTime 2011-04-18T19:06:22
StopTime 2011-04-18T19:06:22
DeltaTime P0000-00-00T00:00:00
StartPosition 0
TransferredBytes 410
AverageSpeed 1192
******************************end example email*********************

Info from the "About" section of SmartFTP:

******************************start SmartFTP details*********************
ID: 400125919
Version: 2.1
Number: 1
Maintenance: 2011-05-14
Features: Ultimate

+- System -----------------------------
Microsoft Windows XP Professional
Service Pack 3 (Build 2600)

CPU Speed : 1794 MHz
Total Memory : 511 MB
Free Memory : 172 MB

+- SmartFTP ---------------------------
Version : 4.0.1178.0
Time Stamp : 2011-04-10 13:58:35
Platform : x86
Id : 400125919
Maintenance : 2011-05-14
Days in use : 382

+- Language ---------------------------
en-US

+- Internet Explorer ------------------
Version : 7.0.5730.11

+- Winsock ----------------------------
Winsock : 2.2
******************************end SmartFTP details*********************

TIA,

--Network Technician

Edited by NetTech, 18 April 2011 - 07:54 PM.


#2 mb

mb

    Developer

  • Administrators
  • 11527 posts

Posted 18 April 2011 - 08:33 PM

Please contact our technical support by email. Thank you.

#3 NetTech

NetTech
  • Members
  • 3 posts

Posted 18 April 2011 - 08:55 PM

Per your request, I've submitted these details to support@smartftp.com.

#4 NetTech

NetTech
  • Members
  • 3 posts

Posted 20 April 2011 - 11:25 PM

Final solution to this problem has not been arrived at, but the support end of this issue is complete.

My understanding of the Transfer Queue was flawed. My issue is most likely going to be resolved by using the SDK scripting feature.