Jump to content


Photo

Hotel Will Not Allow FTP Connection


This topic has been archived. This means that you cannot reply to this topic.
5 replies to this topic

#1 JetJagger

JetJagger
  • Members
  • 11 posts

Posted 01 March 2011 - 11:02 PM

I am in an Extended Stay Deluxe Hotel for eight days.

Their access to the Web is password-protected.

Though I can access the Web, I cannot connect to ANY of my accounts via SmartFTP (v4.0.1054.0). When I click on a "Favorite" account to log into, I just get the preloader on the tab (in SmartFTP) which keeps spinning. Nothing loads. (At this point, all SmartFTP proxy connection settings are set to "Use Default Settings". This includes CONNECTION > PROXY and FTP > CONNECTION > PROXY.

I then tried connecting to the Web via a proxy server using my "Internet Options". Though this method work for my browser, it did not work for FTP.

I then used the same proxy IP address and port in CONNECTION > PROXY as follows:

For CONNECTION > PROXY : HTTP Proxy - Connection Tunnel (Login to Proxy / Firewall option was NOT selected)

(NOTE: I did not change FTP > CONNECTION > PROXY because I don't understand the drop-down options)


Strangely, I have been able to connect to root directories ONLY in accounts wherein I have not yet set the open path to "public_html". But, when I try to open any directory to access Website files, I get stuck with the preloader that just spins and spins on the account tab (in SmartFTP).

Bottom line is this:

If I'm in a hotel that has firewalled FTP access (assuming this is the problem):

1. Where (in SmartFTP) do I apply proxy settings to get around their firewall, and what drop-down options should I select if prompted?

2. What proxy I.P. and port number should I use? If you do not have provide this, where would I get it?


I stand to lose a very big contract if I can't figure this out. My hotel is already paid-for, so I can't leave.

Any IMMEDIATE help would be appreciated.


Thank you,

Jet

-

#2 JetJagger

JetJagger
  • Members
  • 11 posts

Posted 01 March 2011 - 11:15 PM

Additional Note: I am using XP and tried to connect with the Windows Firewall on and off. Still no joy.

-

#3 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 01 March 2011 - 11:17 PM

Most likely they are running an application proxy which only allows port 80 and 443, so you won't be able to connect without setting up some kind of VPN connection to another network.

Please let us know the name of the hotel so other users can avoid it in the future :-)

#4 JetJagger

JetJagger
  • Members
  • 11 posts

Posted 01 March 2011 - 11:20 PM

Most likely they are running an application proxy which only allows port 80 and 443, so you won't be able to connect without setting up some kind of VPN connection to another network.

Please let us know the name of the hotel so other users can avoid it in the future :-)



LOL ~ It's at the top of my post: EXTENDED STAY DELUXE

"Deluxe"...yeah, right ~ lol.

-

#5 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 01 March 2011 - 11:23 PM

I have been in the same situation as you. The only solution is to use a VPN (SSTP) that tunnels all the traffic through HTTPS. But this is something that needs to be setup beforehand. There are commercial VPN providers that offer VPN SSTP. On the client side, VPN SSTP is supported on Windows Vista and higher. On Windows XP you probably need to use a 3rd party client.

#6 JetJagger

JetJagger
  • Members
  • 11 posts

Posted 01 March 2011 - 11:29 PM

I have been in the same situation as you. The only solution is to use a VPN (SSTP) that tunnels all the traffic through HTTPS. But this is something that needs to be setup before. There are commercial VPN providers that offer VPN SSTP.



Thanks mb. Guess I'll just try to work from cPanel's file manager for each account.

-