Jump to content


Photo

CHMOD Rechte setzen


  • Please log in to reply
4 replies to this topic

#1 Hexo

Hexo
  • Members
  • 15 posts

Posted 12 July 2010 - 10:26 AM

Hey.

Ich hab eine kleine Frage bezüglich der Rechtevergabe mit SmartFTP.
Ich hab auf meinem Webspace eine Anzahl von X Ordner. Jeder Ordner enthält X Dateien.
Ich würde jetzt gerne bei jedem Ordner die CHMOD Recht 755 und bei jeder Datei 644 einstellen.

Aktuell kann ich nur einen Ordner anklicken und die Rechte restruktiv nach unten verteilen. Sprich: Ich geb einem Ordner die Rechte 755 und alle Dateien bekommen ebenfalls 755. Ich müsste dann noch manuell die Dateien auf 644 umstellen. Klar, ich kann dann alle Dateien im Ordner anwählen und so den Ordnerinhalt andere rechte geben. Aber das ist wie gesagt.. alles manuell.

Der Hintergrund ist: Wir haben den Server gewechselt. Auf dem neuen Server läuft suPHP und da brauchen die Ordner "nur" 755 bzw. 644 für Dateien (bzw. es gibt sogar Fehler, wenn ein Ordner auf 777 steht). Wenn ich aber jetzt alles manuell einstelle, brauche ich Stunden bis Tage, bis ich mich durch den ganzen Ordnerbaum geklickt habe.

Für die Sicherheit ist das natürlich auch besser.

Also gibt es bei SmartFTP die möglichkeit nur den Ordner gewisse CHMOD rechte zu vergeben und den Daten andere Rechte?

Gruß Hexo
(ps. ich hoffe ihr versteht mich :-) )

#2 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 12 July 2010 - 01:33 PM

Ja das funktioniert. Im Properties dialog kannst du angeben ob du die Rechte fuer alle Files oder alle Folders oder beides setzten willst. Also musst du das in 2 Schritten machen:
1. Die Rechte aller folder setzten
2. Die Rechte alle files setzten

Gruss
Mat

#3 Hexo

Hexo
  • Members
  • 15 posts

Posted 12 July 2010 - 01:46 PM

Hallo mb.
Danke für die schnelle Antwort.
Ich muss jetzt mal doof fragen, da ich anscheinend wegen der Temperatur das nicht so wirklich raffe.

Wie genau muss ich das im Properties Dialog einstellen....
Ich seh da keine "Folder" oder "Files" Option, oder bin ich blind?

Gruß

#4 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 12 July 2010 - 01:57 PM

Eventuell musst du erst die neuste version installieren?
http://www.smartftp.com/download

#5 Hexo

Hexo
  • Members
  • 15 posts

Posted 12 July 2010 - 04:15 PM

Oh man. Das ist ja super Simpel.
Sorry, vor lauter Bäumen hab ich den Wald nicht mehr gesehen ^^
Hab das voll übersehen.

Klappt so perfekt. Genau so hab ich mir das vorgestellt.


Gruß




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users