Jump to content


Photo

Keine Dateiendungen nach upload


  • Please log in to reply
3 replies to this topic

#1 Dorian

Dorian
  • Members
  • 2 posts

Posted 28 October 2009 - 11:12 PM

Hallöle an alle,

leider habe ich ein gravierendes Problem mit meinem SmartFTP. Seit meinem Umstieg von Vista 32bit auf Windows 7 64 bit kann ich SmartFTP in die Tonne treten.

Bei allen Dateien, die ich auf verschiedene Server uploade, gehen die Dateiendungen verloren. Das bedeutet das die Dateien zwar auf den Server übertragen werden, jedoch nutzlos sind da sie nur als "Datei" bezeichnet werden. Es geht also zum Beispiel bei der Datei "test.html" das ".html" verloren und die Datei heißt nur noch "test".

Ich kann jetzt zwar die Datei manuell wieder mit einem ".html" erweitern - das ist aber ab 10 Dateien etwas nervig!!! Angeblich soll SmartFTP ja unter Windows 7 laufen - naja!

Norton 2010 hatte ich zwischendurch deaktiviert - nix.

Das beste ist das meine Lizenz natürlich am 24.09.2009 auslief und ich - zum testen - die aktuellste Version runtergeladen habe (v4.0.1059.0 64bit). Dabei habe ich meine gültige Setup Version überschrieben!!! Super!!! Jetzt kann ich nicht mal mehr die Version für meine Lizenz runterladen.

Man ich habe einen Hals!!!

Bitte Bitte helft mir... ich weiß nicht mehr weiter!

Vielen Dank im Vorraus für Eure Mühen.

Dorian

#2 mb

mb

    Developer

  • Administrators
  • 11525 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 28 October 2009 - 11:26 PM

Wir wissen leider nicht wo das Problem ist, weil es nur sporadisch auftritt. Siehe dazu auch:
http://www.smartftp....the-extensions/

Ein workaround ist die [x] Hide Extension from known file types option in den Windows Explorer options zu disablen:
1. Open Windows Explorer
2. Go to Menu: Tools->Folder Options
3. Go to View dialog
4. Disable [x] Hide extensions from known types

Wenn du interesse hast koennen wir das mit dir debuggen.

#3 Dorian

Dorian
  • Members
  • 2 posts

Posted 29 October 2009 - 10:34 PM

Hallöle.

Vielen Dank für die Antwort.

Also inzwischen bin ich schon einen Schritt weiter... Der Fehler tritt nur auf wenn man irgendwelche Dateien aus Ordner, die sich im "Bibliotheken" Ordner befinden kopiert. Um genauer zu sein (kleine Fehler-Anleitung):

Unter "D:\Eigene Dateien\Hompages\" befindet sich die Datei "body.png"

Diese Datei kann man nun auf 3 Arten erreichen.

1. Man öffnet den Arbeitsplatz (Computer) - Laufwerk "D" - Ordner "Eigene Dateien" - Ordner "Dokumente" - Ordner "Homepages" = keine Fehler

2. Man geht im Startmenü auf den Ordner mit seinem Namen (bei mir "Dorian") - Ordner "Dokumente" - Ordner "Homepages" = keine Fehler

3. Man öffnet den Arbeitsplatz (Computer) - Bibliotheken (links) - Ordner "Dokumente" - Ordner "Homepages" = der Fehler tritt auf

Wie man merkt tritt der Fehler nur im Zusammenhang mit dem komischen Bibliotheken Ordner von Windows 7 auf. Erwähnen sollte man noch das dieser Fehler in jedem Unterordner auftritt den man über Bibliotheken erreicht. Gemeint sind die Unterordner in "Bilder" "Dokumente" Musik" und "Videos". Befindet sich die Datei direkt in einem dieser Ordner - also z.B. in "Bilder" - dann geht es.

Fast vergessen. Ich habe die Ordner von "Eigene Bilder" in "Bilder" usw. umbenannt (da sonst die Pfadangaben - die bei Vista so waren - für andere Programme nicht funktionieren). Ich hoffe aber das es nicht daran liegt.

Ich hoffe das war gut erklärt...

Selbstverständlich bin ich am debuggen des Problems interessiert. Was genau ich dazu machen muß, oder was Ihr von mir braucht müsst Ihr nur sagen...

bis dahin

Dorian

Edited by Dorian, 29 October 2009 - 10:36 PM.


#4 mb

mb

    Developer

  • Administrators
  • 11525 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 30 October 2009 - 04:43 AM

Danke fuer die Ausfuehrung. Wir haben den bug behoben:
http://www.smartftp.com/download

:-)

Gruss
Mat




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users