Jump to content


Photo

.UK.com and .GB.com domains


This topic has been archived. This means that you cannot reply to this topic.
18 replies to this topic

#1 ftipsy

ftipsy
  • Members
  • 10 posts

Posted 03 August 2009 - 11:24 AM

I cannot get SmartFTP to connect successfully to either .UK.com or .GB.com domains (eg mydomain.uk.com)

I appreciate that when registering domains ending with .uk.com or .gb.com, you are technically only buying subdomains (as they are not true TLDs). However, they do behave just like any other TLD in all other respects (eg when uploading / downloading via Dreamweaver).

I want to use FTP over SSL, for which I can't use DW, so instead need to use SmartFTP.

But SmartFTP insists on appending further .TLD info to the end of my already valid urls (eg mydomain.uk.com is turned into mydomain.uk.com.co.uk by SmartFTP). I can't find any way to stop this happening.

Can you please address this issue?

#2 mb

mb

    Developer

  • Administrators
  • 11870 posts

Posted 03 August 2009 - 01:19 PM

Hello ..

SmartFTP does not append anything to the host name you enter. Try to connect with the IP address instead.

Regards,
Mat

#3 ftipsy

ftipsy
  • Members
  • 10 posts

Posted 03 August 2009 - 01:25 PM

Hi Mat

Will look into the IP address suggestion, thanks.

However, I can assure you that extra stuff is being appended to the host names. And if I'm not doing it (which I'm definitely not), that really only leaves SmartFTP. :D

#4 ftipsy

ftipsy
  • Members
  • 10 posts

Posted 21 July 2010 - 03:11 PM

OK, so slight delay on my side...

However: can't use an IP address.

Also, I can categorically promise you that SmartFTP is still appending .co.uk onto the end of domain.uk.com - every single time I try to connect to that domain. There's no way I can find to stop it or to delete it once it's been added.

Is it possible that the software needs a tweak to recognise .uk.com (and .gb.com) as valid top level domains?

That would seem to be the logical cause of the issue to an idiot layman such as myself. :D

#5 ftipsy

ftipsy
  • Members
  • 10 posts

Posted 16 September 2010 - 10:13 AM

Mat - this is still a problem, including with version 4.0.1137.0

Would appreciate a fix being sorted out, please.

#6 mb

mb

    Developer

  • Administrators
  • 11870 posts

Posted 16 September 2010 - 02:07 PM

It's not a problem with SmartFTP but with your dns resolver.

#7 ftipsy

ftipsy
  • Members
  • 10 posts

Posted 16 September 2010 - 04:11 PM

Can you elaborate, please? I've read up quickly on Wikipedia, etc and am still none the wiser.

If I type the domain.uk.com (I use "domain" as a generic replacement for what I'm actually using) directly into a browser address bar, it loads the site correctly. It does so whether I enter:

domain.uk.com
www.domain.uk.com
http://domain.uk.com
or http://www.domain.uk.com

Dreamweaver also connects to the domain successfully using exactly the same ftp address (ftp.domain.uk.com) as I am asking SmartTFP to use.

So why is it only SmartFTP that has a problem with resolving the address? Surely the issue is specific to your software?

Whilst this looks like a longwinded rant, I do appreciate your help with this - am just trying to explain how I'm seeing the issue from my side. :D

Edited by ftipsy, 16 September 2010 - 04:11 PM.


#8 mb

mb

    Developer

  • Administrators
  • 11870 posts

Posted 16 September 2010 - 04:36 PM

SmartFTP uses the standard way/API to resolve the host name. I do not see anything wrong in the code either and we have been using it for more than 10 years now. Try it with another computer in your network, or on a different network. You can also try to change your DNS server to:
Google public dns:
8.8.8.8
8.8.4.4
Instructions on how to configure the network settings (DNS server) can be found at: http://code.google.c...eed/public-dns/

#9 ftipsy

ftipsy
  • Members
  • 10 posts

Posted 16 September 2010 - 05:36 PM

If the problem lay with my dns resolver, surely I wouldn't be able to open this site in a web browser or access it with Dreamweaver? Or am I missing something?

#10 mb

mb

    Developer

  • Administrators
  • 11870 posts

Posted 16 September 2010 - 05:48 PM

Can you please post the log from the remote browser?

#11 mb

mb

    Developer

  • Administrators
  • 11870 posts

Posted 16 September 2010 - 05:58 PM

I did some tests here:
[00:57:35] SmartFTP v4.0.1137.0
[00:57:35] Resolving host name "ftp.orange.uk.com"
[00:57:35] Connecting to 188.220.57.144 Port: 21
[00:57:36] Connected to ftp.orange.uk.com.
[00:57:36] 220 Microsoft FTP Service
[00:57:36] USER anonymous
[00:57:37] 331 Anonymous access allowed, send identity (e-mail name) as password.

No co.uk is added to the host name I have entered.

#12 ftipsy

ftipsy
  • Members
  • 10 posts

Posted 16 September 2010 - 06:00 PM

Upon entering ftp.domain.uk.com into the remote browser bar, plus login and p/w, then clicking the Go button, the log file says:

[18:52:19] SmartFTP v4.0.1137.0
[18:52:19] Resolving host name "ftp.domain.uk.com.co.uk"
[18:52:19] Unable to resolve host name.
[18:52:19] Active Help: http://www.smartftp.com/support/kb/81
[18:52:19] Connect failed. Waiting to retry (30s)...
[18:52:33] Aborted by user.

#13 mb

mb

    Developer

  • Administrators
  • 11870 posts

Posted 16 September 2010 - 06:01 PM

Please check your network settings:
http://img812.images...29/83239945.png

And make sure there are no DNS suffixes configured.

#14 mb

mb

    Developer

  • Administrators
  • 11870 posts

Posted 16 September 2010 - 06:02 PM

Go to the menu: File->New Remote Browser. Then enter the host, username and password. Click OK to connect.

#15 ftipsy

ftipsy
  • Members
  • 10 posts

Posted 16 September 2010 - 06:10 PM

Please check your network settings:
http://img812.images...29/83239945.png

And make sure there are no DNS suffixes configured.


Where is this dialogue box, please?

#16 mb

mb

    Developer

  • Administrators
  • 11870 posts

Posted 16 September 2010 - 06:11 PM

Please try this first:
Go to the menu: File->New Remote Browser. Then enter the host, username and password. Click OK to connect.

#17 ftipsy

ftipsy
  • Members
  • 10 posts

Posted 16 September 2010 - 06:21 PM

Oooh - progress!

That worked. Up to a point. But this time because of some issue with IP addresses.

"500 I won't open a connection to xxx.xxx.x.x (only to xx.xxx.xx.xxx)"

Best discussed with hosting provider?

Edited by ftipsy, 16 September 2010 - 06:24 PM.


#18 mb

mb

    Developer

  • Administrators
  • 11870 posts

Posted 16 September 2010 - 06:30 PM

Please post the log from the remote browser.

I think the server thinks that you are opening the data connection from a different ip address than the one you use for the control connection. You probably have to set the encryption for the data connection (FTP->Connection->SSL) to clear instead of private.

#19 ftipsy

ftipsy
  • Members
  • 10 posts

Posted 16 September 2010 - 06:39 PM

OK, experimented with that. Didn't seem to work at first, but after setting to clear, then back to private (testing in between each time), it finally let me in after everything was put back to private.

Thank you very much indeed for your help with this - it's greatly appreciated.

Just hope it still works tomorrow :D

Edited by ftipsy, 16 September 2010 - 06:58 PM.