Jump to content


Photo

Delete Fails in Search Results


This topic has been archived. This means that you cannot reply to this topic.
5 replies to this topic

#1 Nick

Nick
  • Members
  • 4 posts

Posted 12 May 2009 - 08:08 PM

Steps To Reproduce
  • Start SmartFTP v3.0.1027.0 and connect to a FileZilla server (in my case, via FTP over SSL) on Windows XP SP3.
  • Navigate to a folder on the server that has many files in it via the remote browser.
  • In the Search box in the remote browser's toolbar, enter a search phrase and press enter. A "Search 1" node appears with the filtered search results.
  • Click on the "Search 1" node and select a file in the remote browser.
  • Right-click the item and choose Delete. Press Yes to the confirmation dialog.
Expected Result
The item should be deleted.

Actual Result
One of the following occurs:
  • The operation fails silently.
  • Smart FTP crashes with the "encountered a problem and needs to close" Windows Error Reporting dialog. The faulting AppName is smartftp.exe. The faulting ModName is sfftpshellextension.dll at offset 00110de2.


#2 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 12 May 2009 - 08:12 PM

Thank you for the bug report. We are looking into it.

#3 Nick

Nick
  • Members
  • 4 posts

Posted 12 May 2009 - 09:11 PM

I should add that deleting in the "normal" remote browser view works fine. It's only within the context of a search that it either fails silently or crashes (I assume that when it fails silently, it just corrupted its own memory space). Upon executing the Delete command, the Log pane doesn't update within any relevant commands, as if it never attempted to communicate with the server.

I can connect to some unspecified FTP server on a different host and the Search/Delete combination works fine. The FileZilla server version that exhibits the problem is 0.9.25. Other commands in the right-click menu for the Search pane work fine (such as "View" or "Open" or "Rename"); it's only "Delete" that has the problem. If it helps to note, the "Delete Multiple Items?" or "Delete File" confirmation prompt pops up every time, regardless of whether or not "Don't ask me again" is checked. Perhaps that dialog is failing in some way? I can only speculate. Hope that helps.

#4 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 13 May 2009 - 07:41 PM

The problem has been fixed in the latest version:
http://www.smartftp.com/download/

Thank you for reporting ;-)

Regards,
Mat

#5 Nick

Nick
  • Members
  • 4 posts

Posted 13 May 2009 - 08:15 PM

The problem has been fixed in the latest version:
http://www.smartftp.com/download/

Thank you for reporting ;-)

Regards,
Mat


I downloaded the latest beta (3.0.1027.5) and can confirm that my problem is solved. Thanks for the quick fix!

#6 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 13 May 2009 - 09:23 PM

You are welcome. Thanks for the feedback ;-)