Jump to content


Photo

License problem with Windows 2000


  • Please log in to reply
3 replies to this topic

#1 m.gunesch

m.gunesch
  • Members
  • 16 posts

Posted 03 March 2009 - 02:12 PM

Dear all,

We encountered problems on some machines running Windows 2000.
The methods LoadLicenseKeyFile or LoadLicenseKeyData fail although there is correct license information.

I have set the LogLevel to highest value, as you can see there is a problem creating the MSXML::DOMDocument

LoadLicenseKeyData
20090303 14:56:16.802 Thread(580) Log file opened. LogLevel=7
20090303 14:56:16.802 Thread(580) Set LogLevel to 4294967295.
20090303 14:56:16.812 Thread(580) CLicenseKey::LoadData()
20090303 14:56:16.812 Thread(580) CLicenseKey::LoadDataText()
20090303 14:56:16.812 Thread(580) CLicenseKey::LoadDataXML()
20090303 14:56:16.822 Thread(580) CLicenseKey::LoadDataXML() CreateInstance(__uuidof(MSXML::DOMDocument)) failed (0x80040154).
20090303 14:58:09.203 Thread(580) Log file closed.

LoadLicenseKeyFile
20090303 14:58:12.678 Thread(936) Log file opened. LogLevel=7
20090303 14:58:12.678 Thread(936) Set LogLevel to 4294967295.
20090303 14:58:12.678 Thread(936) CLicenseKey::LoadFile(C:\Documents and Settings\ils\Bureau\key.xml)
20090303 14:58:12.678 Thread(936) CLicenseKey::LoadXML()
20090303 14:58:12.688 Thread(936) CLicenseKey::LoadXML() Failed to create MSXML::DOMDocument hr=-2147467259
20090303 14:58:23.524 Thread(936) Log file closed.

The problem is, that this happens not on all machines running Windwos 2000. We have some PCs with 2k and it works.

Maybe you have a great idea how to solve this problem :-)

Thanks in advance!
BR Markus

#2 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 03 March 2009 - 02:36 PM

Hello ..

It seems the MSXML component is not correctly installed on the machines where you see the problem. The 0X80040154 error is: CLASS NOT REGISTERED

Try to install the newest MSXML updates.

Regards,
Mat

#3 m.gunesch

m.gunesch
  • Members
  • 16 posts

Posted 03 March 2009 - 03:09 PM

I have already tried to install MSXML 4.0, MSXML 5.0 and MSXML 6.0 and it didn't work.
Last try was to install "Microsoft XML Parser (MSXML) 3.0 Service Pack 7 (SP7)" and taaataaaaa it's ok now.

Microsoft ... Oo

Thanks for your help!

BR,
Markus

#4 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 03 March 2009 - 03:36 PM

Yes the FTP Library uses MSXML 3.0 because we thought it's available on every system. Apparently not always.

Regards,
Mat




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users