Jump to content


Photo

Cannot add/edit favourites


This topic has been archived. This means that you cannot reply to this topic.
23 replies to this topic

#1 tomh73

tomh73
  • Members
  • 4 posts

Posted 03 March 2009 - 01:43 PM

Hi,

I am using the 64 bits Version 3.0.1026.11 and I cannot add or change any favourites.
It just does not respond when I go to Favourites and try to add or edit.
Is there a workaround?
Here are my system/version specs.


+- System -----------------------------
Microsoft Windows Vista Business Edition
Service Pack 1 (Build 6001)

CPU Speed : 2133 MHz
Total Memory : 5054 MB
Free Memory : 2356 MB

+- SmartFTP ---------------------------
Version : 3.0.1026.11
Time Stamp : 2009-02-27 16:17:26
Platform : x64
Id : xxxxxxxxxx (removed)
Days in use : 684

+- Application DLL --------------------
sfFTPLib.dll : 1.5.17.17
sfFavorites.dll : 1.0.22.11
sfFavoritesShellExtension.dll : 2.0.2.1
sfTransferQueue.dll : 1.0.19.11
sfFTPShellExtension.dll : 1.0.17.11
SmartFTPPS.dll : 3.0.1026.11

+- Language ---------------------------
SmartFTP.exe : 3.0.1026.11

+- Internet Explorer ------------------
Version : 7.0.6001.18000

+- Winsock ----------------------------
Winsock : 2.2

#2 mb

mb

    Developer

  • Administrators
  • 11874 posts

Posted 03 March 2009 - 02:05 PM

Hello ..

What exactly is not working? Are you able to opent he Favorites browser? Menu: Favorites->Edit Favorites.

Regards,
Mat

#3 mb

mb

    Developer

  • Administrators
  • 11874 posts

Posted 03 March 2009 - 05:05 PM

Please install the latest version (3.0.1026.13) of SmartFTP from here:
http://www.smartftp.com/download

#4 tomh73

tomh73
  • Members
  • 4 posts

Posted 04 March 2009 - 07:14 AM

Please install the latest version (3.0.1026.13) of SmartFTP from here:
http://www.smartftp.com/download


I installed the latest version but the same happens, I am able to open the favourites browser, but when I click an entry with right mouseclick, properties, the properties screen does not appear. Also when I use the Icon "new favourite", nothing happens.

I hope you can help.

regards,Tom

#5 dicks

dicks
  • Members
  • 12 posts

Posted 04 March 2009 - 08:22 AM

Tom, I have the same issue with build .13.

Right click on a favorite (from favorites manager), properties - nothing happens. Click "New" and nothing happens.

There is also a blank menu entry when right clicking on a favorite (running SmartFTP on German OS).

#6 mb

mb

    Developer

  • Administrators
  • 11874 posts

Posted 04 March 2009 - 01:54 PM

Please close SmartFTP and then delete the old german language files *DEU.dll in the C:\Programme\SmartFTP Client folder.

#7 dicks

dicks
  • Members
  • 12 posts

Posted 04 March 2009 - 02:13 PM

Did that, I still can not add a favorite. The window just does not show. When I try to add a new folder SmartFTP crashes.

#8 mb

mb

    Developer

  • Administrators
  • 11874 posts

Posted 04 March 2009 - 02:55 PM

Please try the latest version:
http://www.smartftp.com/download

And reboot your computer if you are prompted to do so.

Regards,
Mat

#9 dicks

dicks
  • Members
  • 12 posts

Posted 04 March 2009 - 04:35 PM

No change with build .14. To repro:

1. Open SmartFTP and click "Favorites" then "Edit favorites". Then right click on an entry and select "Properties" ("Eigenschaften" in my German OS). Nothing happens -> expected window to open.

2. Same as above but in favorites dialog on the right side where the favorites are, in a white area, do a right click and select New, Folder. SmartFTP crashes ungracefully.

3. Click on Favorites menu and then right click on a favorite, select "Properties", also here nothing happens.

#10 mb

mb

    Developer

  • Administrators
  • 11874 posts

Posted 04 March 2009 - 05:46 PM

1. Uninstall SmartFTP
2. Remove the complete C:\Programme\SmartFTP Client folder
3. Install SmartFTP.
4. Then try to run SmartFTP under a different user account

Also please check if you have a file called desktop.ini in the following folder:
%appdata%\SmartFTP\Client 2.0\Favorites

If yes delete it.

Regards,
Mat

#11 dicks

dicks
  • Members
  • 12 posts

Posted 04 March 2009 - 05:53 PM

Uhm, would I not loose all my favorites?

Running under a different user account makes no sense.

This is a bug in the code, please fix it.

#12 mb

mb

    Developer

  • Administrators
  • 11874 posts

Posted 04 March 2009 - 05:57 PM

Please follow the instructions as given.

Please add your license key id to your profile in the forum.

#13 mb

mb

    Developer

  • Administrators
  • 11874 posts

Posted 04 March 2009 - 06:20 PM

Another fix that worked for another user was to delete the registry key at:
HKEY_CURRENT_USER\Software\SmartFTP

1. Go to the start button in Windows (bottom left)
2. Select Run...
3. Enter regedit.exe
4. Press Enter
5. Delete the registry key/folder at:
HKEY_CURRENT_USER\Software\SmartFTP

#14 dicks

dicks
  • Members
  • 12 posts

Posted 04 March 2009 - 07:13 PM

I tried that, does not work.

I still can not add or edit favorites. In the favorites window when I right click and select "New", "Folder" then SmartFTP crashes. I have Vista-32 with SP1.

Can't you repro this, it repro's here every time no matter what you tell me to do.

#15 mb

mb

    Developer

  • Administrators
  • 11874 posts

Posted 04 March 2009 - 10:45 PM

Nope we cannot reproduce it otherwise the problem would not exist. We had a couple of users with the same problem and it all orginated from old localization files (*DEU.dll), a corrupt installation or a registry problem.

Did you try everything I suggested?
1. registry cleanup
2. complete uninstall with manual deletion of all files in the program files folder
3. rename the %AppData%\SmartFTP folder to %AppData%\SmartFTP.Backup

Regards,
Mat

#16 dicks

dicks
  • Members
  • 12 posts

Posted 04 March 2009 - 11:09 PM

Mat,

I took a copy of the favorites folder and then removed the registry key, uninstalled SmartFTP and rebooted. I then manually deleted all folders, also the one in appdata/roaming.

I then re-installed latest 3.0 and voilá I can now edit favorites. However for some reason the copied favorites folder was empty and I now have to re-enter all my favorites. The favorites backup is something you guys need to look at (perhaps offer a server based option like Foxmarks for Firefox?).

Still very puzzeling why a complete uninstall is required to get SmartFTP working again...

Edited by dicks, 04 March 2009 - 11:10 PM.


#17 mb

mb

    Developer

  • Administrators
  • 11874 posts

Posted 05 March 2009 - 12:21 AM

The favorites in SmartFTP are individual .xml files. So you can just copy the xml files/folders from your old favorites folder to the new favorites folder.

You can do daily/weekly backup of your favorites. Menu: Tools->Settings. Then go to the Backup page.

Regards,
Mat

#18 dicks

dicks
  • Members
  • 12 posts

Posted 05 March 2009 - 06:15 AM

OK, I'll take a look at that.

Any idea why a complete uninstall/re-install was required to get rid of the non functional favorites issue and crash when adding a new favorite?

#19 tomh73

tomh73
  • Members
  • 4 posts

Posted 05 March 2009 - 09:08 AM

Hi,

My problem with the favourites on Vista 64 is solved, doing what you suggested:

- start windows vista in safe mode
- delete smartftp registry keys with regedit (hkey_current_user\software\smartftp)
- delete old program files in program files (x86)/Smartftp
- rename users\your_username\AppData\Roaming\Smartftp into Smartftp.backup
- reboot to windown normal mode
- reinstall
- unzip your favourites backup and place them into your appdata smartftp favourites folder

Thank you for your support.

best regards,

Tom

#20 danifer

danifer
  • Members
  • 47 posts

Posted 07 March 2009 - 10:28 AM

tom, I have the same problem (I think) but your solution did not work for me.

did you have problem renaming favourites both in the favourite manager and in the favourite menu?