Jump to content


Photo

Stop Transfer Queue


  • Please log in to reply
20 replies to this topic

#1 marcory

marcory
  • Members
  • 5 posts

Posted 23 February 2009 - 11:41 PM

Que tal , alquien que me ayude pls

Cuando quiero programar (scheduling) alguna tarea el manual indica que detengamos el Stop Transfer Queue sin embargo al realizar este procedimiento mi Transfer Queue se activa inmediatamente por lo que no me da oportunidad a programar tareas. ¿Saben si se tenga que inactivar algun combo o si es cuestion de un timer?
Saludos

#2 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 24 February 2009 - 01:17 AM

You need to stop the transfer queue first.

Regards,
Mat

#3 marcory

marcory
  • Members
  • 5 posts

Posted 24 February 2009 - 04:47 PM

Hi,
Yes but, when I stop the transfer, it immediately restarts..

#4 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 24 February 2009 - 05:07 PM

Hello ..

Are you using the latest version of SmartFTP? Please install it from here (released yesterday):
http://www.smartftp....et/SFTPBeta.exe

Then if you set a start time in the Schedule settings to a future time the item will not be processed immediately.

Regards,
mat

#5 marcory

marcory
  • Members
  • 5 posts

Posted 24 February 2009 - 11:42 PM

I installed the last version but I can´t configure the MONITORING function. Can you explain me?
Please
Regards

Marco

#6 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 24 February 2009 - 11:58 PM

What are you having problems with? You can change the monitor option in the transfer queue item properties. Then go to the Monitor dialog. The monitor options are enabled for local to remote transfers (aka uploads).

#7 marcory

marcory
  • Members
  • 5 posts

Posted 25 February 2009 - 12:57 AM

That is the problem I can´t stop the transfer queue in order to modify the options file, when I stop the transfer queue immediately it restarts by it self and it is done the copy, when stop the transfer queue, immediately it restarts by it self and it is done the copy.

can you tell me how can I do to make pressing the stop button, it will stop and not restart automatically?
Thank

Marco

#8 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 25 February 2009 - 02:08 AM

Set the On Queue Complete option to "Idle". Menu: Tools->Settings "Queue" dialog.

#9 marcory

marcory
  • Members
  • 5 posts

Posted 25 February 2009 - 04:30 PM

Ok but it doesn't change, the aplication restarst immediately. Can you say me if my Queue configuration is correct please:

Number of Workers: 1
Max Speed per worker: 0
Reuse connection in TQ= disable
Automatically remove finished items= enable
Automatically save transfer queue= disable
On aplication start = Stop Queue
On Queue complete = idle

Thks

Marco

#10 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 25 February 2009 - 04:45 PM

Can you please describe your problem again? You are saying you are stopping the transfer queue and it immediately restarts?

If this is the case delete the registry key at:
HKEY_CURRENT_USER\Software\SmartFTP

using regedit.exe

Regards,
Mat

#11 oneballeddie

oneballeddie
  • Members
  • 23 posts

Posted 19 August 2009 - 12:44 PM

Can you please describe your problem again? You are saying you are stopping the transfer queue and it immediately restarts?

If this is the case delete the registry key at:
HKEY_CURRENT_USER\Software\SmartFTP

using regedit.exe

Regards,
Mat



#12 oneballeddie

oneballeddie
  • Members
  • 23 posts

Posted 19 August 2009 - 12:49 PM

I have this problem too. I cannot stop the transfer queue. Click it, stops for half second, then right back to idle state.

Also,the regedit idea does not work: if you try to delete that key you get an error message: cannot delete all the specified values.

Still cannot stop the transfer queue. Therefore cannot schedule a transfer since moving an upload to the transfer queue
causes it to get processed immediately.

Is this a bug in the SmartFTP version I am running? 3.0.1022.38 (Licensed version)

#13 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 19 August 2009 - 12:58 PM

Hello ..

Install the latest version of SmartFTP from here:
http://www.smartftp.com/download

Then if you want to delete the registry key you have to first close SmartFTP.

Regards,
Mat

#14 oneballeddie

oneballeddie
  • Members
  • 23 posts

Posted 19 August 2009 - 01:39 PM

Hi

Closing SmartFTP does not change the inability to delete the registry key.
"Unable to delete all specified values". Is this because it is labeled
as a default key, and the only key in that directory?

#15 oneballeddie

oneballeddie
  • Members
  • 23 posts

Posted 19 August 2009 - 01:41 PM

Hi

Closing SmartFTP does not change the inability to delete the registry key.
"Unable to delete all specified values". Is this because it is labeled
as a default key, and the only key in that directory?


Also, is downloading the latest version going to wipe out all my
connection parameters like it did the last time? That takes me
about 2 hours to reconstruct them.

Thanks

#16 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 19 August 2009 - 01:52 PM

Hello ..

No the upgrade does not wipe out the favorites. Actually it never did.

Regards,
Mat

#17 oneballeddie

oneballeddie
  • Members
  • 23 posts

Posted 19 August 2009 - 02:22 PM

Hello ..

No the upgrade does not wipe out the favorites. Actually it never did.

Regards,
Mat


You are correct, the download did not wipe out the log in settings.

However, still not possible to "stop the transfer queue". Are you saying you can click on the red box and get it to hold in the off/stopped state? Mine immediately reverts to the unstopped idle state with the red box lit back up. This is kind of frustrating since the tutorial on Schedule a Transfer and this dialogue make it seem like it is easy to stop the transfer queue. So far I have downloaded a new version, attempted to change registry keys (all attempts unsuccessful, and, by the way, there are five subdirectories under the path you gave - which to target is unclear, but doesn't matter: you cannot delete any of them), I have gone to the tools->queue menu and changed every possible transfer queue setting to STOP. How can this be? Are marcory and I the only people who cannot stop their transfer queue?

Cannot stop the transfer queue...any suggestions from here?

#18 oneballeddie

oneballeddie
  • Members
  • 23 posts

Posted 19 August 2009 - 02:30 PM

You are correct, the download did not wipe out the log in settings.

However, still not possible to "stop the transfer queue". Are you saying you can click on the red box and get it to hold in the off/stopped state? Mine immediately reverts to the unstopped idle state with the red box lit back up. This is kind of frustrating since the tutorial on Schedule a Transfer and this dialogue make it seem like it is easy to stop the transfer queue. So far I have downloaded a new version, attempted to change registry keys (all attempts unsuccessful, and, by the way, there are five subdirectories under the path you gave - which to target is unclear, but doesn't matter: you cannot delete any of them), I have gone to the tools->queue menu and changed every possible transfer queue setting to STOP. How can this be? Are marcory and I the only people who cannot stop their transfer queue?

Cannot stop the transfer queue...any suggestions from here?


Great Caesar's Ghost! Just as I feared, the new version cannot connect to any of the target machines!
This is what I mean by "wiping out all the connections". Now I get "cannot establish connection because the target machine actively refused it."

#19 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 19 August 2009 - 03:32 PM

This is because your software firewall blocks SmartFTP. Add SmartFTP to the exceptions in the software firewall settings.

Regarding the transfer queue problem. Try this:
http://www.smartftp....ings-f2625.html

This won't delete your favorites but the history. The history is only a list of links to the favorites but not the actual server settings.

If this fails please post the system information from the menu: Help->About "System Informationen"

Regards,
mat

#20 oneballeddie

oneballeddie
  • Members
  • 23 posts

Posted 19 August 2009 - 05:06 PM

This is because your software firewall blocks SmartFTP. Add SmartFTP to the exceptions in the software firewall settings.

Regarding the transfer queue problem. Try this:
http://www.smartftp....ings-f2625.html

This won't delete your favorites but the history. The history is only a list of links to the favorites but not the actual server settings.

If this fails please post the system information from the menu: Help->About "System Informationen"

Regards,
mat


Thank you, Mat, I think I'm going to be operational now. Happily I saved all my connection settings before deleting the registry keys.
I now have scheduled transfers working!

So, if anyone else has this problem where the transfer queue won't stop the quickest solution could be:

1. Save all your connection settings (IP or hostname, username, password) in case you need to do step 4.
2. Download the newest version of SmartFTP
3. Fire it up and see if you can stop the transfer queue, if not
4. Delete the registry folder for the SmartFTP client as described in the article above (see step 1).
5. Fire SmartFTP back up and stop the transfer queue (if it doesn't stop now you are on your own from here)
6. Drag your download/upload file(s) onto the transfer queue.
7. Right click on those you want to schedule, and follow the instructions in the tutorial for "Schedule Transfers" to set your triggers.
8. Restart the transfer queue.

Thanks again for your perserverance and help.
EDS




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users