Jump to content


Photo

cannot download file from z/OS USS


This topic has been archived. This means that you cannot reply to this topic.
7 replies to this topic

#1 myersjj

myersjj
  • Members
  • 5 posts

Posted 11 December 2008 - 09:25 PM

Here is excerpt from system log...

[13:20:46] Transfer failed.
[13:21:16] CWD 'u.myersjj.6100269.build.zOS'
[13:21:16] 501 A qualifier in "u.myersjj.6100269.build.zOS" begins with an invalid character


Here is System Info...
+- System -----------------------------
Microsoft Windows XP Professional
Service Pack 3 (Build 2600)

CPU Speed : 2161 MHz
Total Memory : 2046 MB
Free Memory : 301 MB

+- SmartFTP ---------------------------
Version : 3.0.1024.32
Time Stamp : 2008-11-23 16:59:11
Platform : x86
Id : 400029973
Days in use : 569

+- Application DLL --------------------
sfFTPLib.dll : 1.5.15.6
sfFavorites.dll : 1.0.20.32
sfFavoritesShellExtension.dll : 1.0.1.22
sfTransferQueue.dll : 1.0.17.32
sfFTPShellExtension.dll : 1.0.15.32
SmartFTPPS.dll : 3.0.1024.32

+- Language ---------------------------
SmartFTP.exe : 3.0.1024.32

+- Internet Explorer ------------------
Version : 7.0.5730.11

+- Winsock ----------------------------
Winsock : 2.2

#2 mb

mb

    Developer

  • Administrators
  • 11520 posts

Posted 11 December 2008 - 11:50 PM

Can you please post the log from the remote browser?

What is the correct path?

#3 myersjj

myersjj
  • Members
  • 5 posts

Posted 12 December 2008 - 12:18 AM

The correct path is:
/u/myersjj/6100269/build/zOS/dsmserv.odbc

Here is the full transfer log contents... followed by remote browser log...

[16:14:45] Resolving host name "ezu11.storage.tucson.ibm.com"
[16:14:45] Connecting to 9.11.214.127 Port: 21
[16:14:45] Connected to ezu11.storage.tucson.ibm.com.
[16:14:45] 220-FTP Server (user 'myersjj@us.ibm.com')
[16:14:45] 220
[16:14:45] USER user1
[16:14:45] 331-Password:
[16:14:45] 331
[16:14:45] PASS (hidden)
[16:14:46] 230-220-FTP1 IBM FTP CS V1R8 at EZU11.STORAGE.TUCSON.IBM.COM, 00:14:56 on 2008-12-12.
[16:14:46] 230-USER1 is logged on. Working directory is "TSMWORK.".
[16:14:46] 230
[16:14:46] SYST
[16:14:48] 215 MVS is the operating system of this server. FTP Server is running on z/OS.
[16:14:48] Detected Server Type: MVS
[16:14:48] RTT: 2126.803 ms
[16:14:48] FEAT
[16:14:48] 211 no Extensions supported
[16:14:48] TYPE I
[16:14:49] 200 Representation type is Image
[16:14:49] REST 0
[16:14:49] 504 Restart requires Block or Compressed transfer mode.
[16:14:49] PWD
[16:14:49] 257 "'TSMWORK.'" is working directory.
[16:14:49] CWD 'u.myersjj.6100269.build.zOS'
[16:14:49] 501 A qualifier in "u.myersjj.6100269.build.zOS" begins with an invalid character
[16:14:49] Transfer failed.
[16:15:19] CWD 'u.myersjj.6100269.build.zOS'
[16:15:19] 501 A qualifier in "u.myersjj.6100269.build.zOS" begins with an invalid character
[16:15:19] Transfer failed.
[16:15:49] CWD 'u.myersjj.6100269.build.zOS'
[16:15:49] 501 A qualifier in "u.myersjj.6100269.build.zOS" begins with an invalid character
[16:15:49] Transfer failed.


[16:14:44] SmartFTP v3.0.1024.32
[16:14:46] Resolving host name "ezu11.storage.tucson.ibm.com"
[16:14:46] Connecting to 9.11.214.127 Port: 21
[16:14:46] Connected to ezu11.storage.tucson.ibm.com.
[16:14:46] 220-FTP Server (user 'myersjj@us.ibm.com')
[16:14:46] 220
[16:14:46] USER user1
[16:14:47] 331-Password:
[16:14:47] 331
[16:14:47] PASS (hidden)
[16:14:47] 230-220-FTP1 IBM FTP CS V1R8 at EZU11.STORAGE.TUCSON.IBM.COM, 00:14:57 on 2008-12-12.
[16:14:47] 230-USER1 is logged on. Working directory is "TSMWORK.".
[16:14:47] 230
[16:14:47] SYST
[16:14:49] 215 MVS is the operating system of this server. FTP Server is running on z/OS.
[16:14:49] Detected Server Type: MVS
[16:14:49] RTT: 2107.422 ms
[16:14:49] FEAT
[16:14:50] 211 no Extensions supported
[16:14:50] TYPE I
[16:14:50] 200 Representation type is Image
[16:14:50] REST 0
[16:14:50] 504 Restart requires Block or Compressed transfer mode.
[16:14:50] PWD
[16:14:50] 257 "'TSMWORK.'" is working directory.
[16:14:50] CWD /u/myersjj/6100269/build/zOS
[16:14:50] 250 HFS directory /u/myersjj/6100269/build/zOS is the current working directory.
[16:14:50] PWD
[16:14:50] 257 "/u/myersjj/6100269/build/zOS" is the HFS working directory.
[16:14:50] TYPE A
[16:14:50] 200 Representation type is Ascii NonPrint
[16:14:50] Ignoring LIST options.
[16:14:50] PASV
[16:14:50] 227 Entering Passive Mode (9,11,214,127,4,10)
[16:14:50] Opening data connection to 9.11.214.127 Port: 1034
[16:14:50] LIST
[16:14:51] 125 List started OK
[16:14:51] 10722 bytes transferred. (17.1 KB/s) (609 ms)
[16:14:51] 250 List completed successfully.
[16:14:51] TYPE I
[16:14:51] 200 Representation type is Image
[16:14:51] SIZE dsmfmt
[16:14:52] 501 command aborted - FTP server not configured for SIZE
[16:15:01] The operation has been added to the Transfer Queue. Check the Transfer Queue for the status.
[16:15:22] NOOP
[16:15:22] 200 OK
[16:15:52] NOOP
[16:15:52] 200 OK
[16:16:22] NOOP
[16:16:22] 200 OK
[16:16:52] NOOP
[16:16:52] 200 OK
[16:17:23] NOOP
[16:17:23] 200 OK

#4 mb

mb

    Developer

  • Administrators
  • 11520 posts

Posted 12 December 2008 - 04:39 AM

Thank you.

When you right-click the file in the transfer queue and select Properties dialog what do you see in the Source path? A unix or MVS like path?

Regards,
Mat

#5 myersjj

myersjj
  • Members
  • 5 posts

Posted 12 December 2008 - 05:21 PM

I see this:

/u/myersjj/6100269/build/zOS/dsmserv.odbc


Thank you.

When you right-click the file in the transfer queue and select Properties dialog what do you see in the Source path? A unix or MVS like path?

Regards,
Mat



#6 mb

mb

    Developer

  • Administrators
  • 11520 posts

Posted 14 December 2008 - 10:37 PM

Can you try it again with the newest version?
http://www.smartftp....et/SFTPBeta.exe

If you have the opportunity please download a file from a non-HFS location as well.

Thank you
Mat

#7 myersjj

myersjj
  • Members
  • 5 posts

Posted 15 December 2008 - 05:46 PM

OK, I tried with the new version and it works fine for both USS and regular MVS files! Thanks!

I did notice one small nuisance: when install completes it asks if I want to start SmartFTP, so I clicked the box, then OK, then it tells me I have to reboot.

#8 mb

mb

    Developer

  • Administrators
  • 11520 posts

Posted 15 December 2008 - 07:00 PM

Thank you for your feedback.

>Setup
Yes the [x] Launch SmartFTP box should not be displayed when a restart is required.

Regards,
Mat