Jump to content


Photo

425 No data connection


This topic has been archived. This means that you cannot reply to this topic.
9 replies to this topic

#1 Coastal Web

Coastal Web
  • Members
  • 28 posts

Posted 17 November 2008 - 07:08 PM

I am unable to access an FTP account that l've been using for years. I am ultimately giving the following error:
425 No data connection

I've rebooted my PC. I've deleted the favorite and re-added it. I've had a friend test the FTP site on his computer (same building/network) and he was able to access the FTP server using dreamweavers built in ftp software... any idea what could be causing this?


Complete log:
[11:05:33] SmartFTP v3.0.1022.10
[11:05:33] Resolving host name "bandonvisitorsguide.com"
[11:05:33] Connecting to 207.44.167.242 Port: 21
[11:05:33] Connected to bandonvisitorsguide.com.
[11:05:33] 220---------- Welcome to Pure-FTPd [TLS] ----------
[11:05:33] 220-You are user number 1 of 50 allowed.
[11:05:33] 220-Local time is now 11:05. Server port: 21.
[11:05:33] 220-This is a private system - No anonymous login
[11:05:33] 220-IPv6 connections are also welcome on this server.
[11:05:33] 220 You will be disconnected after 15 minutes of inactivity.
[11:05:33] USER bandonvi
[11:05:34] 331 User bandonvi OK. Password required
[11:05:34] PASS (hidden)
[11:05:34] 230-User bandonvi has group access to: bandonvi
[11:05:34] 230 OK. Current restricted directory is /
[11:05:34] SYST
[11:05:34] 215 UNIX Type: L8
[11:05:34] Detected Server Type: UNIX
[11:05:34] FEAT
[11:05:34] 211-Extensions supported:
[11:05:34] EPRT
[11:05:34] IDLE
[11:05:34] MDTM
[11:05:34] SIZE
[11:05:34] REST STREAM
[11:05:34] MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
[11:05:34] MLSD
[11:05:34] ESTP
[11:05:34] PASV
[11:05:34] EPSV
[11:05:34] SPSV
[11:05:34] ESTA
[11:05:34] AUTH TLS
[11:05:34] PBSZ
[11:05:34] PROT
[11:05:34] 211 End.
[11:05:34] Detected Server Software: PureFTPd
[11:05:34] PWD
[11:05:34] 257 "/" is your current location
[11:05:35] TYPE A
[11:05:35] 200 Command okay.
[11:05:35] PASV
[11:05:35] 227 Entering Passive Mode (10,1,2,235,222,222)
[11:05:35] Passive ip address returned from server different from server ip.
[11:05:35] Opening data connection to 10.1.2.235 Port: 57054
[11:05:35] MLSD
[11:05:35] 425 No data connection
[11:05:35] 0 bytes transferred. (0 bytes/s) (78 ms)
[11:05:35] Automatic failover of data connection mode from "Passive Mode (PASV)" to "Active Mode (PORT)".
[11:05:35] PORT 10,43,21,25,4,185
[11:05:35] 200 PORT command successful.
[11:05:35] MLSD
[11:05:35] 425 No data connection

#2 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 17 November 2008 - 07:13 PM

Hello ..

1. Menu: Favorites->Edit Favorites
2. Locate your favorite (go to the Quick Connect folder)
3. Right-click on your favorite then select Properties from the context menu
4. Go to the FTP->Connection dialog. Then change the Force PASV IP option to Enable
5. Click OK a couple of times

Regards,
Mat

#3 Coastal Web

Coastal Web
  • Members
  • 28 posts

Posted 17 November 2008 - 07:26 PM

Hello ..

1. Menu: Favorites->Edit Favorites
2. Locate your favorite (go to the Quick Connect folder)
3. Right-click on your favorite then select Properties from the context menu
4. Go to the FTP->Connection dialog. Then change the Force PASV IP option to Enable
5. Click OK a couple of times

Regards,
Mat


Hi mb, thanks for the quick response.
I've made this change, and restarted SmartFTP; but l still get the same results.

#4 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 17 November 2008 - 08:20 PM

Post the new log.

#5 Coastal Web

Coastal Web
  • Members
  • 28 posts

Posted 17 November 2008 - 11:20 PM

[15:20:24] SmartFTP v3.0.1022.10
[15:20:24] Resolving host name "bandonvisitorsguide.com"
[15:20:24] Connecting to 207.44.167.242 Port: 21
[15:20:24] Connected to bandonvisitorsguide.com.
[15:20:24] 220---------- Welcome to Pure-FTPd [TLS] ----------
[15:20:24] 220-You are user number 1 of 50 allowed.
[15:20:24] 220-Local time is now 15:19. Server port: 21.
[15:20:24] 220-This is a private system - No anonymous login
[15:20:24] 220-IPv6 connections are also welcome on this server.
[15:20:25] 220 You will be disconnected after 15 minutes of inactivity.
[15:20:25] USER bandonvi
[15:20:25] 331 User bandonvi OK. Password required
[15:20:25] PASS (hidden)
[15:20:25] 230-User bandonvi has group access to: bandonvi
[15:20:25] 230 OK. Current restricted directory is /
[15:20:25] SYST
[15:20:25] 215 UNIX Type: L8
[15:20:25] Detected Server Type: UNIX
[15:20:25] FEAT
[15:20:25] 211-Extensions supported:
[15:20:25] EPRT
[15:20:25] IDLE
[15:20:25] MDTM
[15:20:25] SIZE
[15:20:25] REST STREAM
[15:20:25] MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
[15:20:25] MLSD
[15:20:25] ESTP
[15:20:25] PASV
[15:20:25] EPSV
[15:20:25] SPSV
[15:20:25] ESTA
[15:20:25] AUTH TLS
[15:20:25] PBSZ
[15:20:25] PROT
[15:20:25] 211 End.
[15:20:25] Detected Server Software: PureFTPd
[15:20:25] PWD
[15:20:25] 257 "/" is your current location
[15:20:26] TYPE A
[15:20:26] 200 Command okay.
[15:20:26] PORT 10,43,21,25,14,72
[15:20:26] 200 PORT command successful.
[15:20:26] MLSD
[15:20:26] 425 No data connection
[15:20:26] Automatic failover of data connection mode from "Active Mode (PORT)" to "Passive Mode (PASV)".
[15:20:26] PASV
[15:20:26] 227 Entering Passive Mode (10,1,2,235,171,136)
[15:20:26] Passive ip address returned from server different from server ip.
[15:20:26] Opening data connection to 207.44.167.242 Port: 43912
[15:20:26] MLSD
[15:20:26] 425 No data connection

#6 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 18 November 2008 - 08:46 AM

Install the latest version:
http://www.smartftp....get/SFTPMSI.exe

Did you add SmartFTP to the exceptions in your software firewall?

#7 Coastal Web

Coastal Web
  • Members
  • 28 posts

Posted 18 November 2008 - 05:12 PM

Hello, l've updated to the most recent version (per your link), rebooted and tried again and l'm still getting the same thing:
We do not have any type of firewall taht would be blocking this, besides it's working for some other FTP accounts (on another server). Any other suggestions?

[09:12:10] SmartFTP v3.0.1024.26
[09:12:10] Resolving host name "102things2do.com"
[09:12:10] Connecting to 207.44.167.244 Port: 21
[09:12:10] Connected to 102things2do.com.
[09:12:11] 220---------- Welcome to Pure-FTPd [TLS] ----------
[09:12:11] 220-You are user number 2 of 50 allowed.
[09:12:11] 220-Local time is now 09:11. Server port: 21.
[09:12:11] 220-This is a private system - No anonymous login
[09:12:11] 220-IPv6 connections are also welcome on this server.
[09:12:11] 220 You will be disconnected after 15 minutes of inactivity.
[09:12:11] USER letsgo07
[09:12:11] 331 User letsgo07 OK. Password required
[09:12:11] PASS (hidden)
[09:12:11] 230-User letsgo07 has group access to: letsgo07
[09:12:11] 230 OK. Current restricted directory is /
[09:12:11] SYST
[09:12:11] 215 UNIX Type: L8
[09:12:11] Detected Server Type: UNIX
[09:12:11] RTT: 152.001 ms
[09:12:11] FEAT
[09:12:11] 211-Extensions supported:
[09:12:11] EPRT
[09:12:11] IDLE
[09:12:11] MDTM
[09:12:11] SIZE
[09:12:11] REST STREAM
[09:12:11] MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
[09:12:11] MLSD
[09:12:11] ESTP
[09:12:11] PASV
[09:12:11] EPSV
[09:12:11] SPSV
[09:12:12] ESTA
[09:12:12] AUTH TLS
[09:12:12] PBSZ
[09:12:12] PROT
[09:12:12] 211 End.
[09:12:12] Detected Server Software: PureFTPd
[09:12:12] PWD
[09:12:12] 257 "/" is your current location
[09:12:12] TYPE A
[09:12:12] 200 Command okay.
[09:12:12] PASV
[09:12:12] 227 Entering Passive Mode (10,1,2,235,249,64)
[09:12:12] Passive ip address returned from server different from server ip.
[09:12:12] Substituting received PASV address 235.2.1.10 to server address 244.167.1.207.
[09:12:12] Opening data connection to 207.44.167.244 Port: 63808
[09:12:12] MLSD
[09:12:12] 425 No data connection
[09:12:12] Automatic failover of data connection mode from "Passive Mode (PASV)" to "Active Mode (PORT)".
[09:12:13] PORT 10,43,21,25,4,119
[09:12:13] 200 PORT command successful.
[09:12:13] MLSD
[09:12:13] 425 No data connection

#8 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 18 November 2008 - 05:14 PM

It looks like a network problem (software firewall or antivirus product blocking the data connection) or a problem with the server to me.

#9 Coastal Web

Coastal Web
  • Members
  • 28 posts

Posted 18 November 2008 - 06:47 PM

Hello,

I wanted to let you know we've been able to access FTP now by uninstalling the most recent windows XP security update, and by changing the FTP module on our server from PureFTP to ProFTP. Seems to be a conflict ion between the two for some reason or another.

I just thought l'd let you know incase anyone else runs into this problem.

#10 Александръ

Александръ
  • Members
  • 1 posts

Posted 31 December 2008 - 09:32 AM

Thanks, I had the same problem. It’s working now. Would’ve never thought of it…