Jump to content


Photo

SFTP Uploading Zip files


  • Please log in to reply
4 replies to this topic

#1 assier

assier
  • Members
  • 3 posts

Posted 23 October 2008 - 10:32 PM

Hello,

I am trying to upload Zip files and other binary files to an SFTP server. Uploading appears to complete, but in actual fact doesn't since the transferred file size on the server is always 0KB. Other file types this happens with are RAR, XLS, PDF. This doesn't happen with TXT, XML etc. I set the transfer mode to Binary but this didn't make any difference.

+- System -----------------------------
Microsoft Windows XP Professional
Service Pack 2 (Build 2600)

CPU Speed : 1995 MHz
Total Memory : 2046 MB
Free Memory : 1219 MB

+- SmartFTP ---------------------------
Version : 3.0.1023.4
Time Stamp : 2008-09-30 01:00:16
Platform : x86
Unlicensed
Days in use : 3

+- Application DLL --------------------
sfFTPLib.dll : 1.5.14.6
sfFavorites.dll : 1.0.19.4
sfFavoritesShellExtension.dll : 1.0.1.14
sfTransferQueue.dll : 1.0.16.4
sfFTPShellExtension.dll : 1.0.14.4
SmartFTPPS.dll : 3.0.1023.4

+- Language ---------------------------
SmartFTP.exe : 3.0.1023.4

+- Internet Explorer ------------------
Version : 7.0.5730.11

+- Winsock ----------------------------
Winsock : 2.2

[23:08:30] SmartFTP v3.0.1023.4
[23:08:30] Resolving host name "*****"
[23:08:30] Connecting to ***** Port: 22
[23:08:31] Starting SSH session. Remote Id: "SSH-2.0-ReflectionForSecureIT_6.1.0.16 - Process Software MultiNet"
[23:08:31] Initiating key exchange.
[23:08:32] Computing session key.
[23:08:32] Key Exchange Algorithm: diffie-hellman-group1-sha1
[23:08:32] Key exchange completed.
[23:08:32] Host Key Algorithm: ssh-dss
[23:08:32] Client to Server Encryption: aes256-ctr
[23:08:32] Server to Client Encryption: aes256-ctr
[23:08:32] Session HMAC: hmac-sha1
[23:08:32] Client to Server Compression: zlib
[23:08:32] Server to Client Compression: zlib
[23:08:32] Authentication request. Method: "password"
[23:08:33] User authentication successful.
[23:08:33] SSH session established.
[23:08:33] Connected to *****.
[23:08:34] SFTP protocol version 3
[23:08:34] Detected Server Software: Unknown
[23:08:34] Resolving path ".".
[23:08:34] Path successfully resolved.
[23:08:47] Resolving path "/*****/test".
[23:08:47] Path successfully resolved.
[23:08:47] Reading directory "/*****/test".
[23:08:47] 0 bytes transferred. (0 bytes/s) (140 ms)
[23:08:47] Directory listing complete.
[23:09:01] Getting attributes of "/*****/Master2.zip".
[23:09:01] 2 syserr: no such file or directory, file: *****[*****.test]$M$ASTER2.ZIP
[23:09:01] The operation has been added to the Transfer Queue. Check the Transfer Queue for the status.
[23:09:06] Getting attributes of "/*****/test/Master2.zip".
[23:09:06] Attributes successfully obtained.

Posted Image

Please advise,

thank you.

#2 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 23 October 2008 - 10:44 PM

Did you refresh the folder after your uploads completed?

What do you see in the transfer queue window? Menu: View->Other Windows->Transfer Queue

Is there any chance we can get a test account for 24h on this server?

Regards,
Mat

#3 assier

assier
  • Members
  • 3 posts

Posted 23 October 2008 - 11:15 PM

Did you refresh the folder after your uploads completed?

What do you see in the transfer queue window? Menu: View->Other Windows->Transfer Queue

Is there any chance we can get a test account for 24h on this server?

Regards,
Mat


Hi Mat,

I have refreshed the remote folder many several times, as well as verifying the 0KB file size on a seperate SSH terminal (VMS Server).

Unfortunately, I can't provide access to it, as it is through a VPN.

As for the Transfer Queue, the status field changes from:

connecting -> pre-transfer -> (0 bytes / X MB) 0%

After that the the item gets removed from the queue.

I have uploaded to this server using other clients that support SFTP and I have had no similar issue.

#4 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 23 October 2008 - 11:40 PM

Can you try it again with the latest version of SmartFTP:
http://www.smartftp....et/SFTPBeta.exe

Please also try to get the log from the trasnfer queue. To do this:
1. Stop the transfer queue
2. Do the drag&drop operation
3. Double click the file in the transfer queue
4. Start the transfer queue

If the problem persists we need a test account on the server to look at it.

Regards,
Mat

#5 assier

assier
  • Members
  • 3 posts

Posted 24 October 2008 - 10:34 AM

I tried again with the latest version and now it's working everytime.

Many thanks!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users