Jump to content


Photo

"Verify Class ID" error prevents SFTP from starting


This topic has been archived. This means that you cannot reply to this topic.
30 replies to this topic

#1 webzy

webzy
  • Members
  • 12 posts

Posted 27 August 2008 - 07:46 PM

Hi,

I have just purchased the professional version of SFTP today (Aug 27, 2008) and downloaded the newest version.
Before installing I uninstalled the old free version, because it didn't work anymore, then I installed the new version.

I got the following error (screenshots):
Posted Image
Posted Image
Posted Image
Posted Image
Posted Image
Posted Image

I am not able to take any traces or core dumps, because SFTP fails to even start.

I found out somewhere through google that probably (after some Windows XP security update) the Class ID has to be specifically allowed, so most likely the error "sfFTPShellExtension.dll shell extension is disabled or not correctly registered. hr=0x80070005" says that this shell extension is not enabled/allowed in the registry.

I checked in the shell extensions in the registry, but could not see this one. I saw some other SmartFTP extensions on the list, but not this one.

Could you help me, please!!!

I really liked the old SFTP and that's the reason I bought the new one. If it doesn't now work, what's the use paying for it?!?!?

How can I manually enter the correct stuff in the registry to fix this problem? What key and value do I enter and where?

As I said at the beginning, don't ask me to provide traces, because SFTP does not even start.

webzy

Edited by mb, 12 September 2008 - 07:57 AM.


#2 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 27 August 2008 - 08:30 PM

Hello ..

The Verify Class Id window originates from the verclsid.exe program from Microsoft.

What kind of software firewall or antivirus product do you have instaleld? Can you try to disable them and try again?

Do you have all Security/Important Updates installed from WindowsUpdate?

Regards,
mat

#3 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 27 August 2008 - 08:37 PM

Just for reference this KB article may be related to your problem:
http://support.microsoft.com/kb/918165

#4 webzy

webzy
  • Members
  • 12 posts

Posted 27 August 2008 - 08:42 PM

Hi

What kind of software firewall or antivirus product do you have instaleld? Can you try to disable them and try again?
Do you have all Security/Important Updates installed from WindowsUpdate?


Yes, I do have both (CyberArmor firewall and Symantec AntiVirus), but they do not react to SFTP at all. They never did with the old version anyways. I think it's something with the DLLs or at least with the one DLL -> sfFTPShellExtension.dll
How do I register or enable it in the registry???

BTW, I can't, just like that, disable or uninstall my firewall or antivirus softwares. Why would I have to do that?

webzy

#5 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 27 August 2008 - 08:45 PM

The problem is very likely related to/caused by the software firewall or antivirus product. That's the reason why my recommendation was to disable or uninstall them temporary.

The old version did not use the same dlls and therefore was not affected by this problem.

Regards,
Mat

#6 webzy

webzy
  • Members
  • 12 posts

Posted 27 August 2008 - 09:03 PM

Just for reference this KB article may be related to your problem:
http://support.microsoft.com/kb/918165


I know. That's where I found some info before I asked for help here in this forum. The problem they describe looks very similar, but the solution they suggest does not help me with SFTP, because I still don't know how to enable the shell extensions specific to SFTP.

webzy

#7 webzy

webzy
  • Members
  • 12 posts

Posted 27 August 2008 - 09:05 PM

The problem is very likely related to/caused by the software firewall or antivirus product. That's the reason why my recommendation was to disable or uninstall them temporary.


Oh, so you mean I should only disable them when I install SFTP, but then I can enable these programs again?

webzy

#8 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 27 August 2008 - 09:22 PM

Hello webzy

We believe there is a bug in the CyberArmor software which prevents SmartFTP from working correctly. To confirm this you would need to uninstall CyberArmor and then reinstall SmartFTP and see if it works without CyberArmor installed.

Why do we think so? Because another customer reported a similar problem and he also has the CyberArmor product installed.

Regards,
Mat

#9 webzy

webzy
  • Members
  • 12 posts

Posted 27 August 2008 - 09:53 PM

We believe there is a bug in the CyberArmor software which prevents SmartFTP from working correctly. To confirm this you would need to uninstall CyberArmor and then reinstall SmartFTP and see if it works without CyberArmor installed.


OK, I'll try that then... but will I be able to install CA after installing SFTP?... will see, I guess...

webzy

#10 webzy

webzy
  • Members
  • 12 posts

Posted 28 August 2008 - 07:22 AM

Hi,

Unfortunately after disabling CyberArmor and reinstalling SFTP the problem is still there.

I would really like someone to tell me how to edit the registry to allow/enable/register sfFTPShellExtension.dll based on the instructions from Microsoft you gave me in your email earlier.

All I need is the info on how to manually add SFTP shell extensions to the registry, specifically the sfFTPShellExtension.dll. I have not yet checked in the registry whether the other DLLs need registering as well : sfFTPLib.dll , sfFavorites.dll , sfFavoritesShellExtension.dll , sfTransferQueue.dll
but once I have the sfFTPShellExtension.dll problem taken care of, I can worry about those.

webzy

#11 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 28 August 2008 - 04:24 PM

Did you uninstall CyberArmor (disabling is not enough).

Regards,
Mat

#12 webzy

webzy
  • Members
  • 12 posts

Posted 28 August 2008 - 08:01 PM

Did you uninstall CyberArmor (disabling is not enough).


No, unfortunately I don't have enough rights on my work laptop (even though I have admin rights) to do that. Firewall and probably a couple of other SWs are password protected by some IT guys form support desk. I can't ask them to do that either, because we're supposed to have CA installed B)

I used to use your old SFTP with no problems even with all the "security" SWs and encryption etc. I was not able to use it while at work, but at home no problem.

Is there anything else I could do??? What do you think about my question about the registry manipulation? That I could do without asking any permission :( They would not like it, of course, but then again, they would not like 99% of stuff I do to my laptop or with my laptop :(

webzy

#13 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 28 August 2008 - 08:30 PM

Hello webzy ..

Click Start, click Run, type regedit, and then click OK.

Go to the following registry key:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Shell Extensions\Cached

Then create a new DWORD value. The name of this value is as following:
{82AA9188-44E0-40B9-B956-43A10C315B4F} {000214E6-0000-0000-C000-000000000046} 0x401
And the value has to be set to 1

Exit Registry Editor.

Restart the computer

Regards,
Mat

#14 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 28 August 2008 - 09:16 PM

As far as I understand it the registry key in the Cached key causes the verclsid.exe to bypass the check. There is a good article at:
http://searchenterpr...1189210,00.html

This should not be necessary since our shell extension doesn't do anything weird. But it may fix the problem with the firewall.

Regards,
Mat

#15 webzy

webzy
  • Members
  • 12 posts

Posted 28 August 2008 - 09:47 PM

As far as I understand it the registry key in the Cached key causes the verclsid.exe to bypass the check. There is a good article at:
http://searchenterpr...1189210,00.html

This should not be necessary since our shell extension doesn't do anything weird. But it may fix the problem with the firewall.

Regards,
Mat


Thanks Mat. I did both things you suggested: I first run the exe you pointed me to and after that I did the registry trick, rebooted, etc.

Something must have worked because I can now open and use the SFTP

BUT B) there are still some "Verify Class ID" errors occuring from time to time, especially while trying to view the contents of a directory, but at least I can do what I want.

I will dig some more in the registry and try to put a few more keys in the cache, like the one I just did.

For now the biggest problem is over :( I am happy.

I will let you know what I was able to do more to get rid of the other errors, but not now, 'cause it's 12:45am here and I really am sleepy :(

Have a good evening and "talk" to you soon.

webzy

#16 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 28 August 2008 - 09:55 PM

Oh now we don't know what actually "fixed" the problem :-(

Regards,
Mat

#17 webzy

webzy
  • Members
  • 12 posts

Posted 29 August 2008 - 11:46 PM

Oh now we don't know what actually "fixed" the problem :-(

Regards,
Mat

Well, the exe you gave me actually made it possible for SFTP to start, but the errors are still there.

I don't know what did the creating of the registry key do, but I will experiment and let you know :(

webzy

#18 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 04 September 2008 - 09:24 PM

Hello webzy ..

What version of CyberArmor are you running?

Regards,
Mat

#19 webzy

webzy
  • Members
  • 12 posts

Posted 05 September 2008 - 05:49 PM

Hello webzy ..

What version of CyberArmor are you running?


Hi,

Version 3.0.40520B

webzy

#20 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 05 September 2008 - 06:49 PM

Can you please install the latest version 3.5?

It seems they have fixed the bug in this version.

Thank you
Regards,
Mat