Jump to content


Photo

Remote Edit problem, Cannot use Notepad++


This topic has been archived. This means that you cannot reply to this topic.
31 replies to this topic

#1 Andy Hopkins

Andy Hopkins
  • Members
  • 16 posts

Posted 22 July 2008 - 07:41 PM

Hi,

In Smartftp 2 I had no problems using Notepad++ to edit my online files.

However, in smartftp 3 I just cannot get Notepad++ to work.

I am aware, from reading the forum that this works fine with Notepad, but notepad is at least useless in editing files as it can't interpret most PHP files I create, or are created.

For me, this is a big show stopper for me to purchasing SmartFTP, A program that I have been using for many years, does what I want, and one that I am willing to pay for. But if I can't use another editor other than Notepad, I will be inclined to stop using it. This I hope will not happen.



My settings:

I am using Notepad++ 5.0.2

+- System -----------------------------
Microsoft Windows XP Professional
Service Pack 3 (Build 2600)

CPU Speed : 2814 MHz
Total Memory : 2047 MB
Free Memory : 2047 MB

+- SmartFTP ---------------------------
Version : 3.0.1020.4
Time Stamp : 2008-07-22 03:55:54
Platform : x86
Unlicensed
Days in use : 22

+- Application DLL --------------------
sfFTPLib.dll : 1.5.13.36
sfFavorites.dll : 1.0.16.4
sfFavoritesShellExtension.dll : 1.0.1.13
sfTransferQueue.dll : 1.0.13.4
sfFTPShellExtension.dll : 1.0.11.4

+- Language ---------------------------
SmartFTP.exe : 3.0.1020.4

+- Internet Explorer ------------------
Version : 6.0.2900.5512

+- Winsock ----------------------------
Winsock : 2.2

#2 mb

mb

    Developer

  • Administrators
  • 11799 posts

Posted 22 July 2008 - 07:45 PM

It works perfectly with Notepad++ here and I use it daily. What exactly is not working for you?

Regards,
Mat

#3 Andy Hopkins

Andy Hopkins
  • Members
  • 16 posts

Posted 22 July 2008 - 08:46 PM

It works perfectly with Notepad++ here and I use it daily. What exactly is not working for you?

Regards,
Mat



Hi Mat,

It simply doesn't work, I doesn't upload the file.

However, I have noticed one thing.

I have Office 2003 on my PC. I have noticed, that when ever I try the edit feature I can see that the office XML editor, Microsft 2003 compents are constantly loading and closing take quite a cpu cyles.

From this point on I cannot get any editor feature to work.

Please see the attached image.

Posted Image

This will continue untill I either log out or reboot.

Edited by Andy Hopkins, 22 July 2008 - 08:47 PM.


#4 mb

mb

    Developer

  • Administrators
  • 11799 posts

Posted 22 July 2008 - 08:57 PM

Do you select Notepad++ in the Edit context menu?

When you go to the menu: Favorites->Edit Favorites. Is everything displayed correctly there?

Do you have any kind of software firewall or antivirus product installed? If yes try to uninstall them and then reinstall SmartFTP. We had similar problems with other users where these application just blocked components in SmartFTP.

Regards,
Mat

#5 Andy Hopkins

Andy Hopkins
  • Members
  • 16 posts

Posted 22 July 2008 - 09:52 PM

Do you select Notepad++ in the Edit context menu?

When you go to the menu: Favorites->Edit Favorites. Is everything displayed correctly there?

Do you have any kind of software firewall or antivirus product installed? If yes try to uninstall them and then reinstall SmartFTP. We had similar problems with other users where these application just blocked components in SmartFTP.

Regards,
Mat


Hi Mat,

Thanks for staying with me on this,

When I look at my favourites It seems to be displaying the folder C:\documents and settings\<my profile>\applications data??

Notepad++ is setup as the default viewer also editor.

I can even see after I have closed notepad++ that the monitoring is still running.

I use Eset (Nod32) as my AV,

I don't use a firewall, as I am behind a router + firewall.

I will try and dis-able my AV and re-install SmartFTP.

Regards,

Andy

#6 mb

mb

    Developer

  • Administrators
  • 11799 posts

Posted 22 July 2008 - 09:59 PM

Hello ...

The file that is being monitored is not automatically removed from the transfer queue. That's not the problem. But I think the problem is with the favorites. More specficially with the favorites folder or the shell extension. Nod32 is not causing any problems with SmartFTP so don't disable/uninstall it.

Please verify your favorites folder:
menu: Tools->Settings. Then go to the Favorites dialog and check the path to the Personal Favorites. It should be C:\documents and settings\<my profile>\applications data\SmartFTP\Client 2.0\Favorites

Can you send a screenshot of the edit favorites window? Thanks.

Regards,
Mat

#7 Andy Hopkins

Andy Hopkins
  • Members
  • 16 posts

Posted 22 July 2008 - 10:33 PM

Hello ...

The file that is being monitored is not automatically removed from the transfer queue. That's not the problem. But I think the problem is with the favorites. More specficially with the favorites folder or the shell extension. Nod32 is not causing any problems with SmartFTP so don't disable/uninstall it.

Please verify your favorites folder:
menu: Tools->Settings. Then go to the Favorites dialog and check the path to the Personal Favorites. It should be C:\documents and settings\<my profile>\applications data\SmartFTP\Client 2.0\Favorites

Can you send a screenshot of the edit favorites window? Thanks.

Regards,
Mat


Hi

I tried to change the favourites to as you mentioned, however, I am unable to point to the correct folder. (see image)

Posted Image

If I paste in the correct folder, ie from what you have mentioned above, adding my profile, smartFTP simply shuts down when I press the OK button.

My favourites image as requested


Posted Image

I hope this helps.

Regards,

Andy Hopkins

#8 mb

mb

    Developer

  • Administrators
  • 11799 posts

Posted 22 July 2008 - 10:39 PM

Hello ..

1. Go to the Application Data folder in Windows Explorer and copy all the .xml files to another place.

2. Then open regedit.exe and delete the following registry key:
HKEY_CURRENT_USER\Software\SmartFTP\Client 2.0

3. You may need to copy the favorites back from the folder in 1. once the correct folder has been created.

Regards,
Mat

#9 Andy Hopkins

Andy Hopkins
  • Members
  • 16 posts

Posted 22 July 2008 - 11:50 PM

Hello ..

1. Go to the Application Data folder in Windows Explorer and copy all the .xml files to another place.

2. Then open regedit.exe and delete the following registry key:
HKEY_CURRENT_USER\Software\SmartFTP\Client 2.0

3. You may need to copy the favorites back from the folder in 1. once the correct folder has been created.

Regards,
Mat


Hi,

I did step 1, no problems, I did step 2, big problems,

I couldn't get smart FTP to work at all?! It now refuses to load up.

I have restored my system from a backup. So I am back to where I was..

#10 mb

mb

    Developer

  • Administrators
  • 11799 posts

Posted 23 July 2008 - 12:06 AM

Did you move your application data folder (in Windows) to another location from the default?

What error did you get after you removed the registry key?

Please install and run SmartFTP from a different user account on your system.

Regards,
Mat

#11 mb

mb

    Developer

  • Administrators
  • 11799 posts

Posted 23 July 2008 - 12:10 AM

Also try the same thing again with the registry key. Instead of removing it, rename "Client 2.0" to "Client 2.0 Backup".

Then rename the "C:\Document and Settings\andyman77\Application Data" folder to something else. E.g. "Application Data Backup"

Then start SmartFTP.

Regards,
Mat

#12 Andy Hopkins

Andy Hopkins
  • Members
  • 16 posts

Posted 23 July 2008 - 12:17 AM

Did you move your application data folder (in Windows) to another location from the default?

What error did you get after you removed the registry key?

Please install and run SmartFTP from a different user account on your system.

Regards,
Mat


yep, I removed it completely to allow it to be restored correctly (like a clean install)

I got no error other than smartftp simply not loading at all.

On re-installing I noted that the registry settings didn't appear to return.

#13 mb

mb

    Developer

  • Administrators
  • 11799 posts

Posted 23 July 2008 - 12:20 AM

Okay could you please try the above? The registry key will be created the first time you run SmartFTP.

Regards,
Mat

#14 Andy Hopkins

Andy Hopkins
  • Members
  • 16 posts

Posted 23 July 2008 - 07:55 AM

Okay could you please try the above? The registry key will be created the first time you run SmartFTP.

Regards,
Mat


Hi Mat,

I installed, uninstalled SmartFTP about 3 times, I got the same error on all 3 occasions.

Each time I checked the registry to see if the information would come back. It didn't appear to.

I have now restored my PC back to an earlier time in the day. I am happy to start again with the testing.

#15 mb

mb

    Developer

  • Administrators
  • 11799 posts

Posted 23 July 2008 - 01:56 PM

Did you try the suggestions in my last posts? Also could you answer my earlier questions?

#16 Andy Hopkins

Andy Hopkins
  • Members
  • 16 posts

Posted 23 July 2008 - 04:12 PM

Did you try the suggestions in my last posts? Also could you answer my earlier questions?



Hi Mat, I cannot possibly rename the folder
C:\Document and Settings\andyman77\Application Data

I'm sure you realise which folder this is and how critical it is for all other applications I have running.

I will try and complete the other details when I return home.

I have a full back up of all my data, so, all has been recovered, registry info included.

I should return home in the next 2 to 3 hours.

Many thanks.

#17 mb

mb

    Developer

  • Administrators
  • 11799 posts

Posted 23 July 2008 - 04:20 PM

Hello Andy ..

I understand. My assumption was that you moved the Application Data folder to another location (this is possible in Windows).

Try to delete the following folder instead:
C:\Document and Settings\andyman77\Application Data\SmartFTP

And then delete or move all the .xml files (favorites) in the C:\Document and Settings\andyman77\Application Data to another folder. Also there is a desktop.ini in this folder delete it or move it somewhere. You may only see this desktop.ini when you enable "Show Hidden Files and Folders" and disable "Hide protected system files" in the Windows Explorer options.

Regards,
Mat

#18 Andy Hopkins

Andy Hopkins
  • Members
  • 16 posts

Posted 23 July 2008 - 08:51 PM

Hello Andy ..

I understand. My assumption was that you moved the Application Data folder to another location (this is possible in Windows).

Try to delete the following folder instead:
C:\Document and Settings\andyman77\Application Data\SmartFTP

And then delete or move all the .xml files (favorites) in the C:\Document and Settings\andyman77\Application Data to another folder. Also there is a desktop.ini in this folder delete it or move it somewhere. You may only see this desktop.ini when you enable "Show Hidden Files and Folders" and disable "Hide protected system files" in the Windows Explorer options.

Regards,
Mat


Hi Matt

OK, the favourites are have now been fixed and are point to the correct folder C:\Documents and Settings\andyman77\Application Data\SmartFTP\Client 2.0\Favorites.

Now there is only the editing with notepad++ that isn't working correctly. :(

I can open/edit the file in Notepad++ when I save the file, it doesn't appear to get uploaded at all.

If I try to open a 2nd file, it simply does not open in notepad++ at all.

Regards,

Andy

#19 mb

mb

    Developer

  • Administrators
  • 11799 posts

Posted 23 July 2008 - 08:55 PM

Ah good.

I will try to reproduce it on Windows XP again with the latest Notepad++ version.

Regards,
Mat

#20 mb

mb

    Developer

  • Administrators
  • 11799 posts

Posted 23 July 2008 - 09:22 PM

Hello ..

Works as expected on the test systems I tested it. You said the 2nd file doesn't open. Is the item added to the transfer queue?

Regards,
Mat