Jump to content


Photo

User Authentication Failed


  • Please log in to reply
2 replies to this topic

#1 jmarmash

jmarmash
  • Members
  • 11 posts

Posted 22 July 2008 - 06:05 PM

I copied the C# example from the samples folder and placed it in a simple application. It appears to validate the license and read my private key but, when it tries to connect, I get a "ftpErrorConnect" message. To test, I used the client with the same connection information and private key location and was able to connect. Both the client and my code point to the same file location for the private key.

Here is the successful connection log via the client
[codebox][13:46:18] SmartFTP v3.0.1018.1
[13:46:20] Resolving host name "hsn.xfer.youtube.com"
[13:46:20] Connecting to 208.65.153.158 Port: 22
[13:46:21] Starting SSH session. Remote Id: "SSH-1.99-OpenSSH_4.2"
[13:46:21] Initiating key exchange.
[13:46:22] Computing session key.
[13:46:22] Key Exchange Algorithm: diffie-hellman-group-exchange-sha1
[13:46:22] Key exchange completed.
[13:46:22] Host Key Algorithm: ssh-rsa
[13:46:22] Client to Server Encryption: aes256-ctr
[13:46:22] Server to Client Encryption: aes256-ctr
[13:46:22] Session HMAC: hmac-sha1
[13:46:22] Client to Server Compression: none
[13:46:22] Server to Client Compression: none
[13:46:23] Authentication request. Method: "none"
[13:46:23] Server supported authentications: publickey
[13:46:23] Authentication request. Method: "publickey"
[13:46:23] User authentication successful.
[13:46:24] SSH session established.
[13:46:24] Connected to hsn.xfer.youtube.com.
[13:46:24] SFTP protocol version 3
[13:46:24] Detected Server Software: OpenSSH
[13:46:24] Resolving path "/home/hsn/2008_06_06_1100".
[13:46:24] Path successfully resolved.
[13:46:24] Reading directory "/home/hsn/2008_06_06_1100".
[13:46:25] 355 bytes transferred. (1.70 KB/s) (203 ms)
[13:46:25] Directory listing complete.[/codebox]

Here is the failed connection log via C# application
[codebox][20080722 17:48:08] SmartFTP FTP Library v1.5.13.35
[20080722 17:48:26] Resolving host name "hsn.xfer.youtube.com"
[20080722 17:48:26] Connecting to 208.65.153.158 Port: 22
[20080722 17:48:26] Starting SSH session. Remote Id: "SSH-1.99-OpenSSH_4.2"
[20080722 17:48:26] Initiating key exchange.
[20080722 17:48:27] Computing session key.
[20080722 17:48:27] Key Exchange Algorithm: diffie-hellman-group-exchange-sha1
[20080722 17:48:27] Key exchange completed.
[20080722 17:48:27] Host Key Algorithm: ssh-rsa
[20080722 17:48:27] Client to Server Encryption: aes128-ctr
[20080722 17:48:27] Server to Client Encryption: aes128-ctr
[20080722 17:48:27] Session HMAC: hmac-sha1
[20080722 17:48:27] Client to Server Compression: none
[20080722 17:48:27] Server to Client Compression: none
[20080722 17:48:28] Authentication request. Method: "none"
[20080722 17:48:28] Server supported authentications: publickey
[20080722 17:48:28] Authentication request. Method: "publickey"
[20080722 17:48:28] User authentication failed.
[20080722 17:48:28] Client closed the connection.
[20080722 17:48:28] 2[/codebox]

I'm really at a loss. Everything seems to be exactly the same. Please advise.

Thanks,
Jeff

#2 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 22 July 2008 - 07:03 PM

Are you sure you have the same username/password as in the client?

Regards,
mat

#3 jmarmash

jmarmash
  • Members
  • 11 posts

Posted 22 July 2008 - 07:13 PM

Impressive. I've been beating my head against the wall and, after your suggestion, realized that the first charater of the login was capitalized. The only difference was the case. I changed an uppercase to lower and bada-bing. Now onto testing Uploading/Iterating.

Thank you Matt.

Jeff




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users