Jump to content


Photo

Domain name resolution error


This topic has been archived. This means that you cannot reply to this topic.
3 replies to this topic

#1 Edtech

Edtech
  • Members
  • 16 posts

Posted 08 July 2008 - 07:26 AM

SmartFTP don't resolve the domain name if it's IPv6 only :

[09:27:27] SmartFTP v3.0.1019.2
[09:27:28] Resolving host name "edtech.manga-france.fr"
[09:27:28] Unable to resolve host name.
[09:27:28] Active Help: http://www.smartftp.com/support/kb/81
[09:27:28] Connect failed. Waiting to retry (30s)...


If I ping this domain :

ping edtech.manga-france.fr

Envoi d'une requête 'ping' sur edtech.manga-france.fr [2001:660:f001:2::D3] de 2001:660:f001:2::D9 avec 32 octets de données :
Réponse de 2001:660:f001:2::d3 : temps=56 ms
Réponse de 2001:660:f001:2::d3 : temps=111 ms
Réponse de 2001:660:f001:2::d3 : temps=108 ms
Réponse de 2001:660:f001:2::d3 : temps=136 ms

Statistiques Ping pour 2001:660:f001:2::D3:
Paquets : envoyés = 4, reçus = 4, perdus = 0 (perte 0%),
Durée approximative des boucles en millisecondes :
Minimum = 56ms, Maximum = 136ms, Moyenne = 102ms


If domain is IPv4 and IPv6, SmartFTP resolved only IPv4 and not IPv6. For me, IPv6 must be resolved before IPv4 !

Edited by Edtech, 08 July 2008 - 07:27 AM.


#2 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 08 July 2008 - 07:33 AM

Hello ..

Please set the "Protocol Family Preference" in the Favorite Settings to "IPv6". To edit the favorites please take a look at this article:
http://www.smartftp....orite-f117.html

Regards,
Mat

#3 Edtech

Edtech
  • Members
  • 16 posts

Posted 08 July 2008 - 08:16 AM

Ok, I have

[10:15:04] SmartFTP v3.0.1019.2
[10:15:04] Resolving host name "edtech.manga-france.fr"
[10:15:04] Connecting to [2001:660:f001:2::D3] Port: 990


But why not simply resolve IPv6 and if not answer, resolve IPv4 (with option to inverse order of testing) ?

Thanks fot your help.

#4 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 08 July 2008 - 09:58 AM

Because the default preference is the other way: First IPv4 and then IPv6. But that's why there is a setting you can change ;-)

Regards,
Mat