Jump to content


Photo

Can't create new folders or favourites in Manage Favorite screen


This topic has been archived. This means that you cannot reply to this topic.
8 replies to this topic

#1 jesus2099

jesus2099
  • Members
  • 23 posts

Posted 01 July 2008 - 09:46 AM

Hello,

I installed the latest version available today.
  • There is a typo in the favourites menu. "Manage favorite…" should be called "Manage favo[u]rites…" (with an "S")
  • I can't create any NEW thing in this screen. Neither folder nor favourite. It seems like the same bug than this closed one except that I can see all my old favourites. Why is it like this ? Is the problem only when upgrading ? If so, is the upgrade process improvable for future versions ?

Thank you !!
PS. I came back to SmartFTP from Filezilla because it has the same nag screen when using old versions.

#2 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 01 July 2008 - 02:04 PM

>Typo
This is actually correct. Favourite is British English and Favorite is American English.

>New Folder
Did you restart your computer after the installation? If not please try it. Please post the system information from the menu: Help->About "System Information" dialog.

Regards,
Mat

#3 jesus2099

jesus2099
  • Members
  • 23 posts

Posted 01 July 2008 - 02:19 PM

Hi MB,

typo: Anyway, it seems to me that the trailing "s" is missing.

New folder / New favorite: At that time, no. But now I did and still can't add anything.

+- System -----------------------------
Microsoft Windows 2000 Professional 
Service Pack 4 (Build 2195)

CPU Speed		   : 2793 MHz
Total Memory		: 2039 MB
Free Memory		 : 1212 MB

+- SmartFTP ---------------------------
Version			 : 3.0.1019.4
Time Stamp		  : 2008-07-01 04:44:49
Platform			: x86
Unlicensed
Days in use		 : 307

+- Application DLL --------------------
sfFTPLib.dll		: 1.5.13.32
sfFavorites.dll	 : 1.0.15.4
sfFavoritesShellExtension.dll : 1.0.1.13
sfTransferQueue.dll : 1.0.12.4
sfFTPShellExtension.dll : 1.0.10.4

+- Language ---------------------------
SmartFTP.exe		: 3.0.1019.4

+- Internet Explorer ------------------
Version			 : 6.0.2800.1106

+- Winsock ----------------------------
Winsock			 : 2.2

Thank you :(

#4 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 01 July 2008 - 02:25 PM

Ah Windows 2000. We will look at it.

Regards,
Mat

#5 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 01 July 2008 - 10:01 PM

Please install the latest version from:
http://www.smartftp....get/SFTPMSI.exe

It is possible to create new favorites in a sub folder. e.g in the Quick Connect folder. And you can use the toolbar to create a new favorite/folder in the root folder.

I hope this helps but I still highly recommend to upgrade to a safe OS like Windows XP or Vista.
Regards,
Mat

#6 jesus2099

jesus2099
  • Members
  • 23 posts

Posted 02 July 2008 - 03:58 PM

Well I still had problems.

Here is how I do achieve to edit my favourites now:

I go in Explore look for the folder where my bookmarks are (D:\Documents and Settings\M319937\Application Data\SmartFTP\Client 2.0). Here, I find two folders: Favorites.old and Favorites.
They are write protected.

I unprotect them and I can create anything I want then in SmartFTP (folder, favourite).
But they immediatly reprotect again.

So I have to unprotect them each time I want to edit my favourites.

(sorry bad english)

Edited by jesus2099, 02 July 2008 - 03:59 PM.


#7 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 03 July 2008 - 05:58 PM

Did you try it with the latest version? Because I was told changing the attributes is not necessary - anymore.

Regards,
Mat

#8 jesus2099

jesus2099
  • Members
  • 23 posts

Posted 04 July 2008 - 10:35 AM

In fact now it is quite special.

If I click on a folder (including the special favorites folder) in the left pane, I can only create a new folder (New Favorite is grey in the menu).

If I want to create a new favourite, I have to click in the right pane first.

In any situation, the right click menu doesn't allow me to create anything (I have to use the Favorite menu instead, in the upper menu bar).

But it's really OK to me now, I can do what I want even if it is a little strange. :(
Is it a windows 2000 only bug ?

#9 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 04 July 2008 - 02:20 PM

Hello jesus ..

The latest update included a workaround to enable the "New Favorite" function through the menu/toolbar. Only Windows 2000 is affected.

Regards,
Mat