Jump to content


Photo

Can't transfer AT ALL


This topic has been archived. This means that you cannot reply to this topic.
6 replies to this topic

#1 Daniel Park

Daniel Park
  • Members
  • 3 posts

Posted 24 June 2008 - 07:41 PM

I can't seem to transfer files AT ALL since upgrading to the newest version. Not by drag-n-drop, not by transfer arrow buttons, not with the transfer queue. No way, no how.

Remote browser log:

[21:36:05] SmartFTP v3.0.1018.3
[21:36:06] Resolving host name "www.dappertext.com"
[21:36:06] Connecting to 65.98.83.20 Port: 21
[21:36:06] Connected to www.dappertext.com.
[21:36:06] 220---------- Welcome to Pure-FTPd [TLS] ----------
[21:36:06] 220-You are user number 2 of 50 allowed.
[21:36:06] 220-Local time is now 19:36. Server port: 21.
[21:36:06] 220-This is a private system - No anonymous login
[21:36:06] 220 You will be disconnected after 15 minutes of inactivity.
[21:36:06] USER danielpa
[21:36:06] 331 User danielpa OK. Password required
[21:36:06] PASS (hidden)
[21:36:07] 230-User danielpa has group access to: danielpa
[21:36:07] 230-This server supports FXP transfers
[21:36:07] 230 OK. Current restricted directory is /
[21:36:07] SYST
[21:36:07] 215 UNIX Type: L8
[21:36:07] Detected Server Type: UNIX
[21:36:07] FEAT
[21:36:07] 211-Extensions supported:
[21:36:07] EPRT
[21:36:07] IDLE
[21:36:07] MDTM
[21:36:07] SIZE
[21:36:07] REST STREAM
[21:36:07] MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
[21:36:07] MLSD
[21:36:07] ESTP
[21:36:07] PASV
[21:36:07] EPSV
[21:36:07] SPSV
[21:36:07] ESTA
[21:36:07] AUTH TLS
[21:36:07] PBSZ
[21:36:07] PROT
[21:36:07] 211 End.
[21:36:07] Detected Server Software: PureFTPd
[21:36:07] PWD
[21:36:07] 257 "/" is your current location
[21:36:07] CWD /public_html/camtasiastudio
[21:36:07] 250 OK. Current directory is /public_html/camtasiastudio
[21:36:07] PWD
[21:36:07] 257 "/public_html/camtasiastudio" is your current location
[21:36:07] TYPE A
[21:36:08] 200 TYPE is now ASCII
[21:36:08] PASV
[21:36:08] 227 Entering Passive Mode (65,98,83,20,187,191)
[21:36:08] Opening data connection to 65.98.83.20 Port: 48063
[21:36:08] MLSD
[21:36:08] 150 Accepted data connection
[21:36:08] 226-Options: -a -l
[21:36:08] 226 16 matches total
[21:36:08] 1922 bytes transferred. (11.5 KB/s) (163 ms)
[21:36:13] CWD /public_html
[21:36:13] 250 OK. Current directory is /public_html
[21:36:13] PWD
[21:36:14] 257 "/public_html" is your current location
[21:36:14] PASV
[21:36:14] 227 Entering Passive Mode (65,98,83,20,123,185)
[21:36:14] Opening data connection to 65.98.83.20 Port: 31673
[21:36:14] MLSD
[21:36:14] 150 Accepted data connection
[21:36:14] 226-Options: -a -l
[21:36:14] 226 86 matches total
[21:36:14] 10046 bytes transferred. (27.7 KB/s) (354 ms)
[21:36:19] CWD /public_html/floortime
[21:36:19] 250 OK. Current directory is /public_html/floortime
[21:36:19] PWD
[21:36:19] 257 "/public_html/floortime" is your current location
[21:36:19] PASV
[21:36:19] 227 Entering Passive Mode (65,98,83,20,177,204)
[21:36:19] Opening data connection to 65.98.83.20 Port: 45516
[21:36:19] MLSD
[21:36:19] 150 Accepted data connection
[21:36:19] 226-Options: -a -l
[21:36:19] 226 2 matches total
[21:36:19] 218 bytes transferred. (1.39 KB/s) (153 ms)
[21:36:50] NOOP
[21:36:50] 200 Zzz...
[21:37:21] NOOP
[21:37:21] 200 Zzz...

Multiple files don't work. Single files don't work. The file type appears to be irrelevant.

I've long enjoyed the free version of SmartFTP. The product has grown significantly in that time, and now that the "free lunch" is over, I'm happy to pay for the product, but only if it's actually functional.

cheers, Daniel

#2 mb

mb

    Developer

  • Administrators
  • 11528 posts

Posted 24 June 2008 - 07:49 PM

Please post the system information from the menu: Help->About dialog.

Thank you
Regards,
mat

#3 Daniel Park

Daniel Park
  • Members
  • 3 posts

Posted 24 June 2008 - 09:50 PM

Sure thing - here you go...

+- System -----------------------------
Microsoft Windows Vista Ultimate Edition
Service Pack 1 (Build 6001)

CPU Speed : 1870 MHz
Total Memory : 2047 MB
Free Memory : 1728 MB

+- SmartFTP ---------------------------
Version : 3.0.1018.3
Time Stamp : 2008-06-24 17:31:48
Platform : x86
Unlicensed
Days in use : 295

+- Application DLL --------------------
sfFTPLib.dll : 1.5.13.32
sfFavorites.dll : 1.0.14.3
sfFavoritesShellExtension.dll : 1.0.1.13
sfTransferQueue.dll : 1.0.11.3
sfFTPShellExtension.dll : 1.0.9.3

+- Language ---------------------------
SmartFTP.exe : 3.0.1018.3

+- Internet Explorer ------------------
Version : 7.0.6001.18000

+- Winsock ----------------------------
Winsock : 2.2

#4 mb

mb

    Developer

  • Administrators
  • 11528 posts

Posted 24 June 2008 - 10:33 PM

It looks you have been affected by the same Windows Vista bug as here:
http://www.smartftp....s...20&start=20

The problem is actually with Windows Vista but it seems not even Microsoft has a 100% solution for it. Some users reported the subinacl fix (from Microsoft Support) described in above forum thread worked. For others Microsoft Support is still working on a solution after almost 1 month. It is important to note that not only SmartFTP is affected but any application that uses COM servers. It means on a system that shows such symptoms many other things will not work properly as well.

You can quickly verify that the problem is with Windows Vista:
1. Open the command line with administrative privileges (very important)
2. Select any COM server (this is typically a .dll file) and type regsvr32.exe yourdll.dll
For example you can go to the SmartFTP application folder cd %ProgramFiles%\SmartFTP Client and try to register the sfTransferQueue.dll by typing:
regsvr32.exe sfTransferQueue.dll
3. If 2 fails you know that there is a permission problem with Windows Vista.

Instead of doing step 2 you can also install SmartFTP from: http://www.smartftp....get/SFTPNSI.exe
This setup will automatically elevate your user and register the COM servers. The setup will most likely fail due to the same permission problem.

Regards,
Mat

#5 Daniel Park

Daniel Park
  • Members
  • 3 posts

Posted 25 June 2008 - 08:40 AM

FYI, your proposed solution DID work for me. Many thanks for your diligence.

cheers, d.

#6 mb

mb

    Developer

  • Administrators
  • 11528 posts

Posted 25 June 2008 - 10:46 AM

Thank you for your feedback. Did you use the subinacl fix?

#7 mb

mb

    Developer

  • Administrators
  • 11528 posts

Posted 08 July 2008 - 02:51 AM

The latest version of SmartFTP includes a workaround for the Windows Vista registry permission problem:
http://www.smartftp.com/download

While this solves all the problems related with SmartFTP it does not fix the underlying registry permission problem. To fix this problem contact Microsoft Support or follow the instructions at the following post: http://www.smartftp....s...ost&p=47591
It is important to note that this problem has not been caused by SmartFTP and existed before you installed SmartFTP.

Regards,
Mat
SmartFTP