Jump to content


Photo

Movinmg files on the remote server


This topic has been archived. This means that you cannot reply to this topic.
6 replies to this topic

#1 UKbernard

UKbernard
  • Members
  • 4 posts

Posted 09 April 2008 - 08:07 PM

Using Version 3.0.1012.6

In version of 2.5 I could easily upload a batch of files to a folder on the server, then move them by drag and drop - singly or in groups - to appropriate folders at my leisure.

This now seems not to work. But there is no failue message.

I think that sometimes I can get the move to happen, but the file is then not deleted from the source folder for the move on the server.

Am I doing somemthing wrong? Or is this a bug?

Edited by UKbernard, 09 April 2008 - 08:07 PM.


#2 mb

mb

    Developer

  • Administrators
  • 11527 posts

Posted 09 April 2008 - 08:15 PM

Please install the latest version from:
http://www.smartftp....get/SFTPMSI.exe

Did you start the Transfer Queue? Did you check the log in the Transfer Queue?
http://www.smartftp....lems-f2601.html

Regards,
Mat

#3 UKbernard

UKbernard
  • Members
  • 4 posts

Posted 20 April 2008 - 03:22 PM

Sorry for delay in coming back on this.

Still using version v3.0.1012.6

Some logs are given below. The situation seems to be:

In both the examples below the topmost option of the 'file exists what to do' window was selected.

If you drag-and-drop a file from one's PC to a folder on the server, and if the file already exists on the server/folder, then the file is copied and replaced


[15:46:32] CWD /htdocs
[15:46:32] 250 OK. Current directory is /htdocs
[15:46:32] PWD
[15:46:32] 257 "/htdocs" is your current location (the file visitors.html is already in this folder)
[15:46:32] NOOP
[15:46:32] 200 Zzz...
[15:46:36] MLST visitors.html
[15:46:36] 250-Begin
[15:46:36] type=file;size=9669;modify=20080420153924;UNIX.mode=0700;UNIX.uid=4294967295;UNI
X.gid=4294967295;unique=0g0; visitors.html
[15:46:36] 250 End.
[15:46:39] The operation has been added to the Transfer Queue. Check the Transfer Queue for the status.
[15:46:40] MLST visitors.html
[15:46:40] 250-Begin
[15:46:40] type=file;size=9669;modify=20080420154640;UNIX.mode=0700;UNIX.uid=4294967295;UNI
X.gid=4294967295;unique=0g0; visitors.html
[15:46:40] 250 End. (the file has been copied and overwrites the original)



If you do the above from a folder on the server to another folder on the server, and if the file already exists on the server/folder, then the file is NOT moved and replaced. Note the last few lines of the log extract below.

[15:41:45] 257 "/Update pages" is your current location
[15:41:45] MLST notices1.html
[15:41:45] 550 Can't check for file existence
[15:41:45] The operation has been added to the Transfer Queue. Check the Transfer Queue for the status.
[15:41:47] MLST notices1.html
[15:41:47] 250-Begin
[15:41:47] type=file;size=17838;modify=20080420154147;UNIX.mode=0700;UNIX.uid=4294967295;UN
IX.gid=4294967295;unique=0g0; notices1.html
[15:41:47] 250 End. (file succesfully moved into the folder /Update pages)
[15:41:56] RNFR /Update pages/notices1.html
[15:41:56] 350 RNFR accepted - file exists, ready for destination
[15:41:56] RNTO /htdocs/notices1.html
[15:41:56] 550 Rename/move failure: File exists (file NOT moved and replaced by drag-and-drop to folder where a copy already exists)


Your observations and solutions - is this a bug? The failing operation could be done in v2.5

Thanks

#4 mb

mb

    Developer

  • Administrators
  • 11527 posts

Posted 20 April 2008 - 11:45 PM

Please install the latest version from:
http://www.smartftp....get/SFTPMSI.exe

#5 UKbernard

UKbernard
  • Members
  • 4 posts

Posted 21 April 2008 - 11:43 AM

Thanks for reminding me to use the latest version - now running 3.0.1013.2

Problem still there. I even made sure that the file I was trying to move had a later creation date, it was otherwise the same

[12:33:05] NOOP
[12:33:05] 200 Zzz...
[12:33:26] RNFR /Update pages/HBC v1L1-20080420BC.wpp
[12:33:26] 350 RNFR accepted - file exists, ready for destination
[12:33:26] RNTO /HBC v1L1-20080420BC.wpp
[12:33:26] 550 Rename/move failure: File exists
[12:33:56] CWD /
[12:33:56] 250 OK. Current directory is /
[12:33:56] PWD
[12:33:56] 257 "/" is your current location
[12:33:57] NOOP
[12:33:57] 200 Zzz...

Sorry to keep on with this, it is just an anoyance as I can work around it, but seems a pity to have lost functionallity that existed before. I am using the default Look/Theme - Office 2003. Is this part of the problem for me? The window with choices about file replacement, etc., when pre-existing file is detected flies away.

Thanks in anticipation.

#6 mb

mb

    Developer

  • Administrators
  • 11527 posts

Posted 21 April 2008 - 11:58 AM

You are not running the latest version. Please install it from
http://www.smartftp....get/SFTPMSI.exe

#7 UKbernard

UKbernard
  • Members
  • 4 posts

Posted 21 April 2008 - 05:29 PM

Many thanks mb for sorting this out. Great service

;)

With version 3.0.1013.8 all now working.

Not sure what happened with the download versions. Before my previous post I had downloaded (from download.com) at about 1200 UK Summer time, 21 April, and got v 1013.2. At about 1800 same time zone and date I got v 1013.8 !!!

Excellent piece of software, I use it for two medium size charity web sites - a church and a school, both are updated at least twice a week, so reliable FTP a must!