Jump to content


Photo

ASCII mode ignored with SFTP


This topic has been archived. This means that you cannot reply to this topic.
4 replies to this topic

#1 holmes4

holmes4
  • Members
  • 3 posts

Posted 04 April 2008 - 01:13 AM

I was thrilled to see the Secure FTP (over SSH) option in SmartFTP 3. Thank you. But I do have a problem with it - the ASCII mode setting (either in the toolbar, or in a Favorites setting) seems to be ignored. No matter what I do, ASCII files are downloaded in binary. This used to work fine with regular FTP under 2.5. Is there something I've missed? I added a file type *.log (WildChar) to always be ASCII. I am using 3.0.1012.6

By the way, I think it would be kind if, when the user sets the connection type to SFTP, that the port be changed from 21 to 22. It took me a while to figure out what was wrong...

Edited by holmes4, 04 April 2008 - 01:14 AM.


#2 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 04 April 2008 - 05:00 AM

Ascii mode is not supported with SFTP over SSH. Use a text editor which supports unix line endings.

The port is automatically selected in the latest version.

Regards,
Mat

#3 holmes4

holmes4
  • Members
  • 3 posts

Posted 04 April 2008 - 12:49 PM

I know it is possible to do this because a tool I use at work, F-Secure SSH client, will convert the line endings. I have seen the stock answer of "use a text editor which supports unix line endings", and if it were that simple, I would. Unfortunately in this case the files are being read by a program that requires Windows line endings so I would have to go through a separate conversion step which I was hoping to avoid.

Please consider adding ASCII mode in a future update.

#4 jschenck

jschenck
  • Members
  • 1 posts

Posted 21 May 2008 - 04:41 PM

I also upgraded in order to be able to use SFTP and am curious why ASCII mode transfers "aren't supported". Is this an issue with the SFTP protocol or a bug in SmartFTP? Is there a setting I've missed?

It is a real pain to have to convert the transferred file every time.

#5 holmes4

holmes4
  • Members
  • 3 posts

Posted 21 May 2008 - 05:07 PM

The client has to manage this - it isn't part of the protocol. However, at least one other client I have used, F-Secure, can do this. You have to tell it the type of the remote server so that it gets it right, but once you have done that, it just works.

I find it especially annoying that SmartFTP doesn't even alert the user that ASCII mode isn't supported over SSH when one clicks the ASCII mode button or does a transfer of a file type that matches the ASCII filter.