Jump to content


Photo

Unable to browse remote folders or upload


This topic has been archived. This means that you cannot reply to this topic.
4 replies to this topic

#1 EthylMormon

EthylMormon
  • Members
  • 3 posts

Posted 31 March 2008 - 03:34 PM

Since upgrading to v.3.0 (I'm now using 3.0.1012), I'm unable to explore the contents of remote folders. I have ftp access to about 10 different sites, and they're all behaving in the same way:

On creating a connection, I get a list of greyed-out folders, none of which I'm able to click on. Well, I can click on them, but nothing happens. They don't open, and I can't explore folder contents. Consequently I can't upload or download, because I can't get access to the contents of any folders, all I can ever do is see the folder list. Single-clicking a folder in the folder view used to open the folder; double-clicking a folder in the main window used to do the same. Now, the folder that I click on in the folder view is highlighted for as long as I hold the mouseclick - as soon as I let go, the highlight reverts to the html folder. See screenshot below:

Posted Image

Also, I'm unable to access the Transfer Queue. No matter how many times I toggle the view Transfer Queue, or press CTRL-Q, nothing happens, and no transfer queue appears. Where is it? Where did it go? How do I get it back?

System Info:

+- System -----------------------------
Microsoft Windows XP Home Edition
Service Pack 2 (Build 2600)

CPU Speed : 3064 MHz
Total Memory : 990 MB
Free Memory : 493 MB

+- SmartFTP ---------------------------
Version : 3.0.1012.0
Time Stamp : 2008-03-30 23:33:45
Platform : x86
Unlicensed
Days in use : 277

+- Application DLL --------------------
sfFTPLib.dll : 1.5.12.38
sfFavorites.dll : 1.0.8.0
sfFavoritesShellExtension.dll : 1.0.1.9
sfTransferQueue.dll : 1.0.5.0
sfFTPShellExtension.dll : 1.0.3.0

+- Language ---------------------------
SmartFTP.exe : 3.0.1012.0

+- Internet Explorer ------------------
Version : 7.0.5730.11

+- Winsock ----------------------------
Winsock : 2.2


Remote browser log:


[16:11:55] SmartFTP v3.0.1012.0
[16:11:56] Resolving host name "www.fouriertransform.com"
[16:11:56] Connecting to 64.246.58.104 Port: 21
[16:11:56] Connected to www.fouriertransform.com.
[16:12:09] 220 ProFTPD FTP Server ready.
[16:12:09] USER xxx@fouriertransform.com
[16:12:13] 331 Password required for xxx@fouriertransform.com.
[16:12:13] PASS (hidden)
[16:12:14] 230 User xxx@fouriertransform.com logged in.
[16:12:14] SYST
[16:12:14] 215 UNIX Type: L8
[16:12:14] Detected Server Type: UNIX
[16:12:14] FEAT
[16:12:14] 211-Features:
[16:12:14] MDTM
[16:12:14] REST STREAM
[16:12:14] SIZE
[16:12:14] 211 End
[16:12:14] PWD
[16:12:15] 257 "/home/xxx" is current directory.
[16:12:17] TYPE A
[16:12:17] 200 Type set to A
[16:12:17] PASV
[16:12:17] 227 Entering Passive Mode (64,246,58,104,233,146).
[16:12:17] Opening data connection to 64.246.58.104 Port: 59794
[16:12:17] LIST -aL
[16:12:18] 150 Opening ASCII mode data connection for file list
[16:12:18] 1148 bytes transferred. (1.02 KB/s) (00:00:01)
[16:12:19] 226 Transfer complete.
[16:12:29] CWD /home/xxx/mainwebsite_html
[16:12:29] 250 CWD command successful
[16:12:29] PWD
[16:12:29] 257 "/var/www/html" is current directory.
[16:12:30] PASV
[16:12:31] 227 Entering Passive Mode (64,246,58,104,233,152).
[16:12:31] Opening data connection to 64.246.58.104 Port: 59800
[16:12:31] LIST -aL
[16:12:31] 150 Opening ASCII mode data connection for file list
[16:12:31] 4035 bytes transferred. (5.25 KB/s) (750 ms)
[16:12:32] 226 Transfer complete.
[16:12:46] CWD /var/www/html/001
[16:12:46] 250 CWD command successful
[16:12:46] PWD
[16:12:46] 257 "/var/www/html/001" is current directory.
[16:12:46] PASV
[16:12:46] 227 Entering Passive Mode (64,246,58,104,233,156).
[16:12:47] Opening data connection to 64.246.58.104 Port: 59804
[16:12:47] LIST -aL
[16:12:53] 150 Opening ASCII mode data connection for file list
[16:12:54] 32351 bytes transferred. (4.15 KB/s) (00:00:07)
[16:12:54] 226 Transfer complete.
[16:22:55] 421 No Transfer Timeout (600 seconds): closing control connection.
[16:22:55] An established connection was aborted by the software in your host machine.
[16:22:55] Server closed connection


Really weird, and also really frustrating. What am I doing wrong? I've been a happy SmartFTP user for years, and this has confused me no end.

Edited by EthylMormon, 31 March 2008 - 03:36 PM.


#2 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 01 April 2008 - 02:37 AM

Post the log from the transfer queue as described here
http://www.smartftp....ems-t14153.html

#3 EthylMormon

EthylMormon
  • Members
  • 3 posts

Posted 01 April 2008 - 02:49 AM

That's one of my problems - I can't access the transfer queue. Pressing CTRL-Q does nothing. VIEW > OTHER WINDOWS > TRANSFER QUEUE does nothing. Toggling the Transfer Queue icon in the toolbar does nothing.

Also, I'm unable to access the Transfer Queue. No matter how many times I toggle the view Transfer Queue, or press CTRL-Q, nothing happens, and no transfer queue appears. Where is it? Where did it go? How do I get it back?


;)

#4 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 01 April 2008 - 03:04 AM

Hello ..

Delete the registry key at:
HKEY_CURRENT_USER\Software\SmartFTP

To do this open regedit.exe

We would appreciate if you can export key first (File->Export) and send the .reg file to us for further analysis.
Thank you.

Regards,
Mat

#5 EthylMormon

EthylMormon
  • Members
  • 3 posts

Posted 03 April 2008 - 12:20 AM

Delete the registry key at:
HKEY_CURRENT_USER\Software\SmartFTP


Aha, that worked - thanks a million, Mat!
Transfer Queue is back, and I can open and explore folders. Excellent.

Many thanks ;)