Jump to content


Photo

Symbolic Links on FTP server


This topic has been archived. This means that you cannot reply to this topic.
3 replies to this topic

#1 freebsd

freebsd
  • Members
  • 2 posts

Posted 28 March 2008 - 05:32 AM

I also see an issue when I try to use version 3.0.1011.12
I am connecting to a unix server running freeBSD 6.2
I connect to my home directory fine but when I try to connect to the web directory which is a symlink it kicks me to the root directory.
[01:27:39] 230-FreeBSD 6.2-RELEASE #1: Mon Feb 12 20:47:55 EST 2007
[01:27:39] 230-
[01:27:40] 230 Logged in.
[01:27:40] SYST
[01:27:40] 215 UNIX Type: L8
[01:27:40] Detected Server Type: UNIX
[01:27:40] FEAT
[01:27:40] 211-Extensions supported:
[01:27:40] CLNT
[01:27:40] LANG EN*
[01:27:40] MDTM
[01:27:40] MFMT
[01:27:40] MLST Type*;Size*;Modify*;Perm;Unique;UNIX.mode*;UNIX.owner;UNIX.uid;UNIX.group;UNIX.g
id;
[01:27:40] PASV
[01:27:40] REST STREAM
[01:27:40] SIZE
[01:27:40] UTF8
[01:27:41] TVFS
[01:27:41] RFC 959 2389 2577 3659
[01:27:41] 211 End.
[01:27:41] Detected Server Software: NcFTPd
[01:27:41] CLNT SmartFTP 3.0
[01:27:41] 200 Noted.
[01:27:41] OPTS UTF8 ON
[01:27:41] 501 Option not recognized.
[01:27:41] PWD
[01:27:41] 257 "/usr/home/myname" is cwd.
[01:28:11] CWD /
[01:28:11] 250 "/" is new cwd.
[01:28:11] PWD
[01:28:11] 257 "/" is cwd.

#2 mb

mb

    Developer

  • Administrators
  • 11527 posts

Posted 28 March 2008 - 05:41 AM

Did you set the Path value in the favorite settings General dialog to "/"?
http://www.smartftp....orite-f117.html

Regards,
Mat

#3 freebsd

freebsd
  • Members
  • 2 posts

Posted 28 March 2008 - 05:57 AM

I had not set any values in any favorites.

I am correctly put into my home directory when I log in.

but when I try to click on a folder that is a symlink
(public_html -> /usr/www/users/myname)

is when I am seeing the problem.

I will look at some other settings under the favorites to see if there is something that can be set.

#4 mb

mb

    Developer

  • Administrators
  • 11527 posts

Posted 28 March 2008 - 09:08 AM

Bug fixed:
http://www.smartftp....get/SFTPMSI.exe

Thank you for reporting.