Jump to content


Photo

sym links not working in sftp


This topic has been archived. This means that you cannot reply to this topic.
6 replies to this topic

#1 derril

derril
  • Members
  • 20 posts

Posted 27 March 2008 - 11:41 PM

I have a directly of sym links and they don't work when connecting through SFTP (secure file transfer). They all show up as MS-DOS files or just "File". Are there plans to fix this?

I'm running v 3.0.1011.11

#2 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 28 March 2008 - 12:20 AM

Can you post a screenshot? Thank you.

#3 derril

derril
  • Members
  • 20 posts

Posted 28 March 2008 - 02:05 AM

Screen Shot

Thxs

#4 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 28 March 2008 - 09:09 AM

Thanks.
Working on bug fix.

#5 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 29 March 2008 - 06:59 AM

Hello ..

The latest update addresses the problem. There is still a small problem when you double click on a link to file. But this problem will be fixed in the next version as well.
http://www.smartftp....get/SFTPMSI.exe

Regards,
Mat

#6 derril

derril
  • Members
  • 20 posts

Posted 29 March 2008 - 06:48 PM

mb, looks like the fix you made did fix it. One comment though--I have directory with 300 sym links (a hosting box) and it takes a very long time load the directory (it's resolving paths). Would it be better to resolve the path once it's click on?

Also, I found twice, that after a directory listing it doesn't allow me to click on any directories or download files. The first time was immediately after login. The next time was after clicking on a symlinked dir. The circle that spins when processing in the connection tab, doesn't stop spinning. Here is the log from the initial connection:

[12:26:34] SmartFTP v3.0.1011.18
[12:26:35] Resolving host name "****"
[12:26:35] Connecting to *** Port: 22
[12:26:35] Starting SSH session. Remote Id: "SSH-1.99-OpenSSH_3.9p1"
[12:26:35] Initiating key exchange.
[12:26:35] Computing session key.
[12:26:35] Key Exchange Algorithm: diffie-hellman-group-exchange-sha1
[12:26:35] Key exchange completed.
[12:26:35] Host Key Algorithm: ssh-rsa
[12:26:35] Client to Server Encryption: aes256-ctr
[12:26:35] Server to Client Encryption: aes256-ctr
[12:26:35] Session HMAC: hmac-sha1
[12:26:35] Client to Server Compression: zlib
[12:26:35] Server to Client Compression: zlib
[12:26:35] Authentication request. Method: "none"
[12:26:35] Server supported authentications: publickey,gssapi-with-mic,password
[12:26:35] Authentication request. Method: "password"
[12:26:35] User authentication successful.
[12:26:35] SSH session established.
[12:26:35] Connected to ****.
[12:26:36] SFTP protocol version 3
[12:26:36] Detected Server Software: OpenSSH
[12:26:36] Resolving path ".".
[12:26:36] Path successfully resolved.
[12:26:36] Resolving path "***".
[12:26:36] Path successfully resolved.
[12:26:36] Reading directory "***".
[12:26:37] 2915 bytes transferred. (35.5 KB/s) (80 ms)
[12:26:37] Directory listing complete.

Also, would it be possible to have the dialog boxes ("are you sure you want to close?" or "are you sure you want to close sftp?") appear in the middle of the SFTP window instead of the middle of the screen? If you don't have the window maximized and off to the side, then they appear somewhere else.

That's all for now.

#7 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 31 March 2008 - 03:10 AM

Hello derril ..
Please try the latest version. You can now disable the auto resolve links and the links are resolved correctly when you double click them. However I still recommend to keep the auto resolve links settings enabled.

Regards,
Mat