Jump to content


Photo

Z/OS Invalid Dataset Type on the Upload


This topic has been archived. This means that you cannot reply to this topic.
17 replies to this topic

#1 Charles Hights

Charles Hights
  • Members
  • 14 posts

Posted 27 March 2008 - 02:16 AM

When uploading to Z/OS for some reason SmartFTP thinks the uploaded dataset going to Z/OS system is a duplicate of a dataset on the Z/OS so it appends (2) to it. Which is an invalid dataset type in Z/OS. This happens everytime I try to upload and I have made sure the dataset does not exist. During the upload there is a box that always comes up and ask what should I do. The options are copy (thereby making it the (2)) or don't copy. If I specify don't copy nothing is copied and the transfer que is not populated. Is there a way to force it to copy and not try to make it a (2) option. I know the dataset is not on Z/OS however the dataset is on my PC. So I'm just assuming it is just assuming the image it see's on my PC is the duplicate.

Here is the System Info:
Smart FTP System Info:
+- System -----------------------------
Microsoft Windows XP Professional
Service Pack 2 (Build 2600)

CPU Speed : 1828 MHz
Total Memory : 1021 MB
Free Memory : 280 MB

+- SmartFTP ---------------------------
Version : 3.0.1011.5
Time Stamp : 2008-03-26 00:07:41
Platform : x86

+- Application DLL --------------------
sfFTPLib.dll : 1.5.12.33
sfFavorites.dll : 1.0.7.5
sfFavoritesShellExtension.dll : 1.0.1.9
sfTransferQueue.dll : 1.0.4.5
sfFTPShellExtension.dll : 1.0.2.5

+- Language ---------------------------
SmartFTP.exe : 3.0.1011.5

+- Internet Explorer ------------------
Version : 7.0.5730.11

+- Winsock ----------------------------
Winsock : 2.2

Here is the LOG:
[19:03:00] Resolving host name "sa1l50.sys.eds.com"
[19:03:00] Connecting to 206.122.40.66 Port: 21
[19:03:00] Connected to sa1l50.sys.eds.com.
[19:03:04] 220-NETIFTP1 IBM FTP CS V1R7 at SA1L50.SYS.EDS.COM, 02:03:03 on 2008-03-27.
[19:03:04] 220 Connection will close if idle for more than 5 minutes.
[19:03:04] USER zzdmtb
[19:03:05] 331 Send password please.
[19:03:05] PASS (hidden)
[19:03:05] 230 ZZDMTB is logged on. Working directory is "ZZDMTB.".
[19:03:05] SYST
[19:03:06] 215 MVS is the operating system of this server. FTP Server is running on z/OS.
[19:03:06] Detected Server Type: MVS
[19:03:06] FEAT
[19:03:06] 211 no Extensions supported
[19:03:06] TYPE I
[19:03:06] 200 Representation type is Image
[19:03:06] REST 0
[19:03:06] 504 Restart requires Block or Compressed transfer mode.
[19:03:06] PWD
[19:03:06] 257 "'ZZDMTB.'" is working directory.
[19:03:06] CWD /ZZDMTB
[19:03:06] 550 CWD cmd failed : EDC5129I No such file or directory. (errno2=0x05190050)
[19:03:36] CWD 'ZZDMTB'
[19:03:37] 250 "ZZDMTB." is the working directory name prefix.
[19:03:37] PWD
[19:03:37] 257 "'ZZDMTB.'" is working directory.
[19:03:37] Remote file exist check: "chas.crt (2).txt".
[19:03:37] SIZE chas.crt (2).txt
[19:03:37] 501 command aborted -- FTP server not configured for SIZE
[19:03:37] SIZE not supported.
[19:03:37] MDTM chas.crt (2).txt
[19:03:37] 501 command aborted -- FTP server not configured for MDTM
[19:03:37] Obtaining file information (size/date) from directory listing.
[19:03:37] Ignoring LIST options.
[19:03:37] TYPE A
[19:03:38] 200 Representation type is Ascii NonPrint
[19:03:38] PASV
[19:03:38] 227 Entering Passive Mode (206,122,40,66,8,29)
[19:03:38] Opening data connection to 206.122.40.66 Port: 2077
[19:03:38] LIST
[19:03:38] 125 List started OK
[19:03:38] 982 bytes transferred. (5.60 KB/s) (171 ms)
[19:03:38] 250 List completed successfully.
[19:03:38] File "chas.crt (2).txt" not found in directory listing.
[19:03:38] PASV
[19:03:39] 227 Entering Passive Mode (206,122,40,66,8,30)
[19:03:39] Opening data connection to 206.122.40.66 Port: 2078
[19:03:39] STOR chas.crt (2).txt
[19:03:39] 501 Invalid data set name "chas.crt (2).txt". Use MVS Dsname conventions.
[19:03:39] 0 bytes transferred. (N/A/s) (0 ms)

Please let me know if you need any additional information, since the problem is easily re-creatable.

#2 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 27 March 2008 - 02:48 AM

There are 4 options in the file exist dialog.

1. The first one copies the file
2. The second one skips the file
3. The 3rd one auto renames the file. E.g. it adds the (2) to the file name
4. The 4th one uses the automatic settings in the transfer queue

Are you clicking on the first button?

Regards,
Mat

#3 Charles Hights

Charles Hights
  • Members
  • 14 posts

Posted 27 March 2008 - 02:20 PM

There are 4 options in the file exist dialog.

1. The first one copies the file
2. The second one skips the file
3. The 3rd one auto renames the file. E.g. it adds the (2) to the file name
4. The 4th one uses the automatic settings in the transfer queue

Are you clicking on the first button?

Regards,
Mat

I only see two options. The first two you mentioned above. If I select the first option, it tries to copy but it puts the (2) on it an Z/OS rejects it. On the 2nd option, it says:
Don't Copy, No file will be changed. Leave the folder in the destination folder rarmnetm(/zzdmtb)

When I select option 2, it closes the file exist dialog and it appears to be going to the transfer queue. But nothing is in the trasfer que. In fact I see this message in log:
[07:15:49] The operation has been added to the Transfer Queue.

But I don't see it and it never gets to Z/OS system.

#4 Mike

Mike
  • Root Admin
  • 194 posts

Posted 27 March 2008 - 03:23 PM

The Dialog you are see is the Type Conflict dialog this dialog appears when you try to upload a file to a directory who contains a directory with the same name as the file you want to upload.

Can you prvide a screenshot with the remote browser on the location you want to upload and the local browser you are upload from?

Thanks
-Mike

#5 Charles Hights

Charles Hights
  • Members
  • 14 posts

Posted 27 March 2008 - 03:48 PM

I do not know how to insert the set of screen shots I have taken into this post. Can I send them to you in an e-mail?

#6 Aokromes

Aokromes

    Entity From Outer Space

  • Root Admin
  • 1519 posts

Posted 27 March 2008 - 08:05 PM

You can try uploading to http://www.imageshack.us/

#7 Charles Hights

Charles Hights
  • Members
  • 14 posts

Posted 27 March 2008 - 09:23 PM

You can try uploading to http://www.imageshack.us/

OK here is the image code from Image shack 80114428915012
It needs to be picked up before I close the browser. It is 2:22 PM PST now. I will be leaving around 3:45 PM PST. So if it is not picked up by then, I will try again tomorrow.

#8 Mike

Mike
  • Root Admin
  • 194 posts

Posted 27 March 2008 - 10:21 PM

Can you provide the full link to the image i not able to view them with the given number.

Thanks
-Mike

#9 Charles Hights

Charles Hights
  • Members
  • 14 posts

Posted 27 March 2008 - 10:27 PM

Can you provide the full link to the image i not able to view them with the given number.

Thanks
-Mike

Here it is
http://www.imageshac...=80114428915012

#10 Mike

Mike
  • Root Admin
  • 194 posts

Posted 27 March 2008 - 10:34 PM

Sorry but I get this error message "File upload seems to be abandoned by sender".

-Mike

#11 Charles Hights

Charles Hights
  • Members
  • 14 posts

Posted 27 March 2008 - 10:43 PM

OK, I have added 3 images to Image Hosting:
The first one smartftp1 is just the initial screen. I transferring VVPORT from PC to Host.. Smartftp2 is the duplicate copy box that shows up and I select don't copy (meaning no file will be changed). SmartFTP3 shows it was added to the transfer que. On the host side high lighted in yellow near the top. but it never gets to the host.

SmartFTP1
Posted Image

SmartFTP2
Posted Image

SmartFTP3
Posted Image

#12 Mike

Mike
  • Root Admin
  • 194 posts

Posted 27 March 2008 - 11:12 PM

You also have the log from the remote browser while you try to upload "VVPORT" the log must be the same as from the attempt to upload.

Thanks
-Mike

#13 Charles Hights

Charles Hights
  • Members
  • 14 posts

Posted 28 March 2008 - 02:44 AM

Are you saying you want the log? I have the log as the first entry in this message. Here it is again from an attempt I just tried. From looking at the log it appears you think this is an HFS (Unix) system. This is a Z/OS MVS formatted system I'm trying to transfer to. The MDTM and SIZE are for Unix systems. I have tried to put this uploaded file into my PDS and upload as a sequential file.

[19:33:56] CWD 'ZZDMTB'
[19:33:56] 250 "ZZDMTB." is the working directory name prefix.
[19:33:56] PWD
[19:33:56] 257 "'ZZDMTB.'" is working directory.
[19:33:56] SIZE VVPORT
[19:33:56] 501 command aborted -- FTP server not configured for SIZE
[19:33:56] MDTM VVPORT
[19:33:56] 501 command aborted -- FTP server not configured for MDTM
[19:33:56] CWD 'ZZDMTB.VVPORT'
[19:33:56] 250 "ZZDMTB.VVPORT." is the working directory name prefix.
[19:33:56] PWD
[19:33:56] 257 "'ZZDMTB.VVPORT.'" is working directory.
[19:33:57] CWD 'ZZDMTB'
[19:33:57] 250 "ZZDMTB." is the working directory name prefix.
[19:33:57] PWD
[19:33:57] 257 "'ZZDMTB.'" is working directory.
[19:33:57] TYPE A
[19:33:57] 200 Representation type is Ascii NonPrint
[19:33:57] Ignoring LIST options.
[19:33:57] PORT 148,97,15,29,6,82
[19:33:57] 200 Port request OK.
[19:33:57] LIST
[19:33:57] 125 List started OK
[19:33:57] 982 bytes transferred. (7.73 KB/s) (124 ms)
[19:33:58] 250 List completed successfully.
[19:34:01] The operation has been added to the Transfer Queue. Check the Transfer Queue for the status.
[19:34:36] CWD 'ZZDMTB'
[19:34:36] 250 "ZZDMTB." is the working directory name prefix.
[19:34:36] PWD
[19:34:36] 257 "'ZZDMTB.'" is working directory.
[19:34:36] STAT VVPORT (2)
[19:34:36] 504 STAT file-identifier: not implemented
[19:34:36] TYPE I
[19:34:36] 200 Representation type is Image
[19:34:36] SIZE VVPORT (2)
[19:34:36] 501 command aborted -- FTP server not configured for SIZE
[19:34:36] MDTM VVPORT (2)
[19:34:36] 501 command aborted -- FTP server not configured for MDTM
[19:35:08] CWD 'ZZDMTB'
[19:35:08] 250 "ZZDMTB." is the working directory name prefix.
[19:35:08] PWD
[19:35:08] 257 "'ZZDMTB.'" is working directory.
[19:35:08] STAT VVPORT (2)
[19:35:08] 504 STAT file-identifier: not implemented
[19:35:08] SIZE VVPORT (2)
[19:35:08] 501 command aborted -- FTP server not configured for SIZE
[19:35:08] MDTM VVPORT (2)
[19:35:08] 501 command aborted -- FTP server not configured for MDTM

Whenever you see the 501 return code from the Z/OS FTP server it is saying the format is invalid for the dataset. Here is the FTP Server log from Z/OS

reply: --> 501 Invalid data set name "VVPORT (2)". Use MVS Dsname conventions.
reply: --> 501 Invalid data set name "VVPORT (2)". Use MVS Dsname conventions.

Is there a way to turn off the (2) function in SmartFTP. That is where the problem is. Just to ignore the duplicate dataset (there is no duplicate dataset anyway).

#14 Mike

Mike
  • Root Admin
  • 194 posts

Posted 28 March 2008 - 02:54 AM

The problem is here

[19:33:56] CWD 'ZZDMTB.VVPORT'
[19:33:56] 250 "ZZDMTB.VVPORT." is the working directory name prefix.
[19:33:56] PWD
[19:33:56] 257 "'ZZDMTB.VVPORT.'" is working directory.

The server allows a CWD to VVPORT so smartftp think it is a real folder on the remote site.

We would see how we can fix this.

-Mike

#15 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 28 March 2008 - 04:40 AM

Charles:
Thank you for providing all the information and your time reporting the problem ;-)

If you put the server into HFS (Unix) mode does it have the same behavior with the CWD command as Mike noticed?
The question is if you do a CWD to a random non existent directory does it still succeed?

To configure SmartFTP to force HFS on MVS go to the favorite settings and enter a Unix path into the Path input field in the General dialog.

Regards,
Mat

#16 Charles Hights

Charles Hights
  • Members
  • 14 posts

Posted 28 March 2008 - 05:15 AM

OK. When I used the hfs file format /tmp it put the vvport into /tmp/vvport with no problems. I then was able to cwd to "zzdmtb" (I had to use double quotes) and I got it to my directory. Then I cut put the same file on the MVS system. To prove this was no fluke, I removed the unix format from favorites and went back in again. This time it failed. So I put it back into Unix format and I was able to send to a hfs file system or an MVS file system. Wow. I'm happy. I just have to change all my favorites to point to the HFS format. I did not see a global option that would apply to all my favorites to make this change. Is there one? If not, I don't mind changing them when I need to logon.
Thanks for your help. I will consider this closed. ;)

#17 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 28 March 2008 - 06:46 AM

If somebody else should experience the same problem we have implemented a workaround in the latest version:
http://www.smartftp....get/SFTPMSI.exe

It does no longer use the CWD/PWD combo to check whether a directory with the same name already exists on the server if the server type is MVS in MVS path mode.

Regards,
Mat

#18 Charles Hights

Charles Hights
  • Members
  • 14 posts

Posted 28 March 2008 - 04:26 PM

Yes the new version works as advertised thanks. I went to another system where I did not have the /tmp directory defined to force it to HFS and it worked. Again thanks. ;)