Jump to content


Photo

Remote edit - just opens parent folder of app


This topic has been archived. This means that you cannot reply to this topic.
8 replies to this topic

#1 phw198

phw198
  • Members
  • 4 posts

Posted 25 March 2008 - 12:04 PM

I have always had my "File Viewer" set as "C:\Program Files\ULTRAEDIT-32\uedit32.exe" on the General tab. Under v3.0.1011.3 when I try and edit a file, it simply opens the parents folder (C:\Program Files\ULTRAEDIT-32) in Windows Explorer. The uedite32.exe file definitely exists, and the right-click context sensative menus have the application icon for the "View" and "Edit" items. However, the descriptions next to my custom icons under "View With" and "Edit With" have no description either.

Anyone else experiencing this?

#2 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 25 March 2008 - 03:50 PM

Post the system information from the menu: help->About dialog.

Can you send a screenshot showing the menu: Tools->Settings "General" dialog?

Regards,
Mat

#3 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 25 March 2008 - 11:53 PM

Bug confirmed but we would still be interested if you could post the system information. Thank you for your time.

#4 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 26 March 2008 - 04:41 AM

Bug fixed in the latest version:
http://www.smartftp....get/SFTPMSI.exe

#5 phw198

phw198
  • Members
  • 4 posts

Posted 26 March 2008 - 09:54 AM

Posted Image

I'll get the latest version installed now and report back - thanks!

System Info:-
+- System -----------------------------
Microsoft Windows XP Professional
Service Pack 2 (Build 2600)

CPU Speed : 1994 MHz
Total Memory : 1015 MB
Free Memory : 228 MB

+- SmartFTP ---------------------------
Version : 3.0.1011.3
Time Stamp : 2008-03-24 21:09:52
Platform : x86

+- Application DLL --------------------
sfFTPLib.dll : 1.5.12.33
sfFavorites.dll : 1.0.7.3
sfFavoritesShellExtension.dll : 1.0.1.9
sfTransferQueue.dll : 1.0.4.3
sfFTPShellExtension.dll : 1.0.2.3

+- Language ---------------------------
SmartFTP.exe : 3.0.1011.3

+- Internet Explorer ------------------
Version : 7.0.5730.13

+- Winsock ----------------------------
Winsock : 2.2

#6 phw198

phw198
  • Members
  • 4 posts

Posted 26 March 2008 - 10:23 AM

Hi - sorry, after installing latest version and rebooting, now view or editing remotely, the file enters the transfer queue and then nothing happens. If I'm trying to edit remotely, then the status in the queue just stays at "monitoring" until I manually delete the item in the queue.

The context sensative menu still looks the same as my posting from the previous version (no descriptions). Setting a default editor for my file extensions within Explorer really isn't an option for me - I edit file with pretty much any extension - often non-standard too.

Thanks for your efforts.

+- System -----------------------------
Microsoft Windows XP Professional
Service Pack 2 (Build 2600)

CPU Speed : 1995 MHz
Total Memory : 1015 MB
Free Memory : 404 MB

+- SmartFTP ---------------------------
Version : 3.0.1011.5
Time Stamp : 2008-03-26 00:07:41
Platform : x86

+- Application DLL --------------------
sfFTPLib.dll : 1.5.12.33
sfFavorites.dll : 1.0.7.5
sfFavoritesShellExtension.dll : 1.0.1.9
sfTransferQueue.dll : 1.0.4.5
sfFTPShellExtension.dll : 1.0.2.5

+- Language ---------------------------
SmartFTP.exe : 3.0.1011.5

+- Internet Explorer ------------------
Version : 7.0.5730.13

+- Winsock ----------------------------
Winsock : 2.2

#7 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 26 March 2008 - 11:11 PM

Hello ..

We have added another fix. Please try it again:
http://www.smartftp....get/SFTPMSI.exe

Regards,
Mat

#8 phw198

phw198
  • Members
  • 4 posts

Posted 27 March 2008 - 10:13 AM

Great - that seems to be working now for both View and Edit, and there are also descriptions in the context sensative menu ;)

One other thing (not sure if it's a new thing or not), but if I log into the FTP server and select Update "None" (instead of "Session"), then when I want to view or edit a file I am not promted for a password again and the request fails with the log file saying: -

[10:05:03] USER <user>
[10:05:03] 331 Password required for <user>
[10:05:03] PASS (hidden)
[10:05:03] 530 Login or password incorrect!

The transfer queue just keeps saying "retry at hh:mm:ss" but with the same fail.
Also when closing a file that's being edited, the transfer queue monitor doesn't seem to be pick up on this. Can a check be done to see if the local file has an open file handler on it?

Cheers!

#9 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 27 March 2008 - 10:30 AM

Hello ..

You need to select "Session" in the dialog otherwise SmartFTP doesn't save the password for the Transfer Queue session.

There is no way right now to reliably detect whether you stopped editing the file in the editor. You can either manually remove the item there after you are done editing or the item will automatically removed when you close SmartFTP.

Regards,
Mat