Jump to content


Photo

Remote Editing files other than html


This topic has been archived. This means that you cannot reply to this topic.
3 replies to this topic

#1 S46220

S46220
  • Members
  • 2 posts

Posted 17 March 2008 - 03:39 PM

Having downloaded the latest beta version today, and reading all the other posts on the remote editing and the transfer monitoring queue, I am still having problems editing files using Notepad++, and Textpad.

It seems as if it will only work for remote files ending in .html - any other file does not show as monitoring in the Queue window - yet the other files open ok in Notepad++ and/or Textpad.

I have proved this by renaming .txt and .php files on the remote host to end in .html, and then the remote edit function seems to work ok.

#2 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 19 March 2008 - 01:11 AM

Please try the latest version from:
http://www.smartftp....get/SFTPNSI.exe

Don't forget to check the "by default" option in the menu: Tools->Settings "Remote Edit". Set it to Editors, Default Shell Assoc.

#3 S46220

S46220
  • Members
  • 2 posts

Posted 20 March 2008 - 03:20 PM

Please try the latest version from:
http://www.smartftp....get/SFTPNSI.exe

Don't forget to check the "by default" option in the menu: Tools->Settings "Remote Edit". Set it to Editors, Default Shell Assoc.


Thanks - that has improved things dramatically...
It now works if i right click on a filename and select Edit (which has the Notepad++ icon next to it).

However, even if the File Editor in the General tab set as Notepad++, and the file associations in the Remote Edit set as Notepad++.
With the Remote Edit settings as either "use in default from general tab" or "Editors, Default Shell Assoc"

If I double click on a file in the remote window it opens with default shell association not the default editor, or the editor defined for remote edit.
(The Double Click setting is set to Edit)

#4 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 21 March 2008 - 12:36 AM

Fixed in the latest version (.19). Please install it from:
http://www.smartftp....get/SFTPNSI.exe

Regards,
Mat