Jump to content


Photo

'500 I won't open a connection' problem...


This topic has been archived. This means that you cannot reply to this topic.
1 reply to this topic

#1 dmcd01

dmcd01
  • Members
  • 1 posts

Posted 16 February 2008 - 05:59 PM

Hi,

I have used smartFTP for a while now with my ftp and have had zero problems... until the other week when I upgraded the firmware on my ftp unit (dlink-dns323) since the upgrade I have been unable to access the ftp. I can access the drive via the network but not over an ftp. Any help would be appreciated!

Below is my ftp log:

[09:45:32] SmartFTP v2.5.1008.5
[09:45:32] Resolving host name "71.177.238.203"
[09:45:32] Connecting to 71.177.238.203 Port: 21
[09:45:32] Connected to 71.177.238.203.
[09:45:32] 220---------- Welcome to Pure-FTPd ----------
[09:45:32] 220-You are user number 1 of 10 allowed.
[09:45:32] 220-Local time is now 09:45. Server port: 21.
[09:45:32] 220 You will be disconnected after 2 minutes of inactivity.
[09:45:32] USER xxxx
[09:45:32] 331 User xxxx OK. Password required
[09:45:32] PASS (hidden)
[09:45:32] 230 OK. Current restricted directory is /
[09:45:32] SYST
[09:45:32] 215 UNIX Type: L8
[09:45:32] Detected Server Type: UNIX
[09:45:32] FEAT
[09:45:32] 211-Extensions supported:
[09:45:32] EPRT
[09:45:32] IDLE
[09:45:32] MDTM
[09:45:32] SIZE
[09:45:32] REST STREAM
[09:45:32] MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
[09:45:32] MLSD
[09:45:32] TVFS
[09:45:32] ESTP
[09:45:32] PASV
[09:45:32] EPSV
[09:45:32] SPSV
[09:45:32] ESTA
[09:45:32] 211 End.
[09:45:32] Detected Server Software: PureFTPd
[09:45:32] PWD
[09:45:32] 257 "/" is your current location
[09:45:32] TYPE A
[09:45:32] 200 TYPE is now ASCII
[09:45:32] PASV
[09:45:32] 227 Entering Passive Mode (192,168,1,3,234,190)
[09:45:32] Opening data connection to 192.168.1.3 Port: 60094
[09:45:32] MLSD
[09:45:32] 0 bytes transferred. (N/A/s) (0 ms)
[09:46:32] Timeout (60s).
[09:46:32] Active Help: http://www.smartftp.com/support/kb/74
[09:46:32] Client closed the connection.
[09:46:32] Automatic failover of data connection mode from "Passive Mode (PASV)" to "Active Mode (PORT)".
[09:46:32] Resolving host name "71.177.238.203"
[09:46:32] Connecting to 71.177.238.203 Port: 21
[09:46:32] Connected to 71.177.238.203.
[09:46:32] 220---------- Welcome to Pure-FTPd ----------
[09:46:32] 220-You are user number 2 of 10 allowed.
[09:46:32] 220-Local time is now 09:46. Server port: 21.
[09:46:32] 220 You will be disconnected after 2 minutes of inactivity.
[09:46:32] USER xxxx
[09:46:32] 331 User xxxx OK. Password required
[09:46:32] PASS (hidden)
[09:46:32] 230 OK. Current restricted directory is /
[09:46:32] SYST
[09:46:32] 215 UNIX Type: L8
[09:46:32] Detected Server Type: UNIX
[09:46:32] FEAT
[09:46:32] 211-Extensions supported:
[09:46:32] EPRT
[09:46:32] IDLE
[09:46:32] MDTM
[09:46:32] SIZE
[09:46:32] REST STREAM
[09:46:32] MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
[09:46:32] MLSD
[09:46:32] TVFS
[09:46:32] ESTP
[09:46:32] PASV
[09:46:32] EPSV
[09:46:32] SPSV
[09:46:32] ESTA
[09:46:32] 211 End.
[09:46:32] Detected Server Software: PureFTPd
[09:46:32] PWD
[09:46:32] 257 "/" is your current location
[09:46:32] TYPE A
[09:46:32] 200 TYPE is now ASCII
[09:46:32] PORT 192,168,1,2,192,180
[09:46:32] 500 I won't open a connection to 192.168.1.2 (only to 71.177.238.203)

#2 mb

mb

    Developer

  • Administrators
  • 11642 posts

Posted 16 February 2008 - 06:33 PM

I looks like the FTP masquerading in your router firmware is broken. It means the router does not rewrite the IP for PORT command and it doesn't seem to setup the NAT correctly.
I would downgrade to the old firmware.

Regards,
Mat