Jump to content


Photo

edit files 'in place'


This topic has been archived. This means that you cannot reply to this topic.
5 replies to this topic

#1 AndyS01

AndyS01
  • Members
  • 11 posts

Posted 07 February 2008 - 02:30 PM

When I do a 'open with' and select Notepad, the notepad editor doesn't open for 30-40 seconds.

#2 Mike

Mike
  • Root Admin
  • 194 posts

Posted 07 February 2008 - 02:56 PM

Before the File opens it must be downloaded.

#3 AndyS01

AndyS01
  • Members
  • 11 posts

Posted 07 February 2008 - 06:12 PM

Before the File opens it must be downloaded.


I think there is something else going on. I can upload and download this very small file using SmartFTP, and it takes less than 1 second. If the file to be edited on the remote system has to be downloaded to the local systrem before editing it, then this operation should be very quick, not 30-40 seconds. Or, am I missing something here? (I also see a 30-40 second delay from when I do a 'save' in notepad, to when the changed file is written to the remote system.)

Andy

#4 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 07 February 2008 - 06:22 PM

Why don't look you look into the "Transfer Queue" pane to see what's going on? To enable it go the menu: View->Others Windows->Transfer Queue.

Regards,
Mat

#5 AndyS01

AndyS01
  • Members
  • 11 posts

Posted 07 February 2008 - 08:32 PM

Good suggestion. I see that the time is consumed in the 'connecting' mode. The machine I'm connected to has a LONG connect time. That answers the long delay issue, but why is it re-connecting for each file upload/download? It doesn't do that when I copy files to and from it using the SmartFTP's explorer facilities. I won't be able to use this if I can't get the delay issue corrected. I was going to try it on another machine (with a quick connect time), but the SmartFTP beta version went south on me (I will open a bug report on it shortly), and I had to revert back to version 2.5.1008)

Andy

#6 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 07 February 2008 - 09:41 PM

The reconnect will be here to stay. SmartFTP uses the same strategy when transferring files from and to the server. The problem is very likely on the server side because an average connection takes place in less than 5 seconds.
Regards,
Mat