Jump to content


Photo

Double click on images won't open, force to use open with


This topic has been archived. This means that you cannot reply to this topic.
8 replies to this topic

#1 Mathachew

Mathachew
  • Members
  • 16 posts

Posted 18 November 2007 - 02:19 AM

As the title says, anytime I want to look at an image on my PC, double clicking does nothing, forcing me to right click, go to Open With and select the default program, Windows Photo Gallery. To my knowledge, this problem only exists on Vista. I'm not sure if the default program makes a difference or not, but mine is the original default, Windows Photo Gallery. Here are my system specs:

+- System -----------------------------
Microsoft Windows Vista Ultimate Edition 
 (Build 6000)

CPU Speed		 : 2133 MHz
Total Memory	  : 2045 MB
Free Memory	   :  871 MB

+- SmartFTP ---------------------------
Version		   : 2.5.1008.9
Time Stamp		: 2007-11-11 20:16:59
Platform		  : x64

+- Application DLL --------------------
sfFTPLib.dll	  : 1.5.11.6
sfFavorites.dll   : 1.0.4.9
SmartHook.dll	 : 1.0.2.2

+- Language ---------------------------
SmartFTP.exe	  : 2.5.1008.9

+- Internet Explorer ------------------
Version		   : 7.0.6000.16546

+- Winsock ----------------------------
Winsock		   : 2.2

Thanks!

#2 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 18 November 2007 - 03:05 AM

Bug confirmed. Working on a fix.

Thank you for posting.

#3 yli

yli
  • Members
  • 53 posts

Posted 18 November 2007 - 09:30 AM

Bug confirmed. Working on a fix.

Thank you for posting.

very strange...
in my post about this bug
http://www.smartftp....539-t12884.html

We have no control over this behavior.
Regards,
-Mat



#4 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 18 November 2007 - 10:10 AM

In this case it seems we already looked into it and figured out that we can't "fix" it.
Nevertheless we will give it another try.
Regards,
Mat

#5 yli

yli
  • Members
  • 53 posts

Posted 18 November 2007 - 10:41 AM

In this case it seems we already looked into it and figured out that we can't "fix" it.
Nevertheless we will give it another try.
Regards,
Mat

ok ...try to fix

#6 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 18 November 2007 - 11:00 AM

We just looked into it and the shellview control asks for an interface which is unknown (not documented). As a result the interface cannot be found and the caller (not SmartFTP) crashes for some reason.

Regards,
Mat

#7 yli

yli
  • Members
  • 53 posts

Posted 18 November 2007 - 11:06 AM

We just looked into it and the shellview control asks for an interface which is unknown (not documented). As a result the interface cannot be found and the caller (not SmartFTP) crashes for some reason.

Regards,
Mat

weird...
ask Microsoft how to do this API...

#8 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 21 November 2007 - 02:00 AM

Workaround in the latest version (.16):
http://www.smartftp....get/SFTPMSI.exe

We are handling the double click action ourselves now.

Regards,
Mat

#9 yli

yli
  • Members
  • 53 posts

Posted 21 November 2007 - 08:21 PM

Workaround in the latest version (.16):
<a href="http://www.smartftp.com/get/SFTPMSI.exe" target="_blank">http://www.smartftp.com/get/SFTPMSI.exe</a>

We are handling the double click action ourselves now.

Regards,
Mat

thanks
bug fixed too in Version : 2.5.1008.15 x64

Edited by yli, 21 November 2007 - 08:23 PM.