Jump to content


Photo

Folder doesn't update when folder is moved into tree


This topic has been archived. This means that you cannot reply to this topic.
2 replies to this topic

#1 Ryan J Williams

Ryan J Williams
  • Members
  • 18 posts

Posted 23 October 2007 - 04:06 PM

I've noticed that if I'm in a directory and I try to drag/drop a few files into a sub-directory a few levels down (ie: via the tree), SmartFTP will behave as if it's then in that directory (address bar will change to the sub-directory I moved the files to, if I drag/drop into the remote window it'll upload to that sub-directory, etc).

What's the problem? Well weirdly, my remote view doesn't update to show the contents of the new directory! After moving the files it'll still show the contents of wherever I was, implying that if I drag some files into the remote view they'll go into that folder. But they won't; they'll go into the sub-directory I moved to previously.

Posted Image

My ideal functionality would be for SmartFTP to just stay in the folder I was in before I moved the files (ie: where I moved thm from). Usually I just want to get some files out the way and then carry on uploading into the folder I was already in, so SmartFTP moving me without me explicitly asking it to do so is kind of counter-productive.

Edited by Ryan J Williams, 23 October 2007 - 04:08 PM.


#2 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 11 November 2007 - 01:59 AM

Hello Ryan ..

Thank you for your report. We have completely rewritten the Remote Browser for the next major version (3.0). Thus we are not planning to improve the current code that much. The new Remote Browser doesn't suffer from problems like the one you described.

Regards,
Mat
SmartFTP

#3 ev0style

ev0style
  • Members
  • 1 posts

Posted 11 November 2007 - 05:59 PM

do u know when we can expect version 3.0?