Jump to content


Photo

Remote editor settings not working properly II


This topic has been archived. This means that you cannot reply to this topic.
5 replies to this topic

#1 clarisa

clarisa
  • Members
  • 1 posts

Posted 14 October 2007 - 01:30 PM

Hello.

Ok, I know theres a similar topic like this before but my problem is different.

So, I was using SmartFTP for about 3 months now, and just recently I encountered a problem.

I was about to edit (I just right click >> edit) my .php files for my website, normally, it opens Notepad (my default .php editor, where I edit my .php files). But a while ago when I was doing that, the Notepad won't open. I right click >> edit the .php several times but the notepad won't open, it's just the remote edit (the one that lets you hit upload when its modified). I thought there's just something wrong so I decided to run SmartFTP agan but nothing happened. I tried installing the new version which is the 2.5 but nothing happened as well, the Notepad won't really open.

I really don't know what to do now. Please help.

You can email me at clrz_dirtbag@goingdead.net or posting a reply here on my post. Thank You.

Edited by clarisa, 14 October 2007 - 01:56 PM.


#2 robix

robix
  • Members
  • 2 posts

Posted 18 October 2007 - 01:21 PM

I experience the same issue.

The file is downloaded, but the associated application is not started.

#3 DivineAnarchy

DivineAnarchy
  • Members
  • 2 posts

Posted 18 October 2007 - 07:59 PM

Yep, I've been using SmartFTP for years w/o this problem, so I'm assuming its related to my new Vista install. The VIEW option works however, so I'm investigating the registry to find a manual fix.

#4 DivineAnarchy

DivineAnarchy
  • Members
  • 2 posts

Posted 18 October 2007 - 08:08 PM

Ok its not a bug- but SmartFTP should manifest the "unknown file extension" dialog if the filetype isn't recognized by windows (currently nothing happens).

By default under Remote Edit options, it has "Windows File Association" selected to edit with.

If you're used to the old style of SmartFTP- you can change it to "Same as Viewer" (which is set under General).

Note: I'm using Vista

Edited by DivineAnarchy, 18 October 2007 - 08:09 PM.


#5 mb

mb

    Developer

  • Administrators
  • 11527 posts

Posted 18 October 2007 - 09:56 PM

I have implemented a fallback in the latest version: if there is no file association it will use the default viewer.
Latest version:
http://www.smartftp....get/SFTPMSI.exe

Regards,
Mat

#6 robix

robix
  • Members
  • 2 posts

Posted 19 October 2007 - 10:38 AM

I have implemented a fallback in the latest version: if there is no file association it will use the default viewer.
Latest version:
http://www.smartftp....get/SFTPMSI.exe

Regards,
Mat

For me installing this update did the trick
Many thanks!