Jump to content


Photo

Uploading and Downloading suddenly stopped working


This topic has been archived. This means that you cannot reply to this topic.
10 replies to this topic

#1 BigDad

BigDad
  • Members
  • 3 posts

Posted 08 October 2007 - 03:34 PM

I've been using version 2.5 for 25 days now, and never had any problems. That is, until Saturday night - when all of the sudden, I am unable to upload or download anything. Drag and drop doesn't work, the buttons don't work, and I get no error messages. I was planning on buying a key when my trial was over, but I don't want to purchase one and then not be able to transfer files. I am still able to delete a file from the server. Any ideas?

Just a little info on my system - I'm running XP SP2, with a Pentium 4 processor and 2.5 GB of RAM.

Thanks for the help!

Edited by BigDad, 08 October 2007 - 03:41 PM.


#2 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 08 October 2007 - 04:33 PM

Hello ..

SmartFTP works as expected. Try to uninstall the current version and install the latest version from:
http://www.smartftp....get/SFTPMSI.exe

If it doesn't work for you you may want to provide some more details.

Regards,
Mat

#3 BigDad

BigDad
  • Members
  • 3 posts

Posted 08 October 2007 - 05:02 PM

Hello ..

SmartFTP works as expected. Try to uninstall the current version and install the latest version from:
http://www.smartftp....get/SFTPMSI.exe

If it doesn't work for you you may want to provide some more details.

Regards,
Mat


Thanks for the response. I tried unistalling and re-installing, but it does the same thing. I can connect to my servers with no problem, I can see all the files and folders, but I am unable to upload or download any files - either by drag-and-drop or the upload/download buttons. The log is below:

------------------------
[12:51:10] SmartFTP v2.5.1006.48
[12:51:11] Resolving host name "ftp.sekyghosts.com"
[12:51:11] Connecting to 216.246.57.250 Port: 21
[12:51:11] Connected to ftp.sekyghosts.com.
[12:51:11] 220---------- Welcome to Pure-FTPd [TLS] ----------
[12:51:11] 220-You are user number 2 of 50 allowed.
[12:51:11] 220-Local time is now 11:51. Server port: 21.
[12:51:11] 220-IPv6 connections are also welcome on this server.
[12:51:11] 220 You will be disconnected after 15 minutes of inactivity.
[12:51:11] USER sekyscom
[12:51:11] 331 User sekyscom OK. Password required
[12:51:11] PASS (hidden)
[12:51:11] 230-User sekyscom has group access to: sekyscom
[12:51:11] 230 OK. Current restricted directory is /
[12:51:11] SYST
[12:51:11] 215 UNIX Type: L8
[12:51:11] Detected Server Type: UNIX
[12:51:11] FEAT
[12:51:11] 211-Extensions supported:
[12:51:11] EPRT
[12:51:11] IDLE
[12:51:11] MDTM
[12:51:11] SIZE
[12:51:11] REST STREAM
[12:51:11] MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
[12:51:11] MLSD
[12:51:11] ESTP
[12:51:11] PASV
[12:51:11] EPSV
[12:51:11] SPSV
[12:51:11] ESTA
[12:51:11] AUTH TLS
[12:51:11] PBSZ
[12:51:11] PROT
[12:51:11] 211 End.
[12:51:11] Detected Server Software: PureFTPd
[12:51:11] PWD
[12:51:12] 257 "/" is your current location
[12:51:12] TYPE A
[12:51:12] 200 TYPE is now ASCII
[12:51:12] PORT 192,168,1,101,10,146
[12:51:12] 200 PORT command successful
[12:51:12] MLSD
[12:51:12] 150 Connecting to port 2706
[12:51:12] 2049 bytes transferred. (25.3 KB/s) (79 ms)
[12:51:12] 226-Options: -a -l
[12:51:12] 226 18 matches total
[12:51:21] CWD /www
[12:51:21] 250 OK. Current directory is /www
[12:51:21] PWD
[12:51:21] 257 "/www" is your current location
[12:51:21] PORT 192,168,1,101,10,147
[12:51:21] 200 PORT command successful
[12:51:21] MLSD
[12:51:21] 150 Connecting to port 2707
[12:51:22] 226-Options: -a -l
[12:51:22] 226 57 matches total
[12:51:22] 6939 bytes transferred. (30.9 KB/s) (219 ms)
[12:51:52] NOOP
[12:51:53] 200 Zzz...
[12:52:23] NOOP
[12:52:24] 200 Zzz...
[12:52:54] NOOP
[12:52:55] 200 Zzz...
[12:53:25] NOOP
[12:53:26] 200 Zzz...
[12:53:56] NOOP
[12:53:57] 200 Zzz...
[12:54:27] NOOP
[12:54:28] 200 Zzz...
[12:54:58] NOOP
[12:54:59] 200 Zzz...
[12:55:29] NOOP
[12:55:30] 200 Zzz...
[12:56:00] NOOP
[12:56:01] 200 Zzz...
[12:56:31] NOOP
[12:56:32] 200 Zzz...
[12:57:02] NOOP
[12:57:03] 200 Zzz...
[12:57:33] NOOP
[12:57:34] 200 Zzz...
[12:58:04] NOOP
[12:58:05] 200 Zzz...

------------------------

I'm not sure what other info you may need.

Thanks again for the help.

#4 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 08 October 2007 - 05:11 PM

The files are probably added to the Transfer Queue. Please enable the Transfer Queue view:
menu: View -> Other Windows -> Transfer Queue
or
Ctrl+Q

To change the default drag&drop method go to the menu: Tools->Settings. In the Navigation dialog change the option from Add to Queue to Direct.

Regards,
Mat

#5 BigDad

BigDad
  • Members
  • 3 posts

Posted 08 October 2007 - 05:37 PM

Mat --

That's exactly where the problem lied. Thanks so much for your help - I just got my license key.

Thanks again!

#6 dreamscape

dreamscape
  • Members
  • 3 posts

Posted 18 November 2007 - 06:04 AM

Okay. I'm experiencing the same symptoms, immediately after upgrading to the licensed version (trial also expired). Everything was working wonderfully until now. I verified I'm not transferring to queue.. "Direct" was already selected. On XP, SP2, for what it's worth. I've tried uninstalling, rebooting, reinstalling. After this, SmartFTP picks up with my last successful session instead of landing like it normally would if it was a fresh install; I don't know if that's important. I've tried alternating between active and passive modes; no difference in response. I can even create and rename files on the remote server.. just can't move them. Interestingly, if I try to copy a file on the remote server and paste it into a different directory, I received the following error:

"Copying files within the same server is not supported by the FTP protocol.
Tip: If the FTP server supports FXP open two connections to the same server and then use Drag&Drop from one server to the other."

I've already called my datacenter and they've verified that FTP is working as it should be on all hosting accounts, so they believe the issue falls to SmartFTP. I've tested this on other client accounts and it seems universal, again pointing to SmartFTP. Please advise. I think this is a superb product and I need it to work like it's been doing flawlessly up to this point. My log is below.
M

[00:34:23] SmartFTP v2.5.1008.11
[00:34:24] Resolving host name "ftp.[removed for security].com"
[00:34:24] Connecting to 72.52.149.12 Port: 21
[00:34:24] Connected to ftp.[removed for security].com.
[00:34:24] 220---------- Welcome to Pure-FTPd [TLS] ----------
[00:34:24] 220-You are user number 1 of 50 allowed.
[00:34:24] 220-Local time is now 00:34. Server port: 21.
[00:34:24] 220 You will be disconnected after 15 minutes of inactivity.
[00:34:24] USER [removed for security]
[00:34:24] 331 User [removed for security] OK. Password required
[00:34:24] PASS (hidden)
[00:34:25] 230-User [removed for security] has group access to: [removed for security]
[00:34:25] 230 OK. Current restricted directory is /
[00:34:25] SYST
[00:34:25] 215 UNIX Type: L8
[00:34:25] Detected Server Type: UNIX
[00:34:25] FEAT
[00:34:25] 211-Extensions supported:
[00:34:25] EPRT
[00:34:25] IDLE
[00:34:25] MDTM
[00:34:25] SIZE
[00:34:25] REST STREAM
[00:34:25] MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
[00:34:25] MLSD
[00:34:25] ESTP
[00:34:25] PASV
[00:34:25] EPSV
[00:34:25] SPSV
[00:34:25] ESTA
[00:34:25] AUTH TLS
[00:34:25] PBSZ
[00:34:25] PROT
[00:34:25] 211 End.
[00:34:25] Detected Server Software: PureFTPd
[00:34:25] PWD
[00:34:25] 257 "/" is your current location
[00:34:25] CWD /public_html/themes/carbon/templates
[00:34:25] 250 OK. Current directory is /public_html/themes/carbon/templates
[00:34:25] PWD
[00:34:25] 257 "/public_html/themes/carbon/templates" is your current location
[00:34:25] TYPE A
[00:34:25] 200 TYPE is now ASCII
[00:34:25] PASV
[00:34:25] 227 Entering Passive Mode (72,52,149,12,219,106)
[00:34:25] Opening data connection to 72.52.149.12 Port: 56170
[00:34:25] MLSD
[00:34:26] 150 Accepted data connection
[00:34:26] 1539 bytes transferred. (32.6 KB/s) (46 ms)
[00:34:26] 226-Options: -a -l
[00:34:26] 226 13 matches total
[00:34:56] NOOP
[00:34:56] 200 Zzz...
[00:35:27] NOOP
[00:35:27] 200 Zzz...
[00:35:58] NOOP
[00:35:58] 200 Zzz...
[00:36:29] NOOP
[00:36:29] 200 Zzz... <--All along here I'm trying to upload or download and nothing is happening. Help!
[00:37:00] NOOP
[00:37:00] 200 Zzz...
[00:37:31] NOOP
[00:37:31] 200 Zzz...
[00:38:02] NOOP
[00:38:02] 200 Zzz...
[00:38:33] NOOP
[00:38:33] 200 Zzz...

#7 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 18 November 2007 - 06:17 AM

If you want to move files on the same server you need to "cut" them and then "paste" them. You described you used "copy" and then "paste" which would result in a copy operation. You can also simply drag&drop the files from one folder to another.

I hope this helps.
Regards,
Mat

#8 dreamscape

dreamscape
  • Members
  • 3 posts

Posted 19 November 2007 - 03:08 AM

Okay, well that handles one item, and yes, cutting works where copying didn't. This, however, doesn't address the fact that SmartFTP isn't uploading or downloading any files anymore. Please advise further.

#9 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 19 November 2007 - 04:22 AM

I believe your transfers are queued in the Transfer Queue. If not please send the log of your FTP session showing the transfers.

Regards,
SmartFTP

#10 dreamscape

dreamscape
  • Members
  • 3 posts

Posted 19 November 2007 - 05:15 AM

I did submit my log and I already said I checked the transfer queue and there was nothing there. That's the dump about three posts ago. Well, it looks like I figured it out. I downloaded another FTP software (WS_FTP) and when I ran into the same problem, I had an ah-hah! While it appears SmartFTP will allow you to access zipped files like normal files, if you forget to extract the files locally first, SmartFTP stares back at you blankly when you try to upload or download remotely.

The fix: If you catch yourself trying to upload or download from compressed/zipped folders, extract the desired files first.. then upload and download will occur normally. Case closed.

#11 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 19 November 2007 - 09:51 AM

Ah. Thanks for letting us know about the solution. We will investigate if it's actually possible to implement such a feature in the next version of SmartFTP.

Regards,
Mat