Jump to content


Photo

Keyboard Hot Keys not working


This topic has been archived. This means that you cannot reply to this topic.
9 replies to this topic

#1 Intel X86

Intel X86
  • Members
  • 5 posts

Posted 10 August 2007 - 01:32 PM

I own the Microsoft Internet Keyboard. While working with SmartFTP, I cannot use hot keys such as My computer or Calculator, which is very handy.

Note: The keys are working with other applications

#2 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 10 August 2007 - 10:02 PM

Hello ..

Thank you for reporting this bug. Unfortunately I don't have a keyboard with any specials keys to test it. Thats why I have to ask you to try the following sample application:
http://www.codejock..../win32/Pane.zip

If it doesn't work then it's a problem with the GUI framework we use.

Thank you
Regards,
Mat

#3 Intel X86

Intel X86
  • Members
  • 5 posts

Posted 11 August 2007 - 08:11 AM

I tested the sample. The hot keys are working while I am writing for example in a TextBox.

#4 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 11 August 2007 - 11:55 AM

Thank you.

In the meanwhile we have tested the latest version of SmartFTP on Windows XP with a Microsoft Intelitype Pro keyboard but we didn't see any problems.

In SmartFTP you cannot use them in any case - regardless where the focus is?

#5 Intel X86

Intel X86
  • Members
  • 5 posts

Posted 11 August 2007 - 02:56 PM

I cannot use them in the main form. While managing favorites, viewing the About form hot keys work.

Note: I have not installed IntelliType

#6 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 11 August 2007 - 04:54 PM

Please make a list of controls where the hot keys don't work. Do you have a Local Browser open/focused? Is a Remote Browser open/focused?

Thank you
Mat

#7 Intel X86

Intel X86
  • Members
  • 5 posts

Posted 11 August 2007 - 05:02 PM

remote browser (folder View & folder list listboxes)
Log textbox
Transfer queue Listbox
Temporary queue listbox
connections listbox
speed pane
username & password textboxes
server url dropdown
location dropdown
port textbox

The problem occurs on Windows XP SP2 and Windows Vista.

#8 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 11 August 2007 - 05:07 PM

Thanks.

Therefore it works in the Local Browser?

Regards,
-Mat

#9 Intel X86

Intel X86
  • Members
  • 5 posts

Posted 11 August 2007 - 05:10 PM

neither in local browser controls

#10 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 12 August 2007 - 10:26 PM

What theme are you using in SmartFTP? Settings -> Interface. Does it make a difference if you use a different theme?