Jump to content


Photo

SSL/TLS internal error (Error = 0x6cbce7b4)


  • Please log in to reply
2 replies to this topic

#1 Peter Dunphy

Peter Dunphy
  • Members
  • 5 posts

Posted 09 August 2007 - 04:32 PM

Have a script that has successfully FTPed to an SSL Server for some time. The last two times I received "SSL/TLS internal error (Error = 0x6cbce7b4)" while transferring the file.

Can you tell me the cause?

Thanks
Peter Dunphy

Partial log file:

20070809 14:43:18] SmartFTP FTP Library v1.5.9.16
[20070809 14:43:18] Resolving host name "xxxxxxxxx"
[20070809 14:43:18] Connecting to xxxxxxxxxx Port: 21
[20070809 14:43:18] Connected to xxxxxxxxxxx.
[20070809 14:43:18] 220 (vsFTPd 2.0.5)
[20070809 14:43:18] AUTH TLS
[20070809 14:43:18] 234 Proceed with negotiation.
[20070809 14:43:18] Connected. Exchanging encryption keys...
[20070809 14:43:18] Session Cipher: 168 bit 3DES
[20070809 14:43:18] TLS encrypted session established.
[20070809 14:43:18] PBSZ 0
[20070809 14:43:18] 200 PBSZ set to 0.
[20070809 14:43:18] USER xxxxx
[20070809 14:43:18] 331 Please specify the password.
[20070809 14:43:18] PASS xxxxx
[20070809 14:43:18] 230 Login successful.
[20070809 14:43:18] SYST
[20070809 14:43:18] 215 UNIX Type: L8
[20070809 14:43:18] Detected Server Type: UNIX
[20070809 14:43:18] FEAT
[20070809 14:43:18] 211-Features:
[20070809 14:43:19] AUTH SSL
[20070809 14:43:19] AUTH TLS
[20070809 14:43:19] EPRT
[20070809 14:43:19] EPSV
[20070809 14:43:19] MDTM
[20070809 14:43:19] PASV
[20070809 14:43:19] PBSZ
[20070809 14:43:19] PROT
[20070809 14:43:19] REST STREAM
[20070809 14:43:19] SIZE
[20070809 14:43:19] TVFS
[20070809 14:43:19] 211 End
[20070809 14:43:19] PWD
[20070809 14:43:19] 257 "/"
[20070809 14:43:19] CWD /mv/unisys
[20070809 14:43:19] 250 Directory successfully changed.
[20070809 14:43:19] PWD
[20070809 14:43:19] 257 "/mv/unisys"
[20070809 14:43:19] TYPE I
[20070809 14:43:19] 200 Switching to Binary mode.
[20070809 14:43:19] PROT P
[20070809 14:43:19] 200 PROT now Private.
[20070809 14:43:19] PORT 142,139,40,70,12,92
[20070809 14:43:19] 200 PORT command successful. Consider using PASV.
[20070809 14:43:19] STOR DOF063007.txt
[20070809 14:43:19] 150 Ok to send data.
[20070809 14:43:19] SSL/TLS internal error (Error = 0x6cbce7b4).
[20070809 14:43:19] The token supplied to the function is invalid
[20070809 14:43:19] The token supplied to the function is invalid
[20070809 14:43:19] Client closed the connection.

#2 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 10 August 2007 - 10:14 PM

Hello ..

The error comes from an underlying layer and I couldn't find any reference to it in schannel. Did you set the CertName, CertStore and CertStoreLocation properties correctly? Does the account your script is running under have access to the cert?
Can you connect to the sever with SmartFTP
Did you try this on another computer as well?
Are you able to open a secured data connection to another FTP server? e.g. ftp://ftp.smartftp.com

Regards,
Mat

#3 Peter Dunphy

Peter Dunphy
  • Members
  • 5 posts

Posted 13 August 2007 - 01:10 PM

The server Admin at the other end had changed to require PASV transfers.
Changed my script and all is working.

Thanks
Peter




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users