Jump to content


Photo

Desktop.ini in smartftp folder causing files to be hidden


This topic has been archived. This means that you cannot reply to this topic.
5 replies to this topic

#1 Packet1009

Packet1009
  • Members
  • 7 posts

Posted 23 July 2007 - 12:50 AM

I've just started noticing this with the past couple of versions.

Couldnt find any mention of it on searching for desktop.ini, so here's my hopefully non-duplicated bug report:


Problem: Cannot browse the Smartftp install folder with Windows Explorer - No files are shown.
Properties on folder show the correct size and # of files, but no files are displayed.
The Command prompt will show all files correctly.
Also, cannot manipulate folder due to the usual right click menu options being unavailable.

I finally figured out that it was due to desktop.ini being created on install (and later, upon running the Smartftp application)

Contents of said file:
[.ShellClassInfo]
CLSID={39DD67E0-73B6-4a11-AF55-49E1EBBF72BE}

Deleting the desktop.ini file from the Smartftp folder fixes the issue, however, it returns upon launching the application again.

My workaround has been to remove all the content in the desktop.ini file and mark it as +RSH (read-only, system, hidden). I figure just read-only may work as well, short of using ntfs permissions.

Once the desktop.ini info is removed, I can browse the folder through Windows Explorer again.

system specs as below from Smartftp's 'system info'

+- System -----------------------------
Microsoft Windows 2000 Professional
Service Pack 4 (Build 2195)

CPU Speed : 1992 MHz
Total Memory : 1023 MB
Free Memory : 653 MB

+- SmartFTP ---------------------------
Version : 2.5.1006.4
Time Stamp : 2007-06-08 18:41:59
Platform : x86

+- Application DLL --------------------
sfFTPLib.dll : 1.5.9.24
sfFavorites.dll : 1.0.2.4
SmartHook.dll : 1.0.2.2

+- Language ---------------------------
SmartFTP.exe : 2.5.1006.4

+- Internet Explorer ------------------
Version : 6.0.2800.1106

+- Winsock ----------------------------
Winsock : 2.2

thanks in advance

Edited by Packet1009, 23 July 2007 - 12:51 AM.


#2 mb

mb

    Developer

  • Administrators
  • 11528 posts

Posted 23 July 2007 - 02:52 AM

Hello ..

The desktop.ini is only created in the favorites folder (Settings -> Favorites). In your case the personal favorites folder has been set to to the application folder or the application folder has been added to the additional favorites folders in the favorite settings. This can either happen manually or the favorites folder has been set to the application folder in a previous version of SmartFTP.

To avoid the problem in the future please make sure that the personal favorites folder doesn't point to the application folder.

Regards,
-Mat
SmartFTP

#3 Packet1009

Packet1009
  • Members
  • 7 posts

Posted 02 August 2007 - 10:22 AM

Hi,

Thanks for the info - I tried what you said and moved the Favorites to a new folder. However, I see similar behaviour even in the "favorites" folder.

The clsid within the desktop.ini in the favorites folder causes the folder to not display its contents in windows explorer.

Is this by design?

Edited by Packet1009, 02 August 2007 - 10:23 AM.


#4 mb

mb

    Developer

  • Administrators
  • 11528 posts

Posted 03 August 2007 - 01:31 AM

Hello ...

The folder shouldn't be empty in Windows Explorer. I have the same problem here and we will look into it.

Regards,
-Mat

#5 mb

mb

    Developer

  • Administrators
  • 11528 posts

Posted 04 August 2007 - 02:08 AM

Hello ..

Bug fixed in the latest version (.16):
http://www.smartftp....get/SFTPNSI.exe
or
http://www.smartftp....get/SFTPMSI.exe

Regards,
-Mat

#6 Packet1009

Packet1009
  • Members
  • 7 posts

Posted 04 August 2007 - 12:27 PM

that's such a quick fix - thanks very much