Jump to content


Photo

PROT C Command - Access Denied


  • Please log in to reply
2 replies to this topic

#1 cbranden

cbranden
  • Members
  • 4 posts

Posted 12 June 2007 - 12:31 AM

Sorry I originally posted this under the SmartFTP Client Section, I am actually trying the SmartFTP library.

>>The ftp server requires SSL and only grants permission for a PROT C command.
>>SmartFTP is always sending PROT P which is getting access denied by the ftp server.
>>I have tried changing the PROTFallback property to false and it still only sends the PROT C command.

I don't see how your response applies to the SmartFTP Library, please advise:

Set the data connection for File Transfer and List Transfer to Clear in the Favorite settings FTP -> Connection -> SSL

Thanks,
Chet

#2 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 12 June 2007 - 01:09 AM

Set DataProtection property of the IFTPConnection to ftpDataProtectionClear (numeric 1)

#3 cbranden

cbranden
  • Members
  • 4 posts

Posted 12 June 2007 - 06:18 PM

Thank you this works great, I'm ready to purchase!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users