Jump to content


Photo

CPU usage way high


This topic has been archived. This means that you cannot reply to this topic.
6 replies to this topic

#1 Ender Wiggin

Ender Wiggin
  • Members
  • 39 posts

Posted 27 March 2007 - 11:12 AM

This is something i noticed recently, not sure if it has anything to do with the new upgrade i put in from 2.0 to the latest.... But i have about 1000 images on download queue and my CPU processes shows SmartFTP as taking 48% of my CPU. As soon as i stop the queue the CPU goes back down to nearly nothing as it should be. Why does SmartFTp take up so much juice?

+- System -----------------------------
Microsoft Windows XP Professional
Service Pack 2 (Build 2600)

CPU Speed : 2798 MHz
Total Memory : 1023 MB
Free Memory : 390 MB

+- SmartFTP ---------------------------
Version : 2.5.1005.3
Time Stamp : 2007-03-23 22:41:08
Platform : x86

+- Application DLL --------------------
sfFTPLib.dll : 1.5.9.12
SmartHook.dll : 1.0.2.1

+- Language ---------------------------
SmartFTP.exe : 2.5.1005.3

+- System DLL -------------------------
shell32.dll : 6.00.2900.3051 (xpsp_sp2_gdr.061219-0316)
shlwapi.dll : 6.00.2900.3059 (xpsp_sp2_gdr.070104-0050)
comctl32.dll : 6.0 (xpsp.060825-0040)
riched20.dll : 5.30.23.1228
schannel.dll : 5.1.2600.2180 (xpsp_sp2_rtm.040803-2158)

+- Internet Explorer ------------------
Version : 6.0.2900.2180

+- Winsock ----------------------------
Winsock : 2.2

#2 Ender Wiggin

Ender Wiggin
  • Members
  • 39 posts

Posted 27 March 2007 - 04:07 PM

This is what i found out how to reproduce it.

I like to have 5 workers set in the queue, not all 5 work of course because some site i only allow 1 worker. but I want to be able to transfer 5 times from different sites.

Givens:
On a per site basis:
- 1 worker allowed to download with 1 worker to view only.
- An occasional will have 2 or 3 workers, but generally since i download from home users I set the worker to 1

- I set the number of workers in the queue to 5, allowing me to download 5 times from 5 different sites if i need to, but usually it is 1 or 2.

- If i am on 2 sites, and set the workers to 5 the CPU jumps to nearly 50%. If i reduce it to the 2 connections, then the memory drops back to 5-6% as normal. So far as i know, i should be able to keep the workers at 5, leaving 3 available should i want to connect to a different site. This is reproducible all the time.

EDIT: under options/queue it is set to 2 the last number i set it before the cpu usage goes to 47%, but when i restart the application, it still says 2, but in the queue pane it says 1. Not consistent.

I also updated to the latest version


- As a test I reinstalled version 2.0.1000.0 and redid my queue and all my problems go away. If i have 5 workers, the program says i have 5 even after restarting the program. it does not revert back to 1. Also my CPU will remain below 10% with 5 workers and 3 active. So the problem is somewhere with the v2.5 install.

+- System -----------------------------
Microsoft Windows XP Professional
Service Pack 2 (Build 2600)

CPU Speed : 2798 MHz
Total Memory : 1023 MB
Free Memory : 439 MB

+- SmartFTP ---------------------------
Version : 2.5.1005.5
Time Stamp : 2007-03-27 04:28:24
Platform : x86

+- Application DLL --------------------
sfFTPLib.dll : 1.5.9.12
SmartHook.dll : 1.0.2.1

+- Language ---------------------------
SmartFTP.exe : 2.5.1005.5

+- System DLL -------------------------
shell32.dll : 6.00.2900.3051 (xpsp_sp2_gdr.061219-0316)
shlwapi.dll : 6.00.2900.3059 (xpsp_sp2_gdr.070104-0050)
comctl32.dll : 6.0 (xpsp.060825-0040)
riched20.dll : 5.30.23.1228
schannel.dll : 5.1.2600.2180 (xpsp_sp2_rtm.040803-2158)

+- Internet Explorer ------------------
Version : 6.0.2900.2180

+- Winsock ----------------------------
Winsock : 2.2

#3 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 28 March 2007 - 09:55 AM

Hello ...

Please test it again with the latest version (.6). I have fixed the inconsistency of the "Max Workers" setting.

The high CPU problem is related to the fact that SmartFTP scans (previously every 200 ms) all items in the Transfer Queue to see if it can start a new worker. But as all items have the same Favorite with the Max Worker limit set to 1 it won't be able start anything. I have increased the scan interval to 1s now.

Regards,
-Mat

#4 Ender Wiggin

Ender Wiggin
  • Members
  • 39 posts

Posted 28 March 2007 - 10:46 AM

That is better, the queue remains with 5 workers and no longer reverts back to 1 every time i restart the application. The CPU usage of Smart FTP fluctuates now between 13% and 30% according to task manager. I still think this is too high and when I did my test yesterday with 2.0.1000.0, it never went above 10%

What i noticed as well, and it could be just me, I dunno... If i am connected to only one site with 1 worker out of 5 (with approx 15 files and 5 folders in queue), the CPU % of SmartFTP sticks around 10-11%. As soon as I connect to a 2nd site, and if that site has a ton of files, the CPU seems to jump around quite a bit. If that 2nd site only has one or 2 files, the CPU% remains pretty constant. Again, this is just something i noticed. Could be nothing, i don't know.

Thanks for the quick response on the fix .... Keep up the great work!

#5 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 10 April 2007 - 06:55 AM

The latest version addresses this problem.

Regards,
-Mat

#6 Bruno

Bruno
  • Members
  • 28 posts

Posted 10 April 2007 - 08:37 AM

The high CPU problem is related to the fact that SmartFTP scans (previously every 200 ms) all items in the Transfer Queue to see if it can start a new worker. But as all items have the same Favorite with the Max Worker limit set to 1 it won't be able start anything. I have increased the scan interval to 1s now.


Ihr k

#7 sawjer

sawjer
  • Members
  • 1 posts

Posted 20 June 2007 - 09:13 AM

I notice on my laptop even worse problems with CPU load going to 100%. This happens if directories with large number of files are transferred (>40). Then the system hangs and there is no remedy other than killing the tasks. Sometimes even that does not work!