Jump to content


Photo

Queue transfer : in the destination, nothing but folder "SFTPDROP"


This topic has been archived. This means that you cannot reply to this topic.
7 replies to this topic

#1 olivier.pons

olivier.pons
  • Members
  • 1 posts

Posted 07 March 2007 - 10:19 AM

Sometimes (seldom), when I try to transfer the files, with the 'Q' option clicked, I drag'n drop from my ftp-source to my local folder destination and there's only a folder named SFTPDROP that is created.
The only way to get my transfer to work is to quit then re-launch Smartftp.
This is under WinXP SP2 / latest patches, 4Go RAM, 320 Gb hard drive, and the ftp is a local connexion (= very fast).
It just happened twice, but this is really annoying.
This problem does happen even with only one file.
Note : I'm always using the drag'n drop feature to transfer files, no other way.

#2 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 07 March 2007 - 12:19 PM

Is there any way you can reproduce the problem in a reasonable time span? If it only happens sporadically it's very hard to find a solution for it.

Regards,
-Mat

#3 secarica

secarica
  • Members
  • 3 posts

Posted 16 April 2007 - 01:11 AM

I cannot transfer nothing from remote server to local desktop, because of the same SFTPDROP folder thing. The only way I found for transferring is to rightclick on the desired item and explicitly specify the download destination folder, but this is too annoying to be used.

I installed Smat FTP fresh on a fresh installed WinXP.
The file type is of no importance.
Passive or not makes no difference.
I noticed no problem in file uploading.

?

Cristi

#4 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 16 April 2007 - 08:46 AM

Hello ..

The correct way to install SmartFTP is as following:
1. Install SmartFTP from
http://www.smartftp....get/SFTPMSI.exe

2. It may be necessary to restart your computer

Regards,
SmartFTP

#5 secarica

secarica
  • Members
  • 3 posts

Posted 16 April 2007 - 06:13 PM

The problem has gone after system restart. I'm on a notebook and usually I don't shut down or restart the system until explicitly requested to do so.

As for file version, I downloaded it from this site less than 24 hours than my previous post. The file I have says version 2.5.1005.22 and the length is 3.779.120 bytes.

Thank you,
Cristi

#6 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 16 April 2007 - 07:11 PM

Hello ..

For the CopyHook (SmartHook.dll) to work correctly the Windows Explorer (Explorer.exe) needs to be restarted. Unfortunately there is no other solution. Microsoft doesn't provide the necessary API to reload/refresh the CopyHook shell handlers.

Regards,
-Mat

#7 W13

W13
  • Members
  • 2 posts

Posted 08 July 2007 - 09:41 PM

I can confirm.

I just installed on Vista... and everytime I drag and drop a file from FTP onto my desktop, all I get is that SFTDROP folder (which is empty)

+- System -----------------------------
Microsoft Windows Vista Home Premium Edition 
 (Build 6000)

CPU Speed		 : 1729 MHz
Total Memory	  : 1013 MB
Free Memory	   :  349 MB

+- SmartFTP ---------------------------
Version		   : 2.5.1006.6
Time Stamp		: 2007-06-30 00:31:40
Platform		  : x86

+- Application DLL --------------------
sfFTPLib.dll	  : 1.5.9.24
sfFavorites.dll   : 1.0.2.6
SmartHook.dll	 : 1.0.2.2

+- Language ---------------------------
SmartFTP.exe	  : 2.5.1006.6

+- Internet Explorer ------------------
Version		   : 7.0.6000.16473

+- Winsock ----------------------------
Winsock		   : 2.2


#8 W13

W13
  • Members
  • 2 posts

Posted 08 July 2007 - 10:02 PM

OK- I rebooted computer- and now it works.