Jump to content


Photo

SmartFTP's UPnP support broken with D-Link DGL-4100


This topic has been archived. This means that you cannot reply to this topic.
2 replies to this topic

#1 Ashlyn

Ashlyn
  • Members
  • 10 posts

Posted 17 December 2006 - 01:23 AM

Just a note to say I was using a D-Link DI-604 router with latest firmware, and SmartFTP worked perfectly using UPnP (though it was quite slow with mapping/unmapping). I recently replaced my router with a D-Link DGL-4100 (latest firmware), and now SmartFTP (2.0.1000.4) won't work with UPnP. Resorting to PASV mode works as expected (which is what I used before anyway because the UPnP mapping/unmapping caused too much of a delay).

#2 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 17 December 2006 - 03:02 AM

Does it work with a previous version of SmartFTP? e.g. v2.0 Build 1000.1-3?

#3 Ashlyn

Ashlyn
  • Members
  • 10 posts

Posted 30 December 2006 - 04:01 PM

Does it work with a previous version of SmartFTP? e.g. v2.0 Build 1000.1-3?

Well, I was using v2.0 Build 1000.4, and simply replaced my router. I did not change SmartFTP versions. Not sure how different a UPnP implementation would be between different router models from the same company, but I doubt it's a firmware bug since the DGL-4100 has been out for about 2 years now. However, also strange is that XP itself seems to have an issue with the new router too... In the Network Connections folder, the Internet Connection (Internet Gateway) entry is always shown as disabled for the DGL-4100. It used to show properly as enabled (as its status dialog accessible) for the previous DI-604 router.

Well, thanks for any investigating. Maybe something is actually different about the DGL-4100's UPnP implementation compared to the DI-604, wish I could find out for sure.