Jump to content


Photo

Command sequence FTP to MVS


  • Please log in to reply
7 replies to this topic

#1 Lucky Ncube

Lucky Ncube
  • Members
  • 13 posts

Posted 05 October 2006 - 01:10 AM

Hello.

I am thinking maybe we getting our command sequence wrong. can you please explain explicitly how each command needs to be excuted so that our FTP library software behaves exactly as your client FTP software, that way maybe we will be able to appreciate what we are doing wrong. right now its just stops on UploadFile and we don't really know what we are doing wrong. we have tried all your suggestio but without any success. that brings me to ask the question does SMARTFTP Library support MVS Secure FTP or its Just the SmartFT Client that supports MVS secure FTP.

Because, if they have the same functionality of if the Smartftp client is build using the FTP library then it should work surely.

The other question is on my previous question where I asked you to match commands you mention a command called ClearControlConnection[i] , I can find this command in the FTP library, how do i access it.

Please note that we are using VB6 for developing this application are they other things that we need to aware off.

I sincerely hope you will be able to help me.

#2 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 05 October 2006 - 04:36 AM

Hello ..

The SmartFTP client uses the SmartFTP FTP Library (sfFTPLib.dll). This dll is the same as the one we distribute with the SmartFTP FTP Library.

If you want to match the log of the SmartFTP client you have to add the following 2 parts:
1. Add ReadDirectory before the upload. This will result in a LIST command.
2. Set the DataTransferType property to Image (see the manual) then call GetFileSize(filename)
This will result in TYPE I and a SIZE filename.

ClearCommandChannel
The method I was referring to was: ClearCommandChannel. But this is very likely not supported by your FTP server.

The problem I see is either with a firewall configuration (it blocks your .exe but it doesn't block SmartFTP.exe) or it is with the FTP server running on the MVS.

Regards,
-Mat
SmartFTP

#3 Lucky Ncube

Lucky Ncube
  • Members
  • 13 posts

Posted 07 October 2006 - 06:30 PM

Hello ..

The SmartFTP client uses the SmartFTP FTP Library (sfFTPLib.dll). This dll is the same as the one we distribute with the SmartFTP FTP Library.

If you want to match the log of the SmartFTP client you have to add the following 2 parts:
1. Add ReadDirectory before the upload. This will result in a LIST command.
2. Set the DataTransferType property to Image (see the manual) then call GetFileSize(filename)
This will result in TYPE I and a SIZE filename.

ClearCommandChannel
The method I was referring to was: ClearCommandChannel. But this is very likely not supported by your FTP server.

The problem I see is either with a firewall configuration (it blocks your .exe but it doesn't block SmartFTP.exe) or it is with the FTP server running on the MVS.

Regards,
-Mat
SmartFTP


Do you have an ideas how I can get this to work,. Some Information. the MVS server uses a published public key and how do I tell the client to use that key when uploading. I was talking an IBM MVS expert and there saying my client is not being authenticated ebcause of the different keys. Do you have an idea how i do that with your software

#4 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 08 October 2006 - 03:39 AM

Hello ..

Try to set the client cert in your code. Please look at the following properties in the help:
CertName
CertStore
CertStoreLocation

These settings are controlled in the SmartFTP client in the Menu: Tools->Settings->Connection->SSL.

We set the properties to the following value:
CertName = current user. e.g "mb"
CertStore = "My" (you shouldn't have to change that)
CertStoreLocation = 1 (cert store location of the current user)

I would start with setting the CertName property to the current user your executable is running under.

Or get the newest version of the SmartFTP FTP Library from:
http://www.smartftp....ftplib/download
It automatically sets the CertName to the current user name.

Regards,
-Mat
SmartFTP

#5 kernregister

kernregister
  • Members
  • 7 posts

Posted 08 October 2006 - 04:19 AM

Hello ..

Try to set the client cert in your code. Please look at the following properties in the help:
CertName
CertStore
CertStoreLocation

These settings are controlled in the SmartFTP client in the Menu: Tools->Settings->Connection->SSL.

We set the properties to the following value:
CertName = current user. e.g "mb"
CertStore = "My" (you shouldn't have to change that)
CertStoreLocation = 1 (cert store location of the current user)

I would start with setting the CertName property to the current user your executable is running under.

Or get the newest version of the SmartFTP FTP Library from:
http://www.smartftp....ftplib/download
It automatically sets the CertName to the current user name.

Regards,
-Mat
SmartFTP



hello,,

well today we finally have got passed a mile stone Lucky is one of our software engineers and after almost a week of trouble shooting today he finally fixed it through code he added events becasue the connection was timming out "getting disconnected" so far we are connecting but we still trying to ge tthe file right on the server it saying something liek that the heading is incorrect... but we will post a log today....


Also what are tech support hours we just need an idea to know whe nto expect replies??? are you US based??

#6 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 08 October 2006 - 05:04 AM

Hello ...

Our response time is 1 business day. But as you see from the previous replies we usually reply within less time and even during the weekend!
If you are interested in contract work please contact me and I will tell you about our conditions.

Regards,
SmartFTP

#7 Lucky Ncube

Lucky Ncube
  • Members
  • 13 posts

Posted 17 November 2006 - 07:18 AM

This problem was solved by using the the connectionMTA Object
not the the other one

Hello ..

Try to set the client cert in your code. Please look at the following properties in the help:
CertName
CertStore
CertStoreLocation

These settings are controlled in the SmartFTP client in the Menu: Tools->Settings->Connection->SSL.

We set the properties to the following value:
CertName = current user. e.g "mb"
CertStore = "My" (you shouldn't have to change that)
CertStoreLocation = 1 (cert store location of the current user)

I would start with setting the CertName property to the current user your executable is running under.

Or get the newest version of the SmartFTP FTP Library from:
http://www.smartftp....ftplib/download
It automatically sets the CertName to the current user name.

Regards,
-Mat
SmartFTP



#8 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 17 November 2006 - 11:55 AM

I'm glad you have found a solution. According to our knowledge the FTPConnectionMTA class is not suitable for release builds under VB6.

Regards,
-Mat




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users