Jump to content


Photo

Server Timeout and Internal Error


  • Please log in to reply
3 replies to this topic

#1 Lucky Ncube

Lucky Ncube
  • Members
  • 13 posts

Posted 01 October 2006 - 06:50 PM

Hi.

I thought I had sorted my problems my FTP has been running for a few days but sudently I am getting the error 10 Internal Error or 4 Server timeout. The log is show below. PLEASE HELP, I AM RUNNING BEHIND WITH A CUSTOMER PROJECT, AND I MADE THEM BUY SMARTFTP
[20061001 18:42:29] SmartFTP FTP Library v1.5.8.30
[20061001 18:42:29] Resolving host name "vwix.dhs.ca.gov"
[20061001 18:42:29] Connecting to 134.186.44.120 Port: 21
[20061001 18:42:29] Connected to vwix.dhs.ca.gov.
[20061001 18:42:31] 220-FTPSECRE IBM FTP CS V1R4 at MVSSY1.TEALE.CA.GOV, 18:42:14 on 2006-10-01.
[20061001 18:42:34] 220 Connection will not timeout.
[20061001 18:42:34] AUTH TLS
[20061001 18:42:35] 234 Security environment established - ready for negotiation
[20061001 18:42:35] Connected. Exchanging encryption keys...
[20061001 18:42:37] Session Cipher: 128 bit RC4
[20061001 18:42:37] TLS encrypted session established.
[20061001 18:42:37] PBSZ 0
[20061001 18:42:37] 200 Protection buffer size accepted
[20061001 18:42:37] USER ******
[20061001 18:42:38] 331 Send password please.
[20061001 18:42:38] PASS ******
[20061001 18:42:42] 230 HD02461B is logged on. Working directory is "HD02461B.".
[20061001 18:42:42] SYST
[20061001 18:42:48] 215 MVS is the operating system of this server. FTP Server is running on z/OS.
[20061001 18:42:48] Detected Server Type: MVS
[20061001 18:42:48] FEAT
[20061001 18:43:00] 211- Extensions supported
[20061001 18:43:01] SIZE
[20061001 18:43:01] AUTH TLS
[20061001 18:43:01] PBSZ
[20061001 18:43:01] PROT
[20061001 18:43:01] 211 End
[20061001 18:43:01] TYPE I
[20061001 18:43:02] 200 Representation type is Image
[20061001 18:43:02] REST 0
[20061001 18:43:05] 504 Restart not allowed with active security mechanism
[20061001 18:43:05] PWD
[20061001 18:43:12] 257 "'HD02461B.'" is working directory.
[20061001 18:43:12] SITE LRECL=11 BLOCKSIZE=4400 RECFM=FB
[20061001 18:43:24] 200 SITE command was accepted
[20061001 18:43:24] LIST
[20061001 18:43:24] 550 No data sets found.
[20061001 18:43:24] TYPE A
[20061001 18:43:25] 200 Representation type is Ascii NonPrint
[20061001 18:43:25] Client closed the connection.
[20061001 18:46:01] SmartFTP FTP Library v1.5.8.30
[20061001 18:46:01] Resolving host name "vwix.dhs.ca.gov"
[20061001 18:46:01] Connecting to 134.186.44.120 Port: 21
[20061001 18:46:01] Connected to vwix.dhs.ca.gov.
[20061001 18:47:01] Timeout (60s).
[20061001 18:47:01] 5
[20061001 18:47:01] Client closed the connection.

#2 mb

mb

    Developer

  • Administrators
  • 11520 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 02 October 2006 - 02:08 AM

Internal Error
=========
I assume the internal error you mentioned happend here:
[20061001 18:43:25] 200 Representation type is Ascii NonPrint
[20061001 18:43:25] Client closed the connection.

Can you reproduce it or does it happen randomly?

Reconnect
=======
How do you reconnect to the server after the connection failed? We recommend to create a new FTPConnectionMTA/STA object instead of reusing the existing object.

Regards,
-Mat

#3 Lucky Ncube

Lucky Ncube
  • Members
  • 13 posts

Posted 02 October 2006 - 04:41 AM

Internal Error
=========
I assume the internal error you mentioned happend here:
[20061001 18:43:25] 200 Representation type is Ascii NonPrint
[20061001 18:43:25] Client closed the connection.

Can you reproduce it or does it happen randomly?

Reconnect
=======
How do you reconnect to the server after the connection failed? We recommend to create a new FTPConnectionMTA/STA object instead of reusing the existing object.

Regards,
-Mat


here is the code that I wrote maybe you can tell me where I am going wrong
Dim intI As Integer
Dim errs As enumError
Dim strRemFolder As String
	Dim strList
	Dim FtpErr

	'get the licence key
	Set objGlobal = CreateObject("sfFTPLib.Global")
	If Not objGlobal.LoadLicenseKeyFile(App.Path & "\smartFTp.txt") Then
		MsgBox ("Failed to verify license key. Copy the SmartFTP.txt File to the default apth ofthe application")
		AddMessage "-----------------------------------------------------------------------------"
		Exit Function
	End If
	'Start setting FTP Parameters
	Set objFTP = New sfFTPLib.FTPConnectionSTA
	objFTP.Host = ServerName
	objFTP.Port = TCPPort
	objFTP.Protocol = ftpProtocolSSLExplicit
	objFTP.Username = Username
	objFTP.Password = Password
	objFTP.Passive = True
	objFTP.DataProtection = ftpDataProtectionPrivate
	objFTP.LogFile = App.Path & "\SFTP.log"
	'Finish setting up FTP Parameters and connect to the remote server
	AddMessage "Connecting to server Please wait ..."
	If objFTP.Connect = sfFTPLib.enumError.ftpErrorSuccess Then
		 'send site command
		 objFTP.Command "SITE LRECL=11 BLOCKSIZE=4400 RECFM=FB"
		 AddMessage "Connected  to " & ServerName & "."
		 AddMessage "--------------------------------------------------------"
		'set data transfer mode
		  objFTP.DataTransferType = ftpDataTransferTypeASCII
		  
		 
		 
		 'Show the working directory
		 AddMessage "Current Directory : " & objFTP.WorkingDirectory
		  'Upload the file that is being currently processed
			errs = objFTP.UploadFile(strFileName, "'" & RemoteFile(strFileName, objFTP.WorkingDirectory) & "'", 0, 0)
			If errs = ftpErrorSuccess Then
				LogUpload strVNum, strFileName
				UploadVendorFiles = True
			Else
				AddMessage "Error: " & getErrors(errs)
				AddMessage "-----------------------------------------"
				AddMessage "Connection Closing please wait .."
				objFTP.Close
				UploadVendorFiles = False
				
			 End If
	Else
		AddMessage "Connect() failed. Error = " & getErrors(objFTP.LastError)
		AddMessage "--------------------------------------------------------"
		UploadVendorFiles = False
		  Exit Function
   End If
	'Close all FTP session
	Set objFTP = Nothing


#4 mb

mb

    Developer

  • Administrators
  • 11520 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 02 October 2006 - 07:57 AM

The code looks fine. Nothing wrong with it. The problem seems to be more with the connection to the FTP server.

Regards,
SmartFTP




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users