Jump to content


Photo

Option to ignore hidden files/folders when uploading


  • Please log in to reply
27 replies to this topic

#21 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 08 October 2009 - 06:16 PM

No there is no setting to override this. But if you use a view filter you can prevent the .svn files from being displayed and therefore they cannot be selected ;-)

#22 cpsubrian

cpsubrian
  • Members
  • 6 posts

Posted 21 May 2010 - 08:45 PM

I am trying to filter .svn folders and I cannot find any combination of filter settings that actually work. Let me know what info I can provide to help debug. Let me repeat... no settings that I use filter anything at all. Direct file names, folder names, Regex patterns, etc. I am transferring things by dragging a parent folder from local to remote, then clicking "Merge" and then "Replace". Any items inside that folder than match exclude filters are transferred anyway.

#23 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 21 May 2010 - 09:37 PM

Click on "Use Automatic Rules" in the file exist dialog.

#24 cpsubrian

cpsubrian
  • Members
  • 6 posts

Posted 24 May 2010 - 12:32 AM

Is that the only way? What about the first time I upload a folder. I get no prompt in that case.

#25 cpsubrian

cpsubrian
  • Members
  • 6 posts

Posted 24 May 2010 - 12:35 AM

Also, just tried the "User Automatic Rules" and it still transferred the .svn folders.

#26 cpsubrian

cpsubrian
  • Members
  • 6 posts

Posted 24 May 2010 - 12:47 AM

Ok, I tried a whole bunch of permutations of filters and I did finally get it to work. It appears like the "Any" choice does not work. When I set up a RegExp and set it to "Folder(name)", it finally worked mostly as I would expect.

Might be a bug with the "Any", or I might be misunderstanding what you mean by "Any".

#27 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 24 May 2010 - 12:50 AM

Unfortunately you cannot override this setting. But yes we agree that it is confusing somehow but we just didn't have the resources (yet) to implement a better solution.

#28 cwd

cwd
  • Members
  • 6 posts

Posted 05 January 2011 - 03:51 PM

Okay, I give up. I couldn't get the favorites filter to work, nor filtering on a specific website, using all the suggestions mentioned above. I even tried to filter the local view, which actually worked, but it only does the current folder - so any subfolders still contain the files I'm trying to filter. For now, I'm switching over to FileZilla. I'll gladly return to SmartFTP once this has been resolved.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users